Start with audio and video muted doesn't work

I have set the value of startwithVideoMuted:true and startWithAudioMuted:true in both config.js and settings-config.js but its not working

config.js is regenerated after every container boot. Are you certain those options are in the file? Check with a web browser.

how can I check with browser?

That’s easy: [URL]/config.js
:slight_smile:

In browser those options are in the file and set to true

 // Every participant after the Nth will start audio muted.
     //startAudioMuted: 10,

    // Start calls with audio muted. Unlike the option above, this one is only
    // applied locally. FIXME: having these 2 options is confusing.
     startWithAudioMuted: true,

// Every participant after the Nth will start video muted.
    //startVideoMuted: 10,

    // Start calls with video muted. Unlike the option above, this one is only
    // applied locally. FIXME: having these 2 options is confusing.
    startWithVideoMuted: true,

this code is from my browser

Ah, I think you’ve run into an existing issue: startWithAudioMuted and startWithVideoMuted not as expected from config · Issue #8144 · jitsi/jitsi-meet · GitHub

Enabling the prejoin page should help.

1 Like

ok, thanks

For me the problem still exists with prejoin page.
I have the following settings:
startWithAudioMuted: true, startWithVideoMuted: true, prejoinPageEnabled: true
What am i doing wrong?

I don’t think you are doing anything inherently wrong, we have a bug with those settings because they are read too early, and the prejoin page helps because it allows users to mute themselves before joining.

All right. Thank´s for the quick response.