Stable/jitsi-meet 3344 - Android SDK - React native version mismatch - 0.51.0 & 0.55.0


#1

I Downloaded the latest release of Android SDK (stable/jitsi-meet 3344) from the Git repo and unzip it, to make some view customization and I could see the reactive native version as 0.55.0 in package,json

But in the pre-build SDK in Maven repository https://github.com/jitsi/jitsi-maven-repository/raw/master/releases , it seems like the react native version is 0.51.0.

I’m getting error as react native version mismatch error while compiling . Please help.


#2

We haven’t released Maven artifacts of Jitsi Meet SDK for Android in a long while. It sounds about right that the last released Maven artifact utilizes react-native 0.51.

We’re with react-native 0.55 in master so I suppose it’s possible that the latest stable of Jitsi Meet for Web and desktop has that version in its package.json.

Anyway, you shouldn’t be comparing stable releases of Jitsi Meet for Web desktop with releases of Jitsi Meet app or SDK for Android and iOS.


#3

@lmarinov ,

Thanks for your reply!

However my issue is still exist.

Below is what I did ,

I changed some of the code, in react native like Toolbox buttons, as I needed only 3 button and some stuff like that and tested the app by running react-native run-android and it worked fine, then I generated the aar file for sdk and other dependencies by following the instructions given at,

http://github.com/jitsi/jitsi-meet/tree/master/android

and did aseemble Release and publish using gradle and hosted those at,

https://github.com/JasifShameem/jitsi-maven-repository

everything compiled fine and when I ran the app on the device, getting this error.

But everything works fine when I run it using react-native run-android

08-23 20:15:55.765 23319-23364/com.death.demo E/ReactNativeJS: Can’t find variable: Symbol
08-23 20:15:55.773 23319-23364/com.death.demo E/ReactNativeJS: Module AppRegistry is not a registered callable module (calling runApplication)
08-23 20:15:55.800 23319-23365/com.death.demo E/AndroidRuntime: FATAL EXCEPTION: mqt_native_modules
Process: com.death.demo, PID: 23319
com.facebook.react.common.JavascriptException: Can’t find variable: Symbol, stack:

at

com.facebook.react.modules.core.ExceptionsManagerModule.showOrThrowError(ExceptionsManagerModule.java:54)
at com.facebook.react.modules.core.ExceptionsManagerModule.reportFatalException(ExceptionsManagerModule.java:38)
at java.lang.reflect.Method.invoke(Native Method)
at com.facebook.react.bridge.JavaMethodWrapper.invoke(JavaMethodWrapper.java:372)
at com.facebook.react.bridge.JavaModuleWrapper.invoke(JavaModuleWrapper.java:160)
at com.facebook.react.bridge.queue.NativeRunnable.run(Native Method)
at android.os.Handler.handleCallback(Handler.java:790)
at android.os.Handler.dispatchMessage(Handler.java:99)
at com.facebook.react.bridge.queue.MessageQueueThreadHandler.dispatchMessage(MessageQueueThreadHandler.java:29)
at android.os.Looper.loop(Looper.java:164)
at com.facebook.react.bridge.queue.MessageQueueThreadImpl$3.run(MessageQueueThreadImpl.java:192)
at java.lang.Thread.run(Thread.java:764)

It may be because of the android Maven artifacts does not used the new version of JSCore .(I’m not sure)

How can we resolve this issue?
When can we expect that the jsc-android to be released as maven-artifact ??