Sporadic Problems with Videobridge

Hi everyone,

I seem to be having frequent problems with Videobridge that recurs sporadically.

Last week, I got stuck in a loop where everyone who logged in to the call kept getting disconnected immediately when more than one person joined. I saw on the forums that this was because of a problem with Videobridge, so I restarted videobridge and it worked again.

The same problem happened again on Sunday. And it worked fine when I restarted Videobridge. It happened again today, and got resolved partially when I restarted videobridge. After I restarted videobridge, it worked and let up to five people join the call. But the sixth person kept getting kicked out. We ended up abandoning the call.

I am running Jitsi on Debian 9 and Nginx. I have updated everything on the server, including Videobridge to Videobridge2. Could someone advise me what the problem is, and how I can get Jitsi to work consistently?

Best wishes,

First you need to figure out why is this happening. If you still have the logs, check jicofo logs and see when jvb was considered unhealthy, check jvb logs at that time. What is the problem you see?

Hi Damian,

Thanks for your response.

I had a look at the Jicofo logs, and from about 19:18 last night (BST) Jicofo failed to select the initial bridge and found no bridge available.

I checked the JVB log at the corresponding time and saw that there was no entry for the time. The JVB log ended at 10:52 am BST on 13 Apr. And then there was a gab between 10:52 on 13 Apr and the next entry on the JVB log on 14 Apr at 19:20 when I had restarted JVB:

2020-04-13 10:52:10.077 INFO: [17] Videobridge.createConference#326: create_conf, id=8e7664cb4421df55 gid=null logging=false
2020-04-13 10:52:10.114 INFO: [17] Health.doRun#294: Performed a successful health check in 41ms. Sticky failure: false
2020-04-14 19:20:24.713 INFO: [1] NewConfig$1.invoke#88: Loaded NewConfig with origin: merge of system properties,system properties,reference.conf @ jar:file:/usr/share/jitsi-videobridge/jitsi-videobridge.jar!/reference.conf: 1,reference.conf @ jar:file:/usr/share/jitsi-videobridge/lib/jitsi-media-transform-1.0-139-g33e0a49.jar!/reference.conf: 1

I think the problem is that JVB stopped running, although I can’t seem to figure out why, and the JVB log does not have any entries for that time period from 10:52 on 13 Apr. Until that time, JVB seemed healthy.

After I restarted JVB on the evening of 14 Apr, we tried to host the call, and we managed to get five people to connect but the sixth one kept trying and got disconnected from the call whenever they entered the room. We abandoned the call at 19:22.

I cannot seem to upload a copy of the log for this time because I am a new user. I would past it here but it’s too long. How would you like me to post it here?


Are you monitoring servers memory? Do you see an increase? While you don’t use jvb? What is the memory available to jvb?

Hi Damian,

Thanks for the reply.

I was monitoring the server’s memory, and the memory use peaked at 40-50% and CPU usage around 60-70%. Normally, when JVB is not in use, the server runs on around 2% of its memory. The server has 1 GB of memory. I have the server configured to send me alerts if it exceeds memory or CPU capacity, and I got none of those alerts when using it.