Sorry! You are not allowed to be here :( using JWT after new update (06-oct-2022)

I tried that, but didn’t worked. looks like that external jwt is not allowing to set affiliation.
Then only option remaining for me is to not attach token for guests.

Actually, I was trying to put security that users/guests should join meeting through our web only not directly on jitsi platform (self-hosted). so we could limit spammers. Because we could allow to join meeting only to registered users on website. Even if they have jitsi meeting link they must need to login on our backend website and join meeting from there.

Thank you.

One issue if i only use token_affiliation and not external jwt.
If i set member or none then guest user is still able to access recording and streaming only, they don’t have moderator rights.

Is there any thing i should limit them to not see streaming and recording option?

Thank you.

I forgot to say the second line. There should be the following line:

local timer = require "util.timer"

after the following line:

1 Like

They don’t access in my test setup

After adding timer, it worked. But still same issue. Owner/moderator works well.
But for member they don’t have permission for moderator but have access to recording and streaming.
I just modified things that you suggested. am I doing anything wrong?

Thank you.

  • Do you disable these features in the token for members?

  • Can you share your jicofo.conf?

  • Can you try the member in a private browser window while the moderator in a normal browser session.

1 Like

I didn’t, but i think it should work, because previously i disabled them in jwt. hopefully it should work now.

Yes i tried that. but i’ll test above by disabling featured in token for members.

Thank you for all of your help. It really helped me to understand all this. :heart_eyes:

1 Like