Some questions regarding cyrillic characters and Java's CPU usage when p2p is disabled

Hello.

I’ve installed following the official site’s guide (quick install -stable- +nginx)

I’ve got some questions

  1. How can I enable Cyrillic characters and dashes so that I could use them when naming jitsi’s channels?

  2. I don’t have a turn server running, and I had some problems with screen sharing and connectivity (2 users max), so I disabled p2p and it started working fine, however, CPU usage(jvb) skyrocketed.

2 users, 1 screen share, 1 webcam active =~17- 20% CPU usage according to “top” (java). It’s not the best VPS (4 vcores 8GB RAM, 200GB SSD) but it’s WAY too much compared to nextcloud talk or bigbluebutton CPU usage. If I add 10+ users it gets VERY CPU heavy.

I added to “2 users, 1 screen share, 1 webcam active” just 10 more participants (no sharing, no webcams, just opening several tabs) and Java’s CPU usage increased to 70-80+%

Is this supposed to happen?

  1. Is a secure domain guide on the github still relevant?

This is already the case for unstable.

Not sure about that, definitely not normal … Can you disable TCP Harvester


And report how it goes.

Should it be added to the “config” file in /etc/jitsi/videobridge/?

Where should I put it? Just copy-paste " org.jitsi.videobridge.DISABLE_TCP_HARVESTER=true" to the end of the file?

PS
or should it go into “sip-communicator.properties” in the same folder? The problem is… after I restart (/etc/init.d/jicofo restart && /etc/init.d/jitsi-videobridge restart && /etc/init.d/prosody restart) the file gets deleted and I only have a .bak file left (a backup I made) It’s the same with sip-communicator.properties in jicofo folder.

PS to disable p2p I need to set “enabled: false,” instead of “enabled: true,” and that’s all, right?

Yes, you should put it there.

That is strange, I had never seen that. How did you install?

Yes.

Following this mini-guide

I installed nginx first obviously.

How can I troubleshoot this behaviour?

I’ve just tried it again, I renamed sip-communicator.properties.bak to sip-communicator.properties, created a .bak file then restarted jitsi (all 3 components) and the file disappeared yet again

Thanx

Which one disappears the bak file or the original? Maybe I misunderstood you.

The original. The .bak file doesn’t get deleted.

meet’s and jvb’s config files don’t get deleted.

PS I’ve installed the unstable version

Update

  1. I’ve conducted a small experiment.
  • recreated sip-communicator.properties
  • deleted sip-communicator.properties.bak
  • restarted jitsi

sip-communicator.properties didn’t get deleted.

The original sip-communicator.properties files get deleted only if there is a .bak file in the same folder.

I disabled harvester.

1 user + webcam
+
1 user +webcam

26-30+% CPU java usage

So you have 4 cores, so this 26 is out of 400, you know that right?
You can take a look at top and it should be something like %Cpu(s): 6.5 us, in the case above.

Yeah, I sure do :wink:

It still seems kinda high though compared to the mentioned above alternatives :wink:

With 21 users (webcams disabled) watching 1 screenshare it was pretty noticeable.(overall load)

I guess it’s coz of Java.Most if not all apps i used written in java were quite CPU hungry

I’ve got a question though…

Do I need a turn server for users behind restrictive firewallls to be able to connect and stuff or jvb will do just fine?

Thanx

Recommended setup is to have a turnserver for restrictive firewalls.

I see. I gotta ask though. Recommended in what way? As in " sometimes even jvb won’t be able to make it work" or “a turn server reduces the load on jvb so we recommend running one, but other than that, jvb would still work for everyone”?

Cheers

JVB supports a pseudo ssl tcp, some google thing … which sometimes cannot trick firewalls, where coturn support a true https connection which will pass those firewalls. And jvb support for TCP is not great … so you better disable it and use coturn.

I see. I guess we’ll have to get a coturn server then.

Thanx.

PS When you have some time I hope you’ll investigate the bug with sip-communicator.properties and .bak extension. There is absolutely no reason why a software should delete its own config files upon restart if this config file has a backup located in the same folder. =)

There is some backup mechanism in the configuration service, and I suppose there is the problem of creating the new file because of permissions … So this is known behavior and is nothing to worry about, its just a .bak file triggers this behavior which is not supposed to be used server side.
The mechanism is to try fixing a problem with loosing config because of writing rapidly in the file, but here file is read-only, so nothing to worry about.

Well, it’s just that I’ll have to save a backup into another folder so as not to trigger the original file deletion, and its kinda inconvenient tbh.=) But I’ll get used to it I guess

Just use another extension, like .old or .orig :slight_smile:

lol how silly of me… of course…

  1. There is a small issue with Cyrillic names

When I name my channel “ClinicalPsychology” , jitsi shows it as “Clinical Psychology”

When I name my channel “КлиническаяПсихология”, jitsi shows it as “КлиническаяПсихология”, not “Клиническая Психология”

Is there a way to fix it on my side?

  1. For some reason when using Cyrillic characters some words\combinations do not work (I get 404 error)

Examples:

https://site.xyz/собака works

https://site.xyz/СобакаНаСене works

https://site.xyz/СобакаНаПрироде doesn’t work

https://site.xyz/КлиническаяНаркология doesn’t work

https://site.xyz/КлиническаяПсихология works fine

https://site.xyz/Неврология doesn’t work

They all work fine on the official Jitsi server though

This needs code change, this is just a UI thing splitting words. We use this function that does the work, seems it doesn’t work with cyrilic, if you find a fix for that you can create a PR.
https://lodash.com/docs/4.17.15#startCase

That is really strange and I do not see a big difference in nginx config between what we have in unstable and on meet.jit.si.
I will check it and will come back to you. What I see for now, that the problem comes from Cyrillic letter р.

It is an error in the nginx rule, you can apply the change by hand on your side to test. The problem are the two wrong chars.