Some questions about Jitsi meet features

Hi,

I’m testing Jitsi meet service, and I have some questions that I hope you can help me to solve,

1.- Do you have an approximate data of the number of video participants that are supported in a video conference room? (I know it depends on many different variables, but may be you have some statistics)

2.- Is it possible to asigne a “private room” to a user, in order he always use the same room to make his conferences?

3.- Is there any way to make scheduled conferences? This one is directly related with the question above, if you can use the same (funny) meeting URL I see the way to do this, but I’m not sure if it is supported,

4.- Is there any way to obtain the CDRs of the video calls, in order to know the number of participants involved in a meeting?

5.- Is it possible to connect H.323/SIP devices to the video room?

6.- Is there any limit of time on the video calls?

Thanks in advanced for your support,

Saludos,

Regards,
Mari

1 Like

Currently we normally limit the number of max participants in a room to 50, but we are currently working on big conferences which will support hundreds of participants.

Nope.

You can use whatever meeting name you want. We will soon deploy calendar integration where users will see there events/meetings on the welcompage.

For debugging and monitoring webrtc calls we use callstats.io, but this is external paid service. Also there are analytics, google analytics and option to plug your own analytics, so this can be easily implemented in custom deployments.

If you are asking about sip video there is this project https://github.com/jitsi/jibri/blob/master/doc/sip_gateway.md which can be used for that, but it is in early stage and lack documentation, but we had successfully used it for that. Who uses H.323 in 2018?

If you are asking about meet.jit.si, no. There is only limit for youtube streaming and the pstn calls.

2 Likes

Hi Damian,

Thanks a lot for your detailed responses.
You are doing a great work with this nice tool,

Saludos,

Regards,
Mari

Hi @damencho

is the limit configureable? if so how do i set it?

what is the current limit of time to youtube streaming ?

We are doing this using a prosody module on meet.jit.si.

This is also a setting we choose to do for meet.jit.si, as streaming costs money/machines up and doing this and meet.jit.si is a free service. The current limit is 1.5 hours, I think.

1 Like

which module? name? is it open source?

how do i configure this in my server?

1 Like

This had not been published in the open source project, I will add it in my todo list.

1 Like

thanks @damencho really appreciate the info :smiley:

1 Like

Hi @damencho,
any updates on publishing the limit max participants in a room module?

I will try to create the pr these days

1 Like

@Tanvir https://github.com/jitsi/jitsi-meet/pull/3589

1 Like

Hi @damencho,
Thank you so much for sharing it. I want to ask, how to enable this module? first I created the module in /user/share/jitsi-meet/prosody-plugins folder. then in the /etc/prosody/conf.d/my-domain.cfg.lua file added the following lines,

plugin_paths = { "/usr/share/jitsi-meet/prosody-plugins/" } 
VirtualHost "my.domain.com"
authentication = "internal_plain"
muc_max_occupants = 2
muc_access_whitelist = { "recorder.my.domain.com" }
modules_enabled = {
            "bosh";
            "pubsub";
            "ping"; -- Enable mod_ping
            "muc_max_occupants";
        }
.....
.....

now when I restart i see that module is loaded but nothing happens, when 3rd participant joins in the meeting. he doesn’t get max_limit_reached message. I am using latest jitsi-meet, jicofo and jvb from stable repo. only prosody I am using different Prosody trunk nightly build 747 (2017-02-19, 428d4abee723)

Am I missing something?

It is written in the module description: This module is configured under the muc component that is used for jitsi-meet
You are activeting it under the main virtual host, but you need to activate it under the muc component.

1 Like

thanks it worked!! really appreciate ur help :smile::smile::+1::v::vulcan_salute:

Hey there Tanvir. I’m new to Jitsi but have already moved very quickly on it given the good way that this project is managed. I have not been able to successfully configure this muc component though.

So far II have this

plugin_paths = { "/usr/share/jitsi-meet/prosody-plugins/" }

VirtualHost "vc.domain.com"
        authentication = "internal_plain"
        -- Properties below are modified by jitsi-meet-tokens package config
        -- and authentication above is switched to "token"
        --app_id="example_app_id"
        --app_secret="example_app_secret"
        -- Assign this host a certificate for TLS, otherwise it would use the one
        -- set in the global section (if any).
        -- Note that old-style SSL on port 5223 only supports one certificate, and will always
        -- use the global one.
        ssl = {
                key = "/etc/prosody/certs/vc.domain.com.key";
                certificate = "/etc/prosody/certs/vc.domain.com.crt";
        }
        -- we need bosh
        modules_enabled = {
            "bosh";
            "pubsub";
            "ping"; -- Enable mod_ping
            "muc_max_occupants";
 }



        c2s_require_encryption = false

Component "max_occupants.vc.domain.com" "muc"
        muc_max_occupants = 1
        muc_access_whitelist = { "recorder.vc.domain.com" }

Any help wold be greatly appreciated!
Cheers
George

That is a virtual host, not a muc component. What are you trying to do, and what is your problem, what errors do you see? Give more context.

Thanks @damencho The scenario is this:

  1. Candidate opens a unique link sent to him/her by the interviewer.

  2. Candidate goes into room and waits for the interviewer.

  3. Interviewer enters room and authenticates and both then participate in the videoconference

This is all working very well, but we cannot guarantee that the candidate will not pass the link on to someone else, so I would like to limit the number of participants in any one room, to two.

I don’t see any errors, I think my problem is that I don’t know where to configure the mod_muc_max_occupants module, which looks like it will do exactly what I need it to do!

I hope all of this make sense.

Hoping all are well during the pandemic :slightly_smiling_face:

Cheers
George

You just need to enable it in your prosody config under the conference.youdomain.com component and add:
muc_max_occupants = 3 to limit it to two participants.

Thx. Making progress but still not quite there. In /etc/prosody/conf.d/domain.com.cfg.lua , somethng like this?

....
Component "conference.domain.com" "muc"
storage = "none"
modules_enabled = { "muc_max_occupants" }
 muc_max_occupants = 2
.....

Sorry!

Cheers
George

Yes.

1 Like