[SOLVED with Debian Stretch] Unmet dependencies with Quick Install on fresh Ubuntu 18.04LTS (Bionic Beaver)


#1

Hi,

On a fresh Ubuntu 18.04LTS (Bionic Beaver) the Quick Install procedure always gives me the following error:

The following packages have unmet dependencies:
jitsi-meet : Depends: jitsi-videobridge (= 1104-1) but it is not installable
             Depends: jicofo (= 1.0-451-1) but it is not installable

Universe is activated:

deb http://ports.ubuntu.com/ubuntu-ports bionic universe
deb-src http://ports.ubuntu.com/ubuntu-ports bionic universe
deb http://ports.ubuntu.com/ubuntu-ports bionic-updates universe
deb-src http://ports.ubuntu.com/ubuntu-ports bionic-updates universe

And Java 8 is installed:

openjdk version "1.8.0_191"
OpenJDK Runtime Environment (build 1.8.0_191-8u191-b12-2ubuntu0.18.04.1-b12)
OpenJDK Client VM (build 25.191-b12, mixed mode)

It seems that it’s a recurrent problem, did anyone recently encountered (and hopefully solved) that problem ?

Thanks


#2

Have you checked this part from quick install:

?


#3

Yes, at least I think so, that’s why I gave these lines from /etc/apt/sources.list:

deb http://ports.ubuntu.com/ubuntu-ports bionic universe
deb-src http://ports.ubuntu.com/ubuntu-ports bionic universe
deb http://ports.ubuntu.com/ubuntu-ports bionic-updates universe
deb-src http://ports.ubuntu.com/ubuntu-ports bionic-updates universe

But maybe it’s not enough ?

Thanks


#4

Is there something non-standard in your bionic installation? What image did you use for installing it?


#5

I just created a VM with 18.04 and it works without a problem.
Why are you using http://ports.ubuntu.com isn’t this for arm or some other architecture that is non x86? Probably some of the packages that jitsi-meet depend on are not available on your architecture. We use x86_64 and it works fine.


#6

\o/
You’re perfectly right, I switched to a 2x86-64 instance and all the packages were found, thanks!

BTW, the install fails at this point, I’ll try some other configurations :slight_smile:

Setting up jitsi-meet-web-config (1.0.3186-1) ...
Generating a 4096 bit RSA private key
....................................................++
.....................................................................................................................................++
writing new private key to '/etc/jitsi/meet/meet.example.com.key'
-----
cp: cannot stat '/usr/share/doc/jitsi-meet-web-config/config.js': No such file or directory
dpkg: error processing package jitsi-meet-web-config (--configure):
 installed jitsi-meet-web-config package post-installation script subprocess returned error exit status 1

#7

There is a known issue that installation doesn’t work on a minimal ubuntu image, as it doesn’t allow writing in /usr/share/doc/.


#8

OK… after some unsuccessful attemps to deal with that, I finally changed to Debian Stretch, works perfectly with that sequence:

wget -qO - https://download.jitsi.org/jitsi-key.gpg.key | apt-key add -
sh -c "echo 'deb https://download.jitsi.org stable/' > /etc/apt/sources.list.d/jitsi-stable.list"
apt-get install apt-transport-https
apt-get -y update
apt-get -y install jitsi-meet

(just had to install apt-transport-https)

To be exhaustive, I used a START1-S instance on Scaleway.com, 2x86-64, 2Gb RAM, 50Gb SSD.

Thanks again, hope this will be of some help to others.

PS: To install a Letsencrypt certificate:

/usr/share/jitsi-meet/scripts/install-letsencrypt-cert.sh


#9

Those steps including the apt-transport-https tip are already available in quick install guide

And for running jicofo and jvb on the same machine we would recommend 8GB of RAM, you may hit some problems on more load.