[Solved] When URL is tapped, it must also show to open in Jitsi App - Idea

When a user taps any url, it shows which application a user wants to open - Just Once/ Always? Firefox, Chrome or any other… so it must display the Jitsi App also and the url is then pasted automatically in the “ENTER ROOM NAME” text input box.

Have you tested it with meet.jit.si links, it should work exactly that way. When you click a meet.jit.si link it you will enter in that meeting.
If you want your own deployment to be recognized you need to modify and deploy your own application, mobile team correct me if I’m wrong.

I tried…it enters with browsers …not with an app. App functionality should be there.

I don’t think so… when a link like https://meet.jit.si/abcdefg is tapped…the system will offer you to open link within the Jitsi Meet App - Just Once/Always. When app recognize this link “https://meet.jit.si” , this can be easily changed in the app by replacing our own deployed server dns. If the feature is enabled within the app, the link can be changed and same could be action with your own link.

This is not correct. You can do that by modifying the manifest https://github.com/jitsi/jitsi-meet/blob/master/android/app/src/main/AndroidManifest.xml#L30 and you cannot modify the manifest without deploying new app in the store and install it…

I have done that changes in manifest. As same as Jitsi App doesn’t open with click on link meet.jit.si, our app also doesn’t open by changing host there with click of the link if there. If this is the modification that allows the link to be opened directly into the APP, it doesn’t functioning on any device.

Maybe you need to modify and this: https://github.com/jitsi/jitsi-meet/blob/bf7b1c5cfc78a0211d8ee7c92095e9c1e77e6701/react/features/base/known-domains/reducer.js#L19

You say that once you do the manifest modification (leaving meet.jit.si) the App you are building and installing in android doesn’t recognize even meet.jit.si links?

If you download the Jitsi Meet App from Play Store, and if you have a link https://meet.jit.si/6667 then it will show only browsers option, not an jitsi app option to open with that link. I am 101% sure.

Now suppose if i have keep source code as it but only changed App name and host from meet.jit.si to mydomain.com then it will not open same https://mydomain.com/6667 the App as same as jitsi was not opening.

I have to Copy Url manually and Paste into the Input box to join.

Works here

That’s really strange … aaah now I have to put my R&D into it…might be some deeplinking issue. Here, none of my android device showing such option. Anyway thanks for confirmation. :slight_smile: