[Solved] Unable to find an available Jibri

I setup the jibri on machine say 192.168.0.11 and installed jitsi meet on bridged say 192.168.0.13 with FQDN teleconf… Now after setting up completely as per documentation and video , I am getting error while starting with jibri recording as jicofo log saying " Unable to find an available Jibri "

also i tried ping from both the machines on ip address and dns

I have configured correctly, despite being running on those config, I am still getting error.

Also there’ no log has been generated to Jibri machine till yet.

If there’s no log on the Jibri machine, then Jibri hasn’t started up correctly, or maybe the log directory isn’t writable by Jibri? I’d take a look at that and include Jicofo logs as well.

Which java version are you using on the jibri machine? Make sure it is java8.

@damencho I have recently changed to java 8 and set java 8 in auto mode…let me check n I update you.

Ok…it is now showing error connecting xmmp environment. The following address failed :5222 failed because address /122.161.193.203. Exception connection refused

I have now opened the port and this issue is resolved…however I am still getting Recording Unavailable error.
Jicofo again saying
Jicofo 2019-03-25 13:18:22.997 SEVERE: [139] org.jitsi.jicofo.recording.jibri.JibriSession.log() Unable to find an available Jibri, can’t start
Jicofo 2019-03-25 13:18:22.997 INFO: [139] org.jitsi.jicofo.recording.jibri.JibriRecorder.log() Failed to start a Jibri session, no Jibris available
Jicofo 2019-03-25 13:18:28.184 INFO: [36] org.jitsi.jicofo.ChatRoomRoleAndPresence.log() Chat room event ChatRoomMemberPresenceChangeEvent[type=MemberLeft

No error in Jibri Log now but still a problem exists…

If jibri would be called on jitsi system, it would start chromedriver and ffmpeg and reflect in the logs.

Include jicofo logs please.

@bbaldino
here’s the jicofo log

There’s not much there. Can you restart Jibri and Jicofo and try a call, then attach the Jibri and Jicofo logs?

@bbaldino
Yup for Jibri I am getting same error If I read it from PuTTY
2019-03-27 12:45:22.310 INFO: [1] org.jitsi.jibri.Main.main() Jibri run with args [–config, /etc/jitsi/jibri/config.json]
2019-03-27 12:45:22.335 INFO: [1] org.jitsi.jibri.Main.main() Using config file /etc/jitsi/jibri/config.json
2019-03-27 12:45:22.336 INFO: [1] org.jitsi.jibri.Main.main() Using port 3333 for internal HTTP API
2019-03-27 12:45:22.336 INFO: [1] org.jitsi.jibri.Main.main() Using port 2222 for the HTTP API
2019-03-27 12:45:24.155 INFO: [1] org.jitsi.jibri.Main.loadConfig() Parsed config:
JibriConfig(recordingDirectory=/tmp/recordings, enabledStatsD=true, finalizeRecordingScriptPath=/path/to/finalize_recording.sh, xmppEnvironments=[XmppEnvironmentConfig(name=prod environment, xmppServerHosts= 2019-03-27 12:45:25.717 WARNING: [1] org.glassfish.jersey.internal.inject.Providers.checkProviderRuntime() A provider org.jitsi.jibri.api.http.internal.InternalHttpApi registered in SERVER runtime does not implement any provider interfa
2019-03-27 12:45:26.512 INFO: [1] org.jitsi.jibri.api.xmpp.XmppApi.start() Connecting to xmpp environment on with config XmppEnvironmentConfig(name=prod environment, xmppServerHosts=$
2019-03-27 12:45:26.525 INFO: [1] org.jitsi.jibri.api.xmpp.XmppApi.start() The trustAllXmppCerts config is enabled for this domain, all XMPP server provided certificates will be accepted
2019-03-27 12:45:56.559 WARNING: [20] org.jivesoftware.smackx.ping.PingManager.pingServerIfNecessary() XMPPConnection was not authenticated
2019-03-27 12:45:57.006 SEVERE: [1] org.jitsi.jibri.api.xmpp.XmppApi.start() Error connecting to xmpp environment: org.jivesoftware.smack.SmackException$ConnectionException: The following addresses failed: ':5$
2019-03-27 12:45:57.077 WARNING: [1] org.glassfish.jersey.internal.inject.Providers.checkProviderRuntime() A provider org.jitsi.jibri.api.http.HttpApi registered in SERVER runtime does not implement any provider interfaces applicable in$

New jicofo log

Your jibri cannot connect to the xmpp server
ConnectionException: The following addresses failed: 'teleconf.yogdiagnostics.com:5

@damencho I already got it and noticed the same. Thank You :smile:

Actually You haven’t mentioned that there’s 5222 port need to be opened in the Documentation. So when you told me last time to open 5222, I first opened it on my router and then included in UFW. Now it is connected but the problem is

Can you upload the jibri log, but not paste them in the chat, cause they are truncated?

@damencho here are the logs…

Can send me your jibri config?
Or tell me what are the values of “xmpp_domain” and “room_jid_domain_string_to_strip_from_start”?

Yes…wait while send you config files.

For now xmpp domain is :

:expressionless:

Ohhhhh…my biggest mistake…

its’ " "

not

It has been started…:see_no_evil:

My apology!

@rishabhchd19 i am also getting " Unable to find an available Jibri " error , Please let me know what had you changed in config file,
Thanks

I am facing same error, Please assist.