[solved] Size build iOS SDK too big

Hi Everyone,

I have a problem with my build framework for the iOS SDK. My size JitsiMeet.framework is 140 MB and my WebRTC.framework is 980 MB. I was build like documentation said. I run this
xcodebuild -workspace ios/jitsi-meet.xcworkspace -scheme JitsiMeet -destination='generic/platform=iOS' -configuration Release archive

before I run xcodebuild my WebRTC.framework is 61 MB.

Can anyone explain why my framework size too big? Did I do something wrong?

That’s because bitcode is included for both frameworks.

You can strip the bitcode out and they’ll be back to normal sizes. Check what our SDK build script does: https://github.com/jitsi/jitsi-meet/blob/master/ios/scripts/release-sdk.sh

Hi @saghul, thanks for your response.

Nice, I try your solution and it’s work. My JitsiMeet.framework to normal size now. But WebRTC.framework still too big after success build SDK. My questions, Is it fine if I use version WebRTC.framework (size 61 MB) before building SDK to my app?

I try in my sample it’s fine.

61MB is about the right size. Note that it includes all 4 architectures (simulators included). You need to strip them when submitting your app for review.

How do I strip the architecture?

http://ikennd.ac/blog/2015/02/stripping-unwanted-architectures-from-dynamic-libraries-in-xcode/

Thank you, I will try soon