[SOLVED] OCTO issues in latest installation - April 17, 2021

My OCTO SplitBridgeSelectionStrategy was running perfectly well before I accidently updated the machine

Now meetings are scheduled on new jvb’s and what I expected was that participants get scheduled in different jvb’s from the same meeting which was happening earlier

Looking at commits for Jicofo, there was a recent one that mentions that Selection Strategy config must be set within JVB as well, otherwise it won’t work.

I am not sure what this means but it seems we need to set this SplitBridgeSelectionStrategy to JVB configs too. Could anyone confirm this?

@damencho can you help us with this ?

You have to explicitly enable Octo now in Jicofo. Earlier it was enabled by default. you can add the below config to jicofo.conf to enable octo.


octo {
      // Whether or not to use Octo. Note that when enabled, its use will be determined by
      // $jicofo.bridge.selection-strategy. There's a corresponding flag in the JVB and these
      // two MUST be in sync (otherwise bridges will crash because they won't know how to
      // deal with octo channels).
      enabled = true

      // An identifier of the Jicofo instance, used for the purpose of generating conference IDs unique across a set of
      // Jicofo instances. Valid values are [1, 65535]. The value 0 is used when none is explicitly configured.
      id = "1"
    }

For config, you can follow docker-jitsi-jicofo.conf

Check this commit to compare the before and after changes.

1 Like

Okaye, Ill try this. OCTO was enabled earlier but I see the new ID = 1 setting. I’ll post here the status

Are you still using sip-communicator file for your most of the config?

@metadata - for videobridges, jicofo yes.

Whats the alternate option ?

Btw, this is for the vanilla installation. I couldnt figure out octo for docker so

no issues. I didn’t know that vanilla installations still using sip-communicator file for most of the config. This is not the case in docker installation.

Is adding octo config to jicofo.conf file worked?

@metadata I think this is working. let me re-verify it with other clients

@metadata this worked on my dev instance, let me check it with my public instance.

Meanwhile, you have any idea how do I enable lobby in my vanilla installation ? I am somehow not able to see it. All the packages are latest

That’s Great.

Sorry I haven’t tried Lobby for a while now even on docker so I can’t help you with Lobby. But there a re few tutorial available, you can follow them.

Lobby is enabled by default, in current stable(also a version before that). Needs prosody-11

@tusharsonawane
@metadata

Does the octo have to be added to both jicofo config and jvb configs, or just jicofo only?
Thanks

I have added for both. worked for me

Yes, You have to enable Octo for both jicofo and jvb.

No luck, still doesn’t work after adding octo {enabled = true id = “1”} to both jicofo.conf and
octo {enabled = true} to jvb.conf
Rest of my config is here
( fyi I have never got it to work…)
Thanks

Where is the config?

sorry it is in here

Jitsimeet config

deploymentInfo: {

    region: "region1",
      userRegion: "region1"
},

testing: {

        octo: {
            probability: 1
    }

}

Nginx config

location ~ ^/colibri-ws/jitsimeet/(.*) {
proxy_pass http://127.0.0.1::9090/colibri-ws/jitsimeet/$1$is_args$args;
proxy_http_version 1.1;
proxy_set_header Upgrade $http_upgrade;
proxy_set_header Connection “upgrade”;
tcp_nodelay on;
}

location ~ ^/colibri-ws/bridge3/(.*) {
    proxy_pass http://<Public IP>:9090/colibri-ws/bridge3/$1$is_args$args;
    proxy_http_version 1.1;
    proxy_set_header Upgrade $http_upgrade;
    proxy_set_header Connection "upgrade";
    tcp_nodelay on;
}

JVB sip-communicator.properties.octo on server 1

Additional values for octo

org.jitsi.videobridge.octo.BIND_ADDRESS=127.0.0.1
org.jitsi.videobridge.octo.PUBLIC_ADDRESS=
org.jitsi.videobridge.octo.BIND_PORT=4096
org.jitsi.videobridge.REGION=region1

JVB sip-communicator.properties.octo on server 2
Additional values for octo

org.jitsi.videobridge.octo.BIND_ADDRESS=127.0.0.1
org.jitsi.videobridge.octo.PUBLIC_ADDRESS=
org.jitsi.videobridge.octo.BIND_PORT=4096
org.jitsi.videobridge.REGION=region1

Jicofo sip-communicator.properties

org.jitsi.jicofo.BRIDGE_MUC=JvbBrewery@internal.auth.<my_domain>
org.jitsi.jicofo.auth.URL=XMPP:jms1.univy.io
org.jitsi.jicofo.auth.DISABLE_AUTOLOGIN=true
org.jitsi.jicofo.jibri.BREWERY=JibriBrewery@internal.auth.<my_domain>
org.jitsi.jicofo.jibri.PENDING_TIMEOUT=90
org.jitsi.jicofo.HEALTH_CHECK_INTERVAL=-1

org.jitsi.jicofo.BridgeSelector.BRIDGE_SELECTION_STRATEGY=SplitBridgeSelectionStrategy

jicofo.conf

jicofo {
octo {
enabled = true
}
}

Version information

Prosody Version 11.7
ii jitsi-meet 2.0.5142-1 all WebRTC JavaScript video conferences
ii jitsi-meet-prosody 1.0.4466-1 all Prosody configuration for Jitsi Meet
ii jitsi-meet-tokens 1.0.4466-1 all Prosody token authentication plugin for Jitsi Meet
ii jitsi-meet-turnserver 1.0.4466-1 all Configures coturn to be used with Jitsi Meet
ii jitsi-meet-web 1.0.4466-1 all WebRTC JavaScript video conferences
ii jitsi-meet-web-config 1.0.4466-1 all Configuration for web serving of Jitsi Meet
ii jitsi-videobridge2 2.1-376-g9f12bfe2-1 all WebRTC compatible Selective Forwarding Unit (SFU)

Firewall rule added to both
4096/udp ALLOW Anywhere
4096/udp (v6) ALLOW Anywhere (v6)

JVB on server 1
[Tue Apr 20 12:48:02 BST 2021] INFO Added new videobridge: Bridge[jid=jvbbrewery@internal.auth./fa33b939-66f3-4d84-8643-8e4f63581e98, relayId=<public_ip>:4096, region=region1, stress=0.00]

JVB on server 2
[Tue Apr 20 12:48:59 BST 2021] INFO Added new videobridge: Bridge[jid=jvbbrewery@internal.auth./bridge3, relayId=<public_ip>:4096, region=region1, stress=0.00]

Jicofo log is in here

Pastebin

[Tue Apr 20 12:50:22 BST 2021] INFO Focus request for room: @conference. -…

Pastebin.com is the number one paste tool since 2002. Pastebin is a website where you can store text online for a set period of time.

@metadata
@damencho
@tusharsonawane

Any ideas?