[SOLVED] NAT Problems

Hello,

ive installed my Jitsi Server behind NAT.
When i dont set anything from the NAT advanced config, i can start a conference but withoud Audio/Video.

When i add my local and public IP to the config as described.
And than a secod member is joining the Conference everyone is getting the message “Something went wrong” (see Screenshot)

Anyone knows what to do now ?

I have that aswell, i tried everything, sometimes its working sometimes not,
with Chrome, Firefox, APP on IOS and IPv4 / IPv6 …
Flapping …

Check js console logs, check jvb logs on startup.

My js console log shows:

Logger.js:154 2020-03-25T07:03:55.323Z [conference.js] <z._onConferenceFailed>: CONFERENCE FAILED: conference.videobridgeNotAvailable

I think Port 10000 could be the Problem, i cant even telnet it from localhost. Always says “Connection Refused” but its a fresh Ubuntu install, without a firewall enabled.

netstat says Port 10000 is only listening on udp6:

udp6       0      0 192.168.19X.XXX:10000     :::*

Solved:

ive dísabled the option:

org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS=<Local.IP.Address>

Now everything it working fine.

1 Like