[SOLVED] Lobby - Impossible to get the Lobby enabled

SOLVED : i finally did a complete reinstall of my VPS, not an apt purge etc…
and i get my lobby on the anonymous state, i will try now to enable internal_hashed.
Edit 2 : It works now !

Hello,
After digging all the discourse forum i can’t make Lobby to work.
I just done a clean install of Jitsi-Meet with 2.1 and Prosody at 0.11.7 and i still don’t get the Lobby Switch in the Shield icon.
Before i used internal_plan, on the clean install it’s on anonymous…
Here is my .lua file :
plugin_paths = { “/usr/share/jitsi-meet/prosody-plugins/” }

    -- domain mapper options, must at least have domain base set to use the mapper
    muc_mapper_domain_base = "SUB.DOMAIN.COM";

    turncredentials_secret = "3em3rUasz1DWkzcS";

    turncredentials = {
      { type = "stun", host = "SUB.DOMAIN.COM", port = "3478" },
      { type = "turn", host = "SUB.DOMAIN.COM", port = "3478", transport = "udp" },
      { type = "turns", host = "SUB.DOMAIN.COM", port = "5349", transport = "tcp" }
    };

    cross_domain_bosh = false;
    consider_bosh_secure = true;
    -- https_ports = { }; -- Remove this line to prevent listening on port 5284

    -- https://ssl-config.mozilla.org/#server=haproxy&version=2.1&config=intermediate&openssl=1.1.0g&guideline=5.4
    ssl = {
      protocol = "tlsv1_2+";
      ciphers = "ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-CHACHA20-POLY1305:ECDHE-RSA-CHACHA20-POLY1305:DHE-RSA-AES128-GCM-SHA256:DHE-RSA-AES256-GCM-SHA384"
    }

    VirtualHost "SUB.DOMAIN.COM"
            -- enabled = false -- Remove this line to enable this host
            authentication = "anonymous"
            -- Properties below are modified by jitsi-meet-tokens package config
            -- and authentication above is switched to "token"
            --app_id="example_app_id"
            --app_secret="example_app_secret"
            -- Assign this host a certificate for TLS, otherwise it would use the one
            -- set in the global section (if any).
            -- Note that old-style SSL on port 5223 only supports one certificate, and will always
            -- use the global one.
            ssl = {
                    key = "/etc/prosody/certs/SUB.DOMAIN.COM.key";
                    certificate = "/etc/prosody/certs/SUB.DOMAIN.COM.crt";
            }
            speakerstats_component = "speakerstats.SUB.DOMAIN.COM"
            conference_duration_component = "conferenceduration.SUB.DOMAIN.COM"
            -- we need bosh
            modules_enabled = {
                "bosh";
                "pubsub";
                "ping"; -- Enable mod_ping
                "speakerstats";
                "turncredentials";
                "conference_duration";
                "muc_lobby_rooms";
            }
            c2s_require_encryption = false
            lobby_muc = "lobby.SUB.DOMAIN.COM"
            main_muc = "conference.SUB.DOMAIN.COM"
            -- muc_lobby_whitelist = { "recorder.SUB.DOMAIN.COM" } -- Here we can whitelist jibri to enter lobby enabled rooms

    Component "conference.SUB.DOMAIN.COM" "muc"
        storage = "memory"
        modules_enabled = {
            "muc_meeting_id";
            "muc_domain_mapper";
            -- "token_verification";
        }
        admins = { "focus@auth.SUB.DOMAIN.COM" }
        muc_room_locking = false
        muc_room_default_public_jids = true

    -- internal muc component
    Component "internal.auth.SUB.DOMAIN.COM" "muc"
        storage = "memory"
        modules_enabled = {
          "ping";
        }
        admins = { "focus@auth.SUB.DOMAIN.COM", "jvb@auth.SUB.DOMAIN.COM" }
        muc_room_locking = false
        muc_room_default_public_jids = true

    VirtualHost "auth.SUB.DOMAIN.COM"
        ssl = {
            key = "/etc/prosody/certs/auth.SUB.DOMAIN.COM.key";
            certificate = "/etc/prosody/certs/auth.SUB.DOMAIN.COM.crt";
        }
        authentication = "internal_plain"

    Component "focus.SUB.DOMAIN.COM"
        component_secret = "n4lo@a6O"

    Component "speakerstats.SUB.DOMAIN.COM" "speakerstats_component"
        muc_component = "conference.SUB.DOMAIN.COM"

    Component "conferenceduration.SUB.DOMAIN.COM" "conference_duration_component"
        muc_component = "conference.SUB.DOMAIN.COM"

    Component "lobby.SUB.DOMAIN.COM" "muc"
        storage = "memory"
        restrict_room_creation = true
        muc_room_locking = false
        muc_room_default_public_jids = true

I refresh the Web Browser caches, tested on new PCs … can’t get it to work… thank you for your help.

I have the same config in my test installation and it works. So, the problem is not the prosody config, it’s something else

*the latest stable on Debian Buster with prosody-0.11.2-1"

I get this version before.
I follow a guide then for having the last one but nothing better