SOLVED - LetsEncrypt Fail?

Hey All,

I did a one click install and all seems to work, except the letsencrypt part.

I am getting this when I try to do it. Does anyone have any suggestions?

All the best,
Benjamin

This script will:

  • Need a working DNS record pointing to this machine(for domain connect.intuitionwisdom.com)
  • Download certbot-auto from https://dl.eff.org to /usr/local/sbin
  • Install additional dependencies in order to request Let’s Encrypt certificate
  • If running with jetty serving web content, will stop Jitsi Videobridge
  • Configure and reload nginx or apache2, whichever is used
  • Configure the coturn server to use Let’s Encrypt certificate and add required deploy hooks
  • Add command in weekly cron job to renew certificates regularly

You need to agree to the ACME server’s Subscriber Agreement (https://letsencrypt.org/documents/LE-SA-v1.1.1-August-1-2016.pdf)
by providing an email address for important account notifications
usage:
certbot [SUBCOMMAND] [options] [-d DOMAIN] [-d DOMAIN] …

Certbot can obtain and install HTTPS/TLS/SSL certificates. By default,
it will attempt to use a webserver both for obtaining and installing the
certificate.
certbot: error: argument -m/–email: expected one argument

Letsencrypt needs an email…

One click install? You might want to provide more details about that…

Hey again,

I used one click install from Vultr.

I did enter an email when it prompted me to add one.

Shall I restart?

Benjamin

I believe this is a question to ‘Vultr’ guys as not many here would have idea about their one-click setup…

Assuming it is works as expected, you may:

  1. Verify if the email is in proper format
  2. If you can, opt for no letsencrypt cert and install it after the install is complete.

Refer Install Jitsi Meet on Ubuntu 18.04 LTS - Vultr.com, for doing that…

Or you may simply opt for the manual install process like in the above link…or better go with the jitsi quick install instructions at Self-Hosting Guide - Debian/Ubuntu server · Jitsi Meet Handbook

Hey there,

I started over, I think I solved it. Thank you!