[Solved] Jitsi Not working from last 2 commits on DESKTOP BROWSERS

Jitsi not working from last 2 commits on Chrome 75.0.3770.80 and Firefox 67.0.1. If we use our own Deployment with JWT authentication, it shows Image 4 error. If we use meet.jit.si, it shows Image 5 error. It stucks at Image 6 and doesn’t continue on Chrome, and failed to detect camera & mic on Firefox. It happens seems to me from last 2 commits that I have downloaded through direct Software Update in Linux.
I am getting error as GETTING TURN CREDENTIALS FAILED in our own deployment when use JWT. I am using same token since last month and valid for long years. It was working previously on jitsi setup but not now.
Image 4 - Our Own Deployment with JWT
4

Image 5 - MEET.JIT.SI

Image 6 - Stucks at this phase (Don’t ask permissions - CHROME)

Working perfectly on APP & Mobile Browsers.

Has nothing to do with jwt, have you configure turncredentials module in prosody for your turn server?

About the permission screen, are you reproducing this only on one machine or do you see it on several devices?

It is working fine here. What OS you are testing on?

with turncredentials do you mean credentials in conf.avail> .cfg.lua? Components secret passwords and app secret?

I think yes, credentials are fine because I am getting enabled to talk on conference with Jitsi APP on Android.

In recent I have renew cert with letsencrypt.

On same machine… I think yes, I should check on other Windows Devices also.

No. You need to install a turn server with a valid certificate and configure it and install extra module for that, if this is what you want.

I am able to find out that I am facing issue on particular machine but on all browsers.

I don’t know why it is showing on the specific machine…other machines opening it perfectly.

Also I have enabled turn servers in config file…do we need turncredentials separately in prosody?

This is what I have already done:

You will need turnserver for few things, you will decide whether you need it.

  • In p2p mode if there is path to connect correctly, participants can use turn server and this way you can offload jvb. If you don’t have turn those participants will use jvb connection
  • In case of some networks and enterprise networks it will not be possible to send udp or to use other than https port 443 with valid certificate and this is when you will need turn server.

So this is not how turn servers actually works?

and the thing is - why this only machine giving turncredential error and why not other machines or devices?

I doubt this is the case, if you see it with one computer on your deployment you will see it and with rest.

These are stun servers needed for p2p participants to discover their addresses and ports and try connecting directly. For more info how to connfigure the turn server I pasted above some links.

Yes this is what… I have now stuck with my workstation. Well will see by reinstalling the browsers. The thing is - after updating the last 2 commits both the Firefox and Chrome browsers started showing this issue. is there anyway we can turn off mod that responsible looking the turn credentials…How can I check that? Is it something like mod_turncredentials… ?

@damencho can you just tell me where can I check if mod_turncredentials is enable or not? and how to disable it? I don’t know why this specific device is looking up turn credentials while not any other else is looking up.

If you have not enable it by hand it is disabled.

and how to enable it, can you just give me the steps?

I have make it true in config.js . I just wanted to know where and what to configure in prosody and how to enable mod_turncredentials?

@damencho I have tested that CHROME 74 devices not giving this issue but devices with CHROME 75 stucks at the permission.
OS: Windows

Interesting, we haven’t seen reports like that. I don’t see it here with chrome 75, but on macosx.

Ok…I think I need to check with other various platforms before I guaranteed the issue really existed or something wrong with my systems.