[SOLVED] Jitsi Electron - Disable Recent List

Hate to give up, but I’ve been struggling for days to figure out how to disable the “recent list” in the electron desktop app. Nothing has worked. I’ve tried modifications in Welcome.js, main.js e.t.c…, no luck. Can someone please point me to how to do this? :pray:t5: Thanks in advance.

Can anyone help with a pointer on this? Need to get this done.

It is added here: https://github.com/jitsi/jitsi-meet-electron/blob/master/app/features/welcome/components/Welcome.js#L180
You need to comment that and rebuild the electron app.

Thanks so much! Will try this.

Commenting that parenthesis gave an error. Should I be commenting out the whole block of code?

Screen Shot 2020-10-05 at 12.58.33 PM

Oh wrong line :frowning: sorry.

Unfortunately, that didn’t work either. I’d actually focused on that block of code while trying previously, myself and it didn’t do it. I just tired it again per your suggestion and it’s the same result.

Hum, this is the only place in the electron app where recent list is shown.
You are doing:

npm install
npm start

?

I’m doing

npm install jitsi-meet-electron-utils --force

(because I’m using a local copy of electron-utils)

And then doing

npm run dist

Are you sure then you are running the correct version produced by dist? Try with npm start first to check the change from the source code.

I actually just compiled and ran everything from scratch using the repo vanilla now, still the same.

  1. Cloned repo, npm install, npm run dist - built Jitsi electron app
  2. Then made change to welcome.js, npm update, npm run dist - built Jitsi electron app with recents list still enabled

So commenting out that line is not disabling the recents list, unfortunately.

You are missing npm install on the second step, or maybe that is not needed … I’m not sure …

What about npm start on second step, do you still see it when running from source?

Normally npm install is not needed on the 2nd step since I just edited an already installed app (if I’m not mistaken). But just in case, I did it over, ran npm install instead of npm update and the recent list still shows up.

npm start has never really worked for me - it just launches a blank application. It’s supposed to launch the app in dev mode, but all I get is a blank frame. Maybe there’s something I should be seeing that I’m not aware of. So I typically just go to the distribution package by running npm run dist

Just tried “npm start” and for the first time ever, that actually ran a version of the app for me… lol. But unfortunately, the recents list still shows up - even in dev mode. It shows up with the comment line, interestingly.

Wait a bit or refresh and it will. disappear.

I just tested it from master with no changes:

  1. npm install && npm start - I see it.
  2. just change the code to remove RecentList leaving just <Body /> and the app auto refreshes and the list disappears, without even stopping and starting the app:
1 Like

YESSSSS!!! :man_dancing:t5::man_dancing:t5::man_dancing:t5:

Deleting the line completely did it (commenting it out did not). Thanks so much!
And on a side note, I’m glad the dev mode is also working for me now (for some reason, it’s chosen to… lol). Makes life so much easier.

Thanks @damencho! You’re the man! :muscle:t5: