[solved] Jitsi-Authentication breaks after upgrade to ubuntu 20.04 LTS

Today I upgraded my Jitsi-Server to ubuntu 20.04 LTS. After the upgrade I was not able to authenticate myself.

Jitsi threw an error: GET_SESSION_ID_ERROR

I found this thread, that solved my problem: GET_SESSION_ID_ERROR : Prosody-0.11,Ubuntu-19.04

Edit

/etc/prosody/conf.avail/servername.de.cfg.lua

replace storage = “none” with storage = “memory”

[...]

Component "conference.servername.de" "muc"
    storage = "memory"
    modules_enabled = {
        "muc_meeting_id";
        "muc_domain_mapper";
        -- "token_verification";
    }
    admins = { "focus@auth.servername.de" }

-- internal muc component
Component "internal.auth.servername.de" "muc"
    storage = "memory"
    modules_enabled = {
      "ping";
    }
    admins = { "focus@auth.servername.de", "jvb@auth.servername.de" }
    
[...]

and restart the services. Now you should be able to authenticate yourself.

2 Likes

This fix allowed one connection at a time to succeed and stay connected in my case.
However, the remaining problem is that the first connection is dropped when the next one comes in to the same room. I’m able to connect however to a different room with two devices at the same time.
FYI: Before that Ubuntu upgrade 18.04 — 20.04 crashed at some point but the o/s appears anyway to run as usual.

Solved. The other problem was with startup of videobridge. Noticed some things:

file /etc/systemd/system/jvb.service
/etc/systemd/system/jvb.service: broken symbolic link to /lib/systemd/system/jitsi-videobridge.service

ls /lib/systemd/system/jitsi-videobridge.service
ls: cannot access ‘/lib/systemd/system/jitsi-videobridge.service’: No such file or directory

ls /lib/systemd/system/jitsi*
/lib/systemd/system/jitsi-videobridge2.service

Made sure SystemD starts only “jitsi-videobridge2” and not “jitsi-videobridge”.