[SOLVED] Jicofo sets moderator to every users despite setting member

Not sure where to ask for the problem, prosody or jicofo issue I guess.

I am using k8s setup and iframe api from frontend.

Other than that I’m using multi-tenant settings.

My jwt look like this.

{
  "context": {
    "user": {
      "id": 98035,
      "name": "John Doe",
      "affiliation": "owner",
      "avatar": "http://some_url",
      "email": "johndoe@example.com"
    },
    "group": "tenant1"
  },
  "room": "[tenant1]5c4aa6b1-0d7e-11ed-988f-9948a2e6cf87",
  "app_id": "tenant1",
  "iat": 1658941090,
  "exp": 1658997899,
  "aud": "app",
  "iss": "tenant1",
  "sub": "tenant1"
}

I am using this token_affiliation custom module from jitsi -contrib prosody-plugins/token_affiliation at main · jitsi-contrib/prosody-plugins · GitHub

Everthings seems fine and plugin is also executing, I can clearly see logs on prosody.

But despite all that all the users are moderator.

Other things I tried by setting auto-owner = false on jicofo.

...
conference {
      enable-auto-owner = false
....

I am using stable build containers.

But there is no problem with simple deployment setup (a docker-compose), on difference in that is jwt algorithm, unlike above docker-compose setup has es256.

I guess this might be somethings to do with multi-tenant, any guide would be appreciated.

Thanks.

I don’t know how it’s set for K8s but if the external auth is enabled for jicofo, it is normal to get this result.

The setup is docker equivalent.

External auth you mean jwt; or the iframe api?

Jwt has rs256 algorithm. Do you thank that has the effect?

I mean

That solved it. Thanks a lot.

But I’m not sure how it works. Is there any documentation I can look into it.