[SOLVED] Jibri with JWT token enabled Jitsi


#21

uh oh. What to do now. I still can’t figure out what could be wrong. If the selenium page fails to load, there couldn’t be any error in Jibri/Selenium as the same jibri works well with non-JWT Jitsi.

What else could it be?

Abhijit


#22

Hi @damencho @Aaron_K_van_Meerten @bbaldino,

Any idea why would the selenium session be failing ? I tried setting up a fresh setup as well, but the problem is persistent.

Abhijit


#23

Yeah this is strange setting ‘allow_empty_token = true’ should bring you to the state that meet.jit.si is using the jibris and this is prooven it works.
The next step will to set your username and password in localstorage on your browser and try again with the link and see whether it succeeds.
To save something you need to execute this in the javascript console when you open your welcome page window.localStorage.setItem('$key', '$value'). Where key is xmpp_username_override and your jibri user jibri@recorder.jitsi.net… and xmpp_password_override with value of its password.


[SOLVED] Error: "Cannot read property 'isJoined' of undefined"
#24

hello @damencho

we have tried this also with allow_empty_token both true and false. Unfortunately, the issue still persists, in fact, strophe is not getting connected now.

we set value as below in local storage of browser session
window.localStorage.setItem(‘xmpp_username_override’ ,‘username@recorder.domain’);
window.localStorage.setItem(‘xmpp_password_override’ ,‘password’);

Can you please guide us with the configuration that might be we missed?

Thanks,
Aneri & @abhijitnathwani


#25

So if it is not getting connected, you need to check why. Open the network tab in developer tools and see what is the received error response from the server and what is the content of the response.

I can if I know what is the problem. The first goal is to find what is the problem, see above ^.


#26

Hi @damencho

Please find the logs below, I don’t see any errors on the network tab.

Prosody Config: https://pastebin.com/admPCCbh
Jibri Config: https://pastebin.com/0YZJMi2p

Abhijit


#27

Server did not offer ... is something else, take a look: Cannot login to jitsi-meet - "Strophe: Server did not offer a supported authentication mechanism"


#28

Hi @damencho,

Thanks a lot for all the help. The problem was this,
c2s_require_encryption = false
It was set to be true.

The community helps alot. Thanks for having this platform.

Abhijit


[SOLVED] Error: "Cannot read property 'isJoined' of undefined"