[Solved] Is there any way to add room name/description

I have configured Jitsi token authentication with room name as unique ID like below.

{
  "exp": 1596455620,
  "iat": 1596455320,
  "auth_time": 1596452607,
  "jti": "51a2381f-7434-412c-9a1d-3a92401f5dd8",
  "iss": "test",
  "aud": "test-meet",
  "sub": "abbe961f-53a0-44de-84e2-a177df24cd16",
  "typ": "Bearer",
  "azp": "test-meet",
  "nonce": "1f5949af-d527-4474-823a-6676c166bd86",
  "session_state": "cff3b15f-1101-4221-88af-58b0780fc0d4",
  "acr": "0",
  "scope": "openid",
  "context": {
    "user": {
      "name": "Srikanth",
      "id": "abbe961f-53a0-44de-84e2-a177df24cd16",
      "email": "test@gmail.com"
    },
    "group": "create-room"
  },
  "room": "abbe961f-53a0-44de-84e2-a177df24cd16"
}

So the room id is appearing on screen as well as on the browser tab which is not looking good. (basically I am not giving the option to user to enter the room id to start the meeting, but want to give the option to meeting description to appear on the screen as well as in invite)

Is there any way to configure room name or description which can be displayed instead of room id?

Yes. Use config.subject, like this:

https://meet.example.com/abbe961f-53a0-44de-84e2-a177df24cd16#config.subject="TestMeeting"

@corby I tried this one, but didn’t work. Its still showing that login unique id on screen as well as on tab title.
Is it because I am authenticating user with JWT ? I even added sub claim with string. Still not working.
Am I doing anything wrong ?

I tried without JWT (no authentication) still not working. Its always showing room id on browser tab & on screen.

Try https://meet.jit.si/abbe961f-53a0-44de-84e2-a177df24cd16#config.subject=“TestMeeting”

Nope, its still same thing

Notice the # not the ? (I corrected my above reply)

https://meet.jit.si/abbe961f-53a0-44de-84e2-a177df24cd16#config.subject="TestMeeting"

Just worked for me:

Thank you Corby its working, I forgot quotes.

There is one issue, it is working with no authentication, but when I am trying with jwt, authentication itself failing.

https://mydomain.com/1-2-3-4#config.subject="TestMeeting"?jwt=token

in browser console

Failed to parse URL parameter value: %22TestMeeting%22?jwt SyntaxError: JSON.parse: unexpected non-whitespace character after JSON data at line 1 column 7 of the JSON data
    a parseURLParams.js:49
    a parseURLParams.js:33
    <anonymous> constants.js:12

Try: https://meet.jit.si/abbe961f-53a0-44de-84e2-a177df24cd16?something=1&something else=2#config.subject="TestMeeting"

https://meet.jit.si/abbe961f-53a0-44de-84e2-a177df24cd16?jwt=token&#config.subject="TestMeeting"

Ya keeping #config.subject as the last param did the trick. But the subject is not coming as browser tab title.

Yeah. I believe it only applies to the display subject/meeting name, not the <title> attribute, which is what you see in the browser tabs.

It’s probably something for the developers to add but likely low on the priority list.

You could easily make it happen on your own deployment, though (through some JavaScript)

Yup, will try that. Thank you corby.