[solved] Installation of jitsi-meet+jicofo+jvb on lxd container

Hi,
I’m trying to install on a container with ubuntu 16 (the same thing with 18.04).
I ahve the following error on jvb.log
SLF4J: See http://www.slf4j.org/codes.html#multiple_bindings for an explanation.
SLF4J: Actual binding is of type [org.slf4j.impl.JDK14LoggerFactory]
JVB 2019-03-25 14:54:25.792 SEVERE: [26] org.jitsi.impl.osgi.framework.BundleImpl.start() Error starting bundle: null
java.lang.ClassNotFoundException: org.jitsi.eventadmin.Activator
at jdk.internal.loader.BuiltinClassLoader.loadClass(java.base@9-internal/BuiltinClassLoader.java:366)
at java.lang.ClassLoader.loadClass(java.base@9-internal/ClassLoader.java:419)
at org.jitsi.impl.osgi.framework.BundleImpl.loadClass(BundleImpl.java:237)

do you have a solution for this problem?

Are you running with java8?

java -version
openjdk version “9-internal”
OpenJDK Runtime Environment (build 9-internal+0-2016-04-14-195246.buildd.src)
OpenJDK 64-Bit Server VM (build 9-internal+0-2016-04-14-195246.buildd.src, mixed mode)

Please, use java8 and try again.

thanks, java 8 is the solution
thank you again

Angelo
I too am using Ubuntu 18.04 and SNAP LXD and have install jitsi using two different guides:

https://jitsi.org/downloads/ubuntu-debian-installations-instructions/

and also tried…

On both I can access Jitsi in the LXD container (container is also ubuntu 18.04) and I get prompted to permit use of my webcam on either firefox or chromium.

However, when I get prompted to “start a new meeting” and enter a meeting name then click GO
the next screen does not display my webcam video or play my webcam’s mic audio ?

BUT … if I click SETTINGS (lower right corner)… then I do see my WebCam output however, although the sound bar moves … I don’t hear any audio output.

Maybe its just my USB Webcam/Mic but did you do anything special to get this to work for you
in LXD ??

thanks
brian