[SOLVED] How to enable multiple videobridges

EDIT: Solution in this post

Hi all, I’ve tried to follow this tutorial but something still doesn’t work, when I try to connect the server always try to use the main videobridge and not the backup one.

Could anyone try to help me?
I’m sure I’m missing something to configure in the main server to say him which are the other videobridges…



THANKS @flyinghuman FOR THE HELP



SOLUTION:
Follow the installation, plus set in the JVB (alternative videobridges) the next parameter to avoid checking certificate since it’s missing in the file:
/etc/jitsi/videobridge/sip-communicator.properties
org.jitsi.videobridge.xmpp.user.shard.DISABLE_CERTIFICATE_VERIFICATION=true

2 Likes

@damencho I’m sure you’re able to identify in less than a minute where’s the problem.

I’m following this tutorial since it’s a lot more clear than the official one, since it make a really step by step instruction, telling also which parametesr change, sorry man but @jcfischer has trascurated that people like me could not figure out what to change and what not to touch during this setup.

What does trascurated mean?

For example @flyinghuman 's tutorial expose the content of the file and what’s to change in it.

@jcfischer checking the tutorial made by @flyinghuman could you see if there’s something absent?
Becasue I change those 2 files on the secondary videobridge but it seems that the main server still try to continue connecting to the main one.

I’m sure that there’s something more to modify where I should put the alternative videobridges or that they’re in a kind of cluster.

hi, i have updated the doc and published it here: https://github.com/jitsi/jitsi-meet/wiki/jitsi-meet-load-balancing-installation-Ubuntu-18.04-with-MUC-and-JID

1 Like

What has changed?

e.g. use of videobridge2 instead of videobridge package and more explanation
other useres here reported that the howto ist good and did work for them. so i can’t say whats wrong at your side. look into the logfiles for errors.

Edit: jcfischer did also a howto for this, maybe look into both and check your settings twice

1 Like

I’ve followed your tutorial yet 1 hour ago and this is what I do:

JMS installed as should by following the standard intallation tutorial via apt install etc. etc.

Followed your tutorial for JVB:

  • apt install jitsi-videobridge2
  • copy JVB_SECRET from JMS /etc/jitsi/videobridge/config
  • copy hostname, domain & password from JMS /etc/jitsi/videobridge/sip-communicator.properties
  • restart the JVB videobridge service and it’s running correctly
  • when I stop videobridge2 on main server I can see that connection doesn’t work since it output the nickname of JMS videobridge

Obviously for testing pourpose firewall is disabled

@jcfischer what I’m missing?

did you change the nickname at the second bridge?

It’s different from the server 1

in jicofo.log you should see joining the second server with it’s nickname on your first server where jicofo is installed. is this logged?

Jicofo is only on the first server, as explained in the guide.
I see the nickname of the first one only, and since it’s shutted down the service it goes KO

due MUC connection it should not be neccesary to open prosody for the world but maybe you can try to add this to your /etc/prosody/prosody.cfg.lua:

component_ports = { 5347 }
component_interface = "0.0.0.0"

and restart the service?

also, what is the output of your /var/log/jitsi/jvb.log from second bridge?

Let me try, I’ll be back in 2 mins

WARNING: [3479] [hostname=live.hot4.cash id=shard] MucClient$1.connectionClosedOnError#295: Closed on error:
javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path validation failed: java.security.cert.CertPathValidatorException: signature check failed

WARNING: [3563] org.jivesoftware.smack.AbstractXMPPConnection.callConnectionClosedOnErrorListener: Connection XMPPTCPConnection[not-authenticated] (0) closed with error
javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path validation failed: java.security.cert.CertPathValidatorException: signature check failed

do you have a self signed cert? replace it with a valid certificate on jitsimeet-server. (let’s encrypt for example)

like it is described here: https://github.com/jitsi/jitsi-meet/blob/master/doc/quick-install.md

1 Like

on JMS I’ve the cert made by certbot script included in the tutorial

hmm, i use a own valid certificate - maybe the let’s encrypt part of the install script is broken? idk