[SOLVED] How to enable mobile browser in jitsi-meet

Jitsi meet is running on docker

Installed https://github.com/jitsi/docker-jitsi-meet

Jitsi meet is not working in iPhone chrome browser

image

I don’t know how to help you. I don’t use docker

See the most recent comments on the link, I believe this would be the appropriate solution.

1 Like

Thanks for the quick fix but the chatbox button is disappeared & when we will rotate the phone screen then it’s reaper!

any idea how we can hide “screen sharing” and show the “chat” button in mobile browser users with building or deploying the whole app from reacting source code?

I have no idea :pensive:

My Jitsi installation disconnects every time I enter with a cell phone.
Has anyone else had this problem?

Jitsi by default has dsabled mobile. New versions has a new way to enable them

@pratik,

Screen sharing is not supported by the chrome mob browsers as of now… and you can find the chat in the options on the right side…

Regards,

How could I enable it?

Hello all,

is the new version already in deployment? I know we can use this “fix” to bypass the limitation:
https://meet.jit.si/YourMeetingNameHere#config.disableDeepLinking=true

this worked like a charm !

Thank you

Hello guys,

can anyone help me with this, how to enable chrome browser use for jitsi meet on android and ios with jitsi meet api

i set disableDeepLinking: true and MOBILE_APP_PROMO: false but it doesnt work.
thank you !

<script src="https://meet.jit.si/external_api.js"></script>
<div id="meet"></div>     
<script>
    var domain = 'meet.jit.si';
    var options = {
       roomName: 'tester',
       ConfigOverwrite: {
            disableDeepLinking: true,
        },
        interfaceConfigOverwrite: {
           MOBILE_APP_PROMO: false,
        },
        parentNode: document.querySelector('#meet')
    };

    var api = new JitsiMeetExternalAPI(domain, options);
</script>

changing to this works now, great:
function i(){return false; return"android"===r.a.OS||“ios”===r.a.OS}

but only chrome android for example huawai p10lite works fine ! with chrome ios i got detection error with cam and microphone, fo example with iphone6s and ipad, tested with IOS 13.5.1, Chrome 81.0.4044.124

also update to the newest chrome version 83.0.41033.88 doesnt fix the issue

I’ll try

The latest solution is very elegant.
Go to “/etc/jitsi/meet/-config.js” and update the disableDeepLinking setting as below
“disableDeepLinking: false”

The app would open just fine on browser and desktop. (No changes are required in the interface js files)


If some developer can guide me on changes to css, to ensure the app view is optimized for phone browsers that would be very helpful.

1 Like

It is taking lot of time to load in the mobile browser. I have enabled cache but still the same issue

Any thing else needs to be done . Its taking almost 120 Seconds for me to load .

Any guidance . In the desktop version it loads fine. I am using the Mobile Internet and not on a great bandwidth

Thanks
Naveen

Change the default browser on mobile. For example in my case, on apple iOS , i had a chrome browser which never loaded the video call, but when i use the safari, it loads the video call instantly.

With the above code, I have managed to switch iOS and Android users via a mobile browser.
there are many ways to be directed to the mobile browser only for IOS users ?

Why? It seems perfect as for now :thinking: