[SOLVED] How to enable mobile browser in jitsi-meet

SOLUTION In the next post:

Problem:
Hello, I’d like to enable mobile devices on Jitsi

a user said me this:
edit file /usr/share/jitsi-meet/libs/app.bundle.min.js

  • from:

if(“android”===n||“ios”===n)

  • to:

if(false && (“android”===n||“ios”===n))

but…
there’s not that line of code in that file, maybe there was in older versions…

anyone could have an idea on how to do it?

P.S. using desktop mode on mobile interface is really small, but enabling full screen the page is quite perfect for mobile, so that’s why I’d like to let also this to be possible.

1 Like

@damencho have you any idea on how this could be done?

sincerely because I’m using an experimental device that won’t work with mobile apps :pensive: only PWA or web or specifically made ones.

Talking from memory but that line has changed somehow… now it’s something like
if(“android”===n.OS||“ios”===n.OS)
If you search for if(“android”=== you’ll find it.
We do something similar in one of our deploys.

@Joan
I had tried to do the same with no effects :pensive:

I think that they changed a lot of code and now it became lot more complex to allow mobile browsers.

In my case I haven’t tried the latest version yet, buy maybe you are looking for something like this

userAgent.match(/Android/i)

or this

Platform.OS === ‘android’

Paste your app.bundle.min.js file contents here or something…

It’s 2.7 MB of js, maybe better not paste it all

You can upload files via this text editor… try and see if it accepts the file, at least as a .txt file

@Joan here is the file, let’s see if it accept it so big

app.bundle.min.js.txt (2.8 MB)

good, seems to accept it

Pretty sure this is what you are looking for:

function i(){return"android"===r.a.OS||“ios”===r.a.OS}

1 Like

so how should I change it?

Plus… how to make this change have effects? Because I had notice that nothing chages when I for example change a language page

If you want all devices to work as desktop web pages…
function i(){return false; return"android"===r.a.OS||“ios”===r.a.OS}
The function will always return false and so the device will never be detected as Android or iOS.
This change should take effect immediately unless your server has some kind of cache… in that case I cannot help you in a forum.

2 Likes

@Joan thanks man! it worked!!!

#solution thanks to @Joan

change in /usr/share/jitsi-meet/libs/app.bundle.min.js

  • from:

function i(){return"android"===r.a.OS||“ios”===r.a.OS}

  • to:

function i(){return false; return"android"===r.a.OS||“ios”===r.a.OS}

Tip:
To easily find the part of code search for:

return"android"===

3 Likes

No luck here

docker exec -it docker ps | grep web | awk '{print $1}' bin/bash

sed -r -i.bak ‘s/(return"android")/return false;\1/g’ /usr/share/jitsi-meet/libs/app.bundle.min.js

…}function ve(){return false;return"android"===fe.Platform.OS||“ios”===fe.Platform.OS}…

@operat0r unfortunately I didn’t used the docker image, you should install it by apt or install it manually from sources.

I’m not familiar with docker, in worst I think you should recompile the docker image after the edit.

Still working on this ill update post if I sort it out:

https://jitsi.rmccurdy.com/libs/app.bundle.min.js

Remember that everytime you update jitsi, that file is updated, I think it’s a lot better if you fork from source and build with your modification.

@damencho why don’t you add a feature editable directly from main settings?
I think that client app must be advised but not forced.
Specially in a moment where PWA are arising on popularity

Hello RubensRainelli,

I’m also trying to get it to work in the browser, i just installed JitSi YESTERDAY on my own server using APT, but when i try to use it from phone it forces me to get the app, but i want it to work in the phone browser WITHOUT downloading the app.

Can you please tell me how you did it?

Thanks

In android browser jitsi-meet is working, but in iPhone browser it is not working(not able to turn on audio and video)
When i am click on video icon, it showing “failed to access your camera”

Follow thisn and love it xD

Check browser permission in iPhone’s privacy settings