[SOLVED] How to change the resolution of quality presets?

Hi,
I need to change the target resolution for different quality presets.
I have some users with Avermedia PW513 and some with Camlink + DSLR which can do 2160p at 30 fps fine and without a problem with this configuration.

constraints: {
video: {
aspectRatio: 16 / 9,
height: {
ideal: 2160,
max: 2160,
min: 240
}
}
},

My problem are users with a logitech c920, this cam does 1920x1080 at 30 fps but also 2300x1200 at 2 fps and that is a problem because with the config above it will go in the 2 fps mode instead of staying in 1920x1080 at 30 fps.
How can I change the standardresolution quality preset to be 1080p so users of a c920 can use that while users with better gear can still use 2160p?
Currently it defaults to 360p which looks shit.

Thanks for any help

I think that this incantation looks very much like a straight browser parameter that is passed as is to Javascript code, so you could try reading this doc, try to play with the interactive part and check what it gives, including using the ‘advanced’ keyword.
I have never tried it but I’d be interested to know if it works for you.

Thanks for the hint, but that doesn’t help. The Browser will prioritize resolution over fps.
That is why i wanted to utilize the quality slider of jitsi meet. but it seems like there is no way to configure the presets that there are available.

Anyone else a idea how to do a workaround?

still looking for a solution or workaround

I’m assuming you already set the following parameter in config.js and that didn’t work?

resolution: 1080,

Hi,
yes I use it and if i put 1080 in it, the 2160 capable devices are also limited to 1080. So that is no solution sadly

What if you specify 30fps in the constraint? I imagine that would take precedence over resolution.

Hi I did that in the past, but i was stupid and did only append it to my config which did result in having resolution overrulling fps.

this:

 constraints: {
     video: {
         aspectRatio: 16 / 9,
   frameRate: {
   ideal: 30,
   min: 30,
   max: 60
  },
         height: {
             ideal: 2160,
             max: 2160,
             min: 240
         }
     }
 },

did the trick now for me.
C920 users use 1080p 30 fps and user with better gear 2160p 30fps and with vp9 and 10 mbit/s bitrate that looks really awesome.

Glad it worked. :+1:t5:

1 Like