[Solved] How can we enable VOICE as default in Android & iOS app?

  1. What settings need to be changed in which file that changed the app opening default to Video during app Build? I want the VOICE is enabled instead Video and user tap manually the camera icon to enable the camera.
    What is the minimum upload data speed required in VOICE calling?

  2. From where can I change the color of the app where I changed the color code #1235A to my own?

@saghul…any help?

This is not currently possible. You can select if you want a video or voice call, but on a per-call basis, the welcome page is a bit different. You could probably just edit the code if you are making changes anyway?

I don’t know off the top of my head, but we use the Opus codec, which was variable bitrate, it adjusts based on network conditions.

Most colors can be changed here: https://github.com/jitsi/jitsi-meet/blob/master/react/features/base/color-scheme/defaultScheme.js

can’t we set .setVideomuted (true) in original jitsi source code and just enable to start with AUDIO?

You can use setAudioOnly, but that won’t make the toggle look different, I think. Maybe just dive it a try :slight_smile:

OK. Thanks @saghul . I will give it a try and check the best possible way to keep the Video Disable when an app is opened.

@saghul The .setVideoMuted (true) Worked!

Also I have just left with NOTIFICATION bar color edit. It is still blue by default…I am unable to find how to change it to green. In android studio there’s a style.xml changed for NAVIGATION bar green in colour from default one. But how can I change notification bar color?

Good to hear! The status bar color is set in JS, check the StatusBar component.

I checked, I didn’t get the path of the file to edit @saghul

oooooh Ok…I got it. I have already changed it with the new colour…i think i need to clear cache then. Thanks @saghul for your help :hugs:

The .setAudioOnly (true) worked. I revert the changes and found this worked only and not .setVideoMuted (true) as I wanted.

And clearing the cache resolved color issue. Thank you @saghul