[SOLVED] Headphones Cut Off Phone Mic In App

I am requiring to use the Jitsi app on my mobile phone, but when I plug in my headphones the mic is switched off on my phone, so I can’t communicate. How can I prevent this from happening? I am in a noisy environment and cannot hear the video call without headphones.

This probably sounds silly to ask, but to be clear, the headphones you’re plugging in have a mic, right?

No. If they did, then I wouldn’t need to post my question. I don’t have headphones with a mic. When I use Jitsi with my laptop the mic doesn’t automatically switch off when I plug in my headphones. So I need the same configuration for when I use Jitsi on my mobile phone.

So you plug in a mic-less headphone into an input that functions to relay signals from both speakers and microphone and you’re wondering why your voice is not carrying through? Yet you get snarky when asked to clarify? I probably wouldn’t be so snorty if I were you, seeing as I don’t understand the difference between separate mic and speaker inputs on a laptop and a single input on a phone carrying both signals. :roll_eyes:

  1. I’m not being snarky or snorty.
  2. I was not aware that the input of the mobile phone is twin purposed.
    So, there’s no need to be so presumptive and rude.
    Thanks for taking the time to answer, but please, there’s no need to bring your superiority attitude and sarcasm to this post.

I have discovered an app called SoundAbout, which provides an option to configure mic-less headphones priority, which turns on the mobile phone mic whilst retaining the ability to use the headphones.