[Solved] Facing the issue while running release-sdk.sh

#1

I am facing this issue after going with NPM INSTALL

I am on windows and added environment variables for jq, maven and git but getting the error while preparing repo

Also, I get the error message in the studio “cannot run : scripts/run-packager.sh is not a valid win32 application”

#2

Sorry, we do not support building under windows.

#3

that means it will work in Linux?

#4

Linux and Mac, yes.

#5

There’s again an issue in Linux

#6

why build is getting failed…can anyone help sorting out with this issue?

#7

@damencho any clue?

#8

I have never seen this one. Can you please try to build it as non-root? Also, have you run npm install first?

#9

Yes I did npm install with npm -v 3.5.2 node -v 8.10.0

#10

I have tried, again getting same issue. It says

Task :sdk:bundleReleaseJsAndAssets
warning: the transform cache was reset.
Loading dependency graph, done.
error Unable to resolve module js-utils/random from /opt/jitsi-meet/react/features/app/getRouteToRender.js: Module js-utils/random does not exist in the Haste module map

#11

what is the npm and nodejs versions are you using for this? @saghul?

#12

As the README states you need to be running npm 6 and Node 10.

#13

Also, don’t use sudo, it’s not needed and will do you more harm than good.

#14

if i don’t put sudo I get error message PERMISSIONS DENIED. Also the android Sdk folder is installed in root folder.

#15

I installed npm 6 and node 10… Still getting same issue

what is the exact version you have tried upon?

These are the versions I am using

#16

The output should be longer. Can you delete your current node_modules directory and try again?

#17

I deleted several times…facing same issue again and again and now getting a new one on installing

#18

This is the error I received when delete the node_modules folder and try installing without sudo.

#19

You deleted the wrong folder. It’s not /node_modules but node_modules

#20

I deleted using Linux UI later on … that’s not an issue…but the issue is with npm Install. even after installing nodejs 12 when i run the script from script folder, i get error message that Couldn’t found com.facebook.react:react native:0.59.5 required by the project