[Solved]! Conference get crashed with users more than 3, not on p2p


#1

Whenever more than 3 users connect a conference, the video calling cashed and not even re-established with 3 users. Only p2p works. Problems detected with jvb and jicofo in log around 2019-03-07 14:25 … I have already added port map harvest config and local & public ip harvet config in sip config file and 127.0.0.1 localhost Dev-VideoConf-Jitsi in hosts file to make run more than 3 users on jvb. Worked perfectly upto 3 users.
JVB LOG
jvb_log.txt (918.4 KB)

JICOFO LOG
jicofo_log.txt (49.2 KB)


#2

What does it mean crash? Do you see the reload screen or your browser crashes?


#3

I mean this problem @damencho .


#4

Most probably this means there is no jvb registered to the xmpp server. You can verify this by opening the js console and checking the error you see.
It is either jvb missing or focus(jicofo) missing.


#5

OK i will see let you confirm. but if jvb was not available it would definitely nt connected the 3rd user.


#7

@damencho In my case, I’m getting p2p connection very easily with STUN TURN servers enabled also and as soon as 3rd user or 4th user joins the conference, jvb or jicofo breakdown resulting in either crash the conference or connectivity issue with 3rd and 4th user. If we restarts with terminal command as :sudo service jicofo restart ; and sudo service jitsi-videobridge restart then it starts working again and connect 3rd and 4th user else it keeps disconnect users more than 2 and don’t allow more users than p2p.

I mean when it encounters, I always need to restart the service. It occurs after every conference users join and almost each time i need to restart the service.

Yes Jicofo and sometimes JVB stops working and requires restart of the service. I am scratching my head upon the same connectivity issue from last several days.


#8

What is the bandwidth on the server? Are jvb and jicofo on the same machine? If that is the case what is the available RAM on that machine?


#9

I have installed on Virtual Box 6. Lan Mode is Bridged and so in same network as in system and router. RAM is 4096M, SSD, Internet bandwidth 40Mbps(Total) with 10Mbps Upload on server. But when I open Resource/health Monitor on Ubuntu, it shows consumption of 1.3GB RAM only with NO Swap and 20% CPU usage Only. For all these 4 Connectivity of Users it just show Max. Sent speed of 1.5Mbps only and Received Speed upto 1Mbps only.

I am testing Conference on

  1. Pixel 2 XL
  2. OnePlus 6
  3. ASUS MAX M2Pro
  4. Laptop(intel)/Desktop(amd)

Im using Desktop Site on Phones and these devices have 4G Speed of 4Mbps respectively and Laptop/Desktop has 24Mbps V-fibre (wifi)connectivity.


#10

Make sure you have 8GB of RAM for running both jvb and jicofo.

This is not enough, so 10 will be enough for around 2 and a half HD streams send from the server.


#11

I don’t know but when Mobiles and Desktop share conference, server on which jvb and jicofo is installed, don’t upload more than 1.5Mbps.
I even tried using LD and SD also, HD doesn’t remain always as it lowers down automatically.
Even it doesn’t use 2.7GB RAM out of 4 and it always remain unused. anyway I will try tomorrow with 3 devices only in SD mode. If this is bandwidth issue, I will confirm you soon by allocating more resources. Thank You :slight_smile:


#12

@damencho I have checked the devices with SD mode only and 4Mbps Upload speed on each device and same 10Mbps on Server. It seems Resources are sufficient to stream SD mode for upto 4 devices and Jicofo and JVB doesn’t consume RAM more than total of 1.5GB including System Data. When Machine is started, it starts with 1.0GB RAM consumption and when 3-4 devices are bridged, it reaches max upto 1.5GB and on average 1.3GB. I have cross-checked with installation on Linux Server (out of Virtual Box VM) and yup JICOFO and JVB not consuming more than 0.5GB on SD Modes that is a Plus Point. The Problem is actually related to “FALLBACK” which means it fails to fall back from p2p to JVB when more than 2 users tries to join the conf. and vice-versa. Since I have enabled the useSTUNTURN, it seems working fine for now for 3-4 devices.

Can you clarify my doubt that there’s 2 option to enable/disable useSTUNTURN server … One is in the p2p and another is outside the p2p…what is this useSTUNTURN doing here and from which path and file it is fetching STUNTURN servers if I enable it?

because STUNTURN servers are mentioned in p2p only.


#13

When you have 2 participants if possible p2p is established, once a third joins it always switches to the bridge connection.

When p2p is not possible, let’s say double nat can be sometimes problem or restricted (symmetric) NATS/firewalls, a relay can be used (turn server) if configured. The turn server can be listening on port 443 for tcp connections (the case with meet.jit.si) and this tricks enterprise restricted firewalls where tcp 443 is only allowed.

The useStunTurn option is to add those turn servers to the jvb connection. For example on meet.jit.si we had disabled jvb option for tcp connections and for those we are using turn. When this is needed client sends tcp media to turn server and it relays the connection sending it to the jvb.

If you haven’t configured a turn server this option will not do anything on your deployment. https://github.com/jitsi/lib-jitsi-meet/blob/c2f269884a4991f1cee466367b98a095ace0b811/modules/xmpp/strophe.jingle.js#L364


#14

That’s interesting, what does the js console logs say when this happen?


#15

I will see and update here. Actually, in mobiles browser it hard to find out issues as direct console logs are not displayed there. I will check with Desktop Devices and update soon. Before raising any such issue on github I wanted to check this out experimentally first. Because I wanted to give a Pilot Test on Conferences in Healthcare field, most of the users will be having Mobile handsets and they really don’t care for app. For Ready to Go browser feature, the mobiles browser must able to keep connected the users with jvb.


#16

That’s nice. I also wanted this…will read a complete anatomy of this. Thank you @damencho :slight_smile:


#17

Hum, you are not using the app on mobile, but the browser?


#18

Yes. Not the app. :slight_smile:


#19

Have you tested the same with the app? Is it working?

Well, in this case, you are on your own. We can only help with decoding the console logs from mobile chrome and give you thought for debugging and fixing the problem. We do not have this use case, it is not tested and we do not encourage it.


#20

No I haven’t tried this on app. Rather I will try to sort problems with mobile web and desktop site first because in Pilot Testing our conference service(personal) I am not going to use app and the testing of the service will dependent on 50,000 users initially that means around 20,000 sessions will be initialized one after another within 3 months. Failing conference sessions on browsers will be an issue for us. Anyway, I hv bn always thankful to you sorting out problems with us and timely response you generate on our queries.

I will update soon the exact problem facing with “fallback” as discussed above with console logs and other logs.


#21

But this way you can find out is it something specific to the web on mobile usecase if app works, just install the app from play store and enter your full meeting id https://yourdomain.com/test will take you few minutes.