[SOLVED] Capture area 1920x1080 at position 0.0 outside the screen size 1280x720

Hello Guys,

I’m trying to set up video recording using jibri but having trouble.

Here is the error that I’m getting:
2021-05-03 04:31:09.332 INFO: [54] ffmpeg.log() [x11grab @ 0x55da677fffc0] Capture area 1920x1080 at position 0.0 outside the screen size 1280x720 2021-05-03 04:31:09.332 INFO: [54] ffmpeg.log() :0.0+0,0: Invalid argument

Things I have checked:
Java version:
openjdk version “1.8.0_292”
OpenJDK Runtime Environment (AdoptOpenJDK)(build 1.8.0_292-b10)
OpenJDK 64-Bit Server VM (AdoptOpenJDK)(build 25.292-b10, mixed mode)

JAVA_HOME
/usr/lib/jvm/adoptopenjdk-8-hotspot-amd64/bin/java

Things I have tried:
I have changed the default resolution to match the screen size (1280x720) in /etc/jitsi/jibri/xorg-video-dummy.conf and restarted the server as well as jibri services (jibri-icewm, jibri-xorg). Still the same issue.

Reinstalled jibri.

Thanks.

Jibri now defaults to 1080p resolution, so you’ll need to keep xorg-video-dummy at 1920x1080.

Thanks @Freddie
But even if that is set it to 1920x1080 (Which is the default), I still had the same issue.

I changed it to 1280x720 only after I had the above issue.

What does your jibri.conf look like?

Here you go @Freddie jibri.config.txt (3.6 KB)

@Freddie Thanks for your help
Solved by adding ffmpeg config in /etc/jitsi/jibri/jibri.conf file

ffmpeg {
  resolution = "1280x720"
  // The audio source that will be used to capture audio on Linux
  // audio-source = "salsa"
  // The audio device that will be used to capture audio on Linux
  // audio-device = "plug:bsnoop"
}

That parameter exists already in the latest jibri.conf and is configurable. Looks like you’re using an older version. But glad all’s well now.

aahhh my bad, which took my 2 days :frowning:

I followed your guide here for configuring new jibri and took the jibri.config from there
Can you please provide a link for the current reference so that other users do not encounter the issue I had

Thanks a lot for your help @Freddie

Unfortunately, the system does not allow edits to old posts. I’ll probably create a new reference post to address that.

Sounds good, thanks