[SOLVED] BridgeChannel.js:85 WebSocket connection to 'wss://localhost:8443/colibri-ws/ failed:

Hi,
I’m trying to use docker jitsi meet.

I have this error:
BridgeChannel.js:85 WebSocket connection to ‘wss://localhost:8443/colibri-ws/192.168.176.4/a3942e00a918c4ef/c74ba521?pwd=43hftaoss83fpp6q5ou62dbdp9’ failed:
Error in connection establishment: net::ERR_CONNECTION_REFUSED

how can I solve this issue?
this is my configuration file:

const config = {
      hosts: {
        domain: "meet.jitsi",
        muc: "muc.meet.jitsi",
      },
      bosh: "/http-bind?room=aaa",
      clientNode: "http://jitsi.org/jitsimeet",
      testing: {
        p2pTestMode: false,
        octo: { probability: 0 },
        capScreenshareBitrate: 1,
      },
      enableNoAudioDetection: false,
      enableNoisyMicDetection: true,
      channelLastN: -1,
      openBridgeChannel: "websocket",
      enableWelcomePage: true,
      enableUserRolesBasedOnToken: false,
      p2p: {
        enabled: true,
        stunServers: [{ urls: "stun:meet-jit-si-turnrelay.jitsi.net:443" }],
      },
      analytics: {},
      deploymentInfo: {},
      makeJsonParserHappy: "even if last key had a trailing comma",
      focusUserJid: "focus@auth.meet.jitsi",
      constraints: {
        video: {
          height: {
            ideal: 720,
            max: 720,
            min: 720,
          },
          width: {
            ideal: 1280,
            max: 1280,
            min: 1000,
          },
        },
      },
      resolution: 720,
      disableSimulcast: true,
      startVideoMuted: 10,
      enableTalkWhileMuted: false,
      disableAP: false,
      stereo: false,
      startAudioOnly: false,
      startAudioMuted: 10,
      enableStatsID: false,
      enableCalendarIntegration: false,
      prejoinPageEnabled: false,
      requireDisplayName: false,
      enableLipSync: false,
      enableRemb: true,
      enableTcc: false,
      useIPv6: false,
      transcribingEnabled: false,
      serviceUrl: `https://myserver.com/http-bind?room=${this.state.roomId}`,
    };

I’m noticing that in sip-communicator.properties file I have the following parameter:
org.jitsi.videobridge.rest.COLIBRI_WS_DOMAIN=localhost:8443
Thank you very much for your help

The error is solved in last commit of docker-jitsi-meet
thanks

Hello @damencho @saghul ,

Tried the kubernetes deployement. Facing the below error.

strophe.umd.js:5463 WebSocket connection to 'wss://localhost:8443/xmpp-websocket?room=possiblebuttersbetrayelse' failed: Error in connection establishment: net::ERR_CONNECTION_REFUSED

_connect @ strophe.umd.js:5463
Logger.js:154 2020-12-08T10:36:23.767Z [JitsiMeetJS.js] <Object.getGlobalOnErrorHandler>: UnhandledError: null Script: null Line: null Column: null StackTrace: Error: Strophe: Websocket error [object Event]
at Object.r.Strophe.log (strophe.util.js:89)
at Object.error (strophe.umd.js:1392)
at N.Websocket._onError (strophe.umd.js:5730)
o @ Logger.js:154
Logger.js:154 2020-12-08T10:36:23.767Z [modules/xmpp/strophe.util.js] <Object.r.Strophe.log>: Strophe: Websocket error [object Event]
o @ Logger.js:154
Logger.js:154 2020-12-08T10:36:23.771Z [connection.js] <a.d>: CONNECTION FAILED: connection.otherError
o @ Logger.js:154

Thanks advance for your input on this…


can u please help me out for this error im using docker build (jitsi version latest )

ENABLE_XMPP_WEBSOCKET to 0 in environment variables as per After upgrade to stable-5142-2 not able to open meeting · Issue #854 · jitsi/docker-jitsi-meet · GitHub helped to work this around

Fill out the PUBLIC_URL env.