Software unusable on Firefox, why?

Discovered this was caused by an extension shutting off webrtc

@dav9597 can you share the extension and where you disabled the WebRTC restriction. uBlock Origin has a preference to prevent local IP leakage via WebRTC.
@damencho Your work on Firefox is hugely appreciated. Jitsi and Firefox have had issues for years now. So it’s great to hear dev team is looking into this. Good luck with your work and thank you!

2 Likes

Dear damencho,

we have been trying to use sharing window with Jitsi Meet, but to no avail.
We are using the updated version of Chrome, fully enabled pop-ups and a mac with Catalina OS.
We start the call directly from your website.
Should it work ?
Thanks!

I have tested meet.jit.si between two computers on my desk, both running Firefox on Ubuntu Linux and encountered no problems, including with desktop sharing. Make sure you are up to date on everything.

Hello! What channel exactly (URL please) do you recommend to follow in order to get notified, when the firefox bugs are fixed?

2 Likes

Hi. I am able to use Jitsi Meet with Firefox 74 (64 bit) on Linux Mint 17.3. The only thing which seems not to work is the image blur option but that is not a major concern. The video and sound quality are just as good as achieved using Chromium and I much prefer Firefox generally.

I had the same experience. It worked fine with 2 computers. However, we were more than two in our group - so in the end, we were practicable unable to use Jitsi Meet :frowning_face: .

1 Like

hhhmmm, I also just discovered that Firefox is a no go, when I started to test the application on https://meet.jit.si/. For me, Firefox is important, because our company does not allow any Google Chrome based Webbrowser, incl. Chrome based Microsoft Edge.

I had read an article on https://hacks.mozilla.org/2015/06/firefox-multistream-and-renegotiation-for-jitsi-videobridge/, which gave me the impression that jitsi would work on Firefox. The publication date is 2015, so it seems that this does not apply anymore to the current version Firefox v74.

I would be interested to know how high this issue is on the priority list of the developers team and to know what the planning is on the timeline to get jitsi compatible with the Firefox webbrowser.

May be Mr George Politis can shine his light on the time line and priority.

I look forward hearing from you. It really is a burning issue for my company.

1 Like

20200402 I can use Firefox in openSUSE LEAP 15.1 when uBlock origin and Ghostery are active.
However I use it for one to one calls. Video calls.

I want to share my experience with Jitsi and Firefox:

Looks like audio and video works when using the Jitsi-provided rooms. (https://meet.jit.si/)

When joining a meeting that is hosted on my own server, using Firefox I get a black screen while other participants are sharing video. There is no audio either. In Chrome everything seems to work as intended.

Edit: When joining with a third participant. Both audio and video stop working, also on Chrome.

Any solutions you can suggest?

2 Likes

I don’t know if it can be useful: in “aboutconfig” I modified these values:
media.peerconnection.video.min_bitrate 100
media.peerconnection.video.start_bitrate 220
media.peerconnection.video.vp9_preferred true
media.webrtc.hw.h264.enabled true
media.webrtc.platformencoder true

It works quite well, but the audio quality. I can’t understand why…
Ale

in the Community Call on Monday they said firefox+safari will have improvements ready in 2-3 weeks! :wink: I am still unsure if these are full and complete fixes, or just small improvements though - does anybody know?

1 Like

Complex I would say, they are migratiing on using Unified Plan and simulcast for both, which is a big change.

1 Like

Here is the error I get in FF v72.0.2 (64-bit) on MacOS 10.14.5 (Mojave):

And here is what i get in FF v75.0 (64-bit) on MacOS 10.14.5 (Mojave):

Looks to be the same error.

Here is some more output from FF 75. This is when I am in the room on FF, and then a new person joins. Prior to them joining my video and audio appear to be working fine. As soon as they join, they both blank out.

This made me snicker.

1 Like

Hello,
I am getting the same issue on Firefox 75 (64-bit) in Mac Mojave. When I try to screenshare I can see the application being shared in the firefox window (the side of user who is sharing), but the other audience in the meeting aren’t seeing the content being shared. This works when shared from Chrome, but not from Firefox. It’s the latest version I downloaded today as most of users in our company are prohibited from using Chrome and so, use Firefox as default user.

I’d like to share some experience of mine:
I’m using xUbuntu desktop 18.04 with dual monitors, and found that with chrome-based browsers like Brave and Vivaldi (don’t have Chromium/Chrome installed) I just could not get the microphone to work so I decided to try meet.jit.si with Firefox (latest 64bit 75.0)
Found that with it audio and video work as expected, the latency seems to be low and image quality very good.
The only problem at the moment with FF is with screen sharing:

  • on first attempt pressing the button on bottom left corner a window is opened where one can choose the application or screen to share from a list; after selecting a window the sharing works, it is shown on remote (verified this locally with a laptop and also with a friend of mine miles away); no button to stop the sharing is shown on the screen like in e.g. Vivaldi (bottom center)
  • pressing the button a second time in order to start a new share, it seems not to do anything, no popup window for selection etc shown anymore…
    Furthermore: the selection of screen/window to share is a bit restricted or confusing; I normally have some 8 virtual desktops on the screen and several applications open, dispersed on the desktops, and the list seems to show them all but there seems not to be an option to choose any another virtual desktop as such.
    I’ve also tried e.g. zoom conferencing and in it the selection of screen to share is much easier and intuitive, there is also the possibility to choose another desktop for sharing.

Otherwise I can verify that it works on Firefox, if not perfectly. Still need some time to test more, and maybe it is also the moment to install Chrome/Chromium just for the purpose.