SIP Video Gateway with Jibri


#1

Hi,

I need to integrate SIP Video functionality with the Jitsi Meet conference. After searching available threads, I see that Jibri has SIP Gateway functionality (https://github.com/jitsi/jitsi-meet/blob/master/doc/sipgw-config.md). However, I don’t find where can we configure a SIP account to be called in, like we do in Jigasi. Can someone help and setup me with this ?

@bbaldino @damencho may be you guys can shed some light.

Thanks,
Abhijit


#2

According to the link provided by @abhijitnathwani, I’ve made configuration changes. But after adding jitsi-meet configuration as mentioned in the link, the invite icon get disappeared and the options start recording and start live streaming get also disabled. Can you guys provide me more guidance on this @bbaldino & @damencho ?


#3

This is because of enableUserRolesBasedOnToken: true, currently the sip video gw part works only when using jwt because of the peopleSearchUrl.


#4

I changed enableUserRolesBasedOnToken: true. And also installed jitsi-meet-tokens plugin for authentication. I’ve followed the steps given in (https://github.com/jitsi/lib-jitsi-meet/blob/master/doc/tokens.md#example-token). After making all changes, I generated token with payload and headers provided in given link. But while joining a room with jwt token, I’m getting error on browser console “connection.passwordRequired” and get my authentication failed. Can you help me to resolve this?


#5

Hum, so debugging this is not easy. You need to open the developer tools, Network tab and check the bosh network requests and the errors returned, there will be a reason for the token error, what does that says?


#6

I’m able to join the meeting with providing jwt token. But still Add People dialog service is not appearing, though I’ve followed all the steps given in the link https://github.com/jitsi/jitsi-meet/blob/master/doc/sipgw-config.md

When I hit url https://api.10.115.3.53/testpath/searchpeople?query=testroomname&queryTypes=[“conferenceRooms”]&jwt=somejwt, it just loading and then says it is unreachable. I guess it is issue of domain name. Ip provided here is private. Do we require public ip/domain to make it work?


#7

Hi @damencho,

Can you please elaborate on setting this up? We have implemented the JWT token, but the Add people dialog is not seen anywhere.

Thanks,
Abhijit


#8

So api.10.115.3.53 seems like not a valid dns, so it will give an error…


#9

Hi @damencho
The complete setup is in our local environment. Hence that IP is resolved in the local system. Is it making any calls to the network outside?
I believe it should work as domains as focus.10.115.3.53 and auth.10.115.3.53 do get resolved and we don’t have any error there.

Thanks,
Abhijit


#10

The api address needs to be resolved, the jitsi-meet client does xhr to retrieve rooms/people for add people dialog. It doesn’t need to be same server or subdomain.


#11

I tried with public IP. It’s still not working with api.<public_ip>. It should work. I’m getting same error “ERR_NAME_NOT_RESOLVED”. And if it is not then will it work with valid DNS ?


#12

Api.64… is not a dns name. You need to put something meaningful which the browser can connect to.


#13

I have setup one VM which is in our local DNS. The domain name of VM is cvm1104.domain.com. Now I’ve installed jitsi on it. And I’ve done all the configuration to enable Add People Service. The (+) icon is ebnabled on UI. But I’m facing the same issue while inviting people on conference. I’m getting same error “ERR_NAME_NOT_RESOLVED”. Now this should not be due to invalid DNS. Because the server is now in our local DNS. How can we debug this issue?

Also, I want to know what does Add People service do? When Add People Dialog appears, Is there any list of rooms should be appeared in dropdown list? How peopleSeearchUrl works in SIP video gateway configuration? Can you please elaborate?


#14

Hi @damencho

Can you please help with this? We are really stuck here.

Thanks,
Abhijit


#15

In another screenshot in another post, not sure where it is I saw you were using api.cvm1104.domain.com not cvm1104.domain.com
Founded here: [jitsi-users] "Add People" jibri configuration?
You can try opening the link from the error, can you open it?


#16

Hi @damencho,

No. I’m not able to open https://api. cvm1104.domain.com/testpath/search?queryparams in browser. As per the configurations given in this link: [https://github.com/jitsi/jitsi-meet/blob/master/doc/sipgw-config.md]
I’ve given peopleSearchUrl in this way: https://api.cvm1104.domain.com/testpath/search. So when I add text in Add People dialog, in background this peopleSerachUrl with query parameters will be called.

Is there any way to make it running through api.domain.com?


#17

Hi @damencho,

I have same query on api.domain. Is there any other configuration needed to make server up on api.domain??

I have configured server based on this link https://github.com/jitsi/jitsi-meet/blob/master/doc/sipgw-config.md in my local network with proper domain name. Note, domain is only accessible with in my local network.

I am getting ERR_NAME_NOT_RESOLVED on this URL https://ap.domain.com/testpath/search?queryparams. And when i hit this URL in separate tab, it throws “site cant reachable” error.

I would appreciated if you could help.


#18

So, the error means you hadn’t setup the dns correctly.


#19

This url is configired in config.js so you can set it however you want.


#20

Hi @damencho,

I’ve modified the peopleSearchUrl. I removed “api.” from the url. So now my url is in this form: https://cvm1104.domain.com/testpath/serachpeople. Now by adding the people on Jitsi, I’m getting 404 not found for this given url. I’ve also attached the snapshot regarding the configuration.

image

Is it necessary to mention api.domain.com in peopleSearchUrl? How can we make chnages to run any service on api domain?