SIP outgoing call and soft keyboard

Hi, we are using Jitsi as VOIP softphone. Most of the functions are running fine, but if I have an active call and I have to make a selection in the receiver menu via the soft keyboard, it does not work. I can press a number and there is also a sound but it is not registered by the receiver. No selections can be made. Does anyone have a solution?

Regards,
Boris

Hi and welcome.

Are you talking about IVR menus and selections while in the call, like a bank IVR?

Yes I do.

Then most probably you need to adjust your sip account DTMF settings according to what your provider supports.


If they support RTP this is the safest choice. Inband can break because of different codecs.
Try setting it to RTP and try again.

The provider told me that we need to use RTP and Inband. I adjust Jitsi to use “Auto” or “RTP” but with no success. Any kinds of hints?

Sorry, nothing we can do. It may happen they don’t like the duration of the tones or the pauses between them … Not sure currently whether we have settings for those … But problems like this end up to be debugged between the client and the operator …
The only other option I can see, if you find something else that works and make a tcpdump of traffic of successful and unsuccessful session, send the dumps and I can take a quick look to check is there anything obvious …