SIP dialin to conference ends with "Initialising Call…"

We have a setup with SIP dialin into Jitsi Meet conferences with Jigasi. This worked in the past. I think as of jitsi-meet 2.0.7416 from 2022-06-16 this fails. It may be releated to an update. But it’s not sure.


The participant calls the phone number, enters the PIN and enters the conference room.
In the conference, the label “Initialising Call…” is shown, the participant heres the ringing tone.

After about 15 seconds, the participant disconnects.


There is one entry in the Jigasi log, which is suspicious.

Jun 24, 2022 10:53:59 AM$JingleIqSetRequestHandler handleIQRequest
SEVERE: Error while handling incoming class org.jitsi.xmpp.extensions.jingle.JingleIQ packet:
java.lang.IllegalStateException: Extension element is not of expected class 'org.jitsi.xmpp.extensions.jitsimeet.StartMutedPacketExtension', because there is no according extension element provider registered with ProviderManager for {}startmuted. WARNING: This indicates a serious problem with your Smack setup, probably causing Smack not being able to properly initialize itself.
        at org.jivesoftware.smack.util.XmppElementUtil.castOrThrow(
        at org.jivesoftware.smack.packet.StanzaView.getExtension(
        at org.jivesoftware.smack.AbstractXMPPConnection$
        at org.jivesoftware.smack.AsyncButOrdered$
        at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(
        at java.base/java.util.concurrent.ThreadPoolExecutor$
        at java.base/

I have no idea, where to debug the problem. Mabe you could give me a hint?


Jigasi, Prosody, Jicofo and Jitis-Meet are running on the same server with Debian 11 and OpenJDK 11.

Which jigasi version is that?

We follow the stable branch. So it’s

ii  jigasi                          1.1-259-g25c51d6-1           all          Jitsi Gateway for SIP

everything else

ii  jitsi-meet                      2.0.7439-1                   all          WebRTC JavaScript video conferences
ii  jitsi-meet-prosody              1.0.6260-1                   all          Prosody configuration for Jitsi Meet
ii  jitsi-meet-web                  1.0.6260-1                   all          WebRTC JavaScript video conferences
ii  jitsi-meet-web-config           1.0.6260-1                   all          Configuration for web serving of Jitsi Meet
ii  jitsi-meet-prosody              1.0.6260-1                   all          Prosody configuration for Jitsi Meet
ii  prosody                         0.11.9-1~bpo10+1             amd64        Lightweight Jabber/XMPP server
ii  jicofo                          1.0-900-1                    all          JItsi Meet COnference FOcus

That is strange, we haven’t seen that with latest one … Ooo, that can be a bug … need to check the code. My guess is that if you enable muted support in jigasi it will work.

Ahh. Stupid question: How do I enable muted support in jigasi?


Can you please open an issue in the jigasi github tracker so we don’t forget about it, I’ll be away from the PC for a few days, but when I’m back I will work on a fix. Thank you.

With this setting, the SIP participant joins the conference as expected. But he is now muted of course and I didn’t find a way to unmute him. But this might be Asterisk not understanding the message?

But better than before and I will write the issue tomorrow.

Have a nice time off.

Yep, it needs a some ivr managing ang getting some sip info messages.

There are some examples here, but it is not trivial moving this to asterisk, but gives mute/unmute option for dial in participants