Sip Dial-in

Hello,

I have a self-hosted jitsi with jigasi.
I try to activate the calls in jitsi by following these instructions https://evilcreamsicle.com/index.php/2018/03/28/jitsi-meet-w-call-in-and-active-directory/

I start in asterisk and I encounter a problem in the dialplan in step 7

exten => 9999.7, Macro (exten-vm, novm, 9999,0,0,0)

What should the macro ‘exten-vm’ do?

[ext-local]
exten => 9999.1, Set (__ RINGTIMER = {IF ( [" {DB (AMPUSER / 9999 / ringtimer)}"> "0"]? {DB (AMPUSER / 9999 / ringtimer)}: { RINGTIMER_DEFAULT})}) exten => 9999.2, Read (Pin, "custom / my_system_recording") exten => 9999.3, Verbose (result is: {Pin})
exten => 9999.4, AGI (jitsi_curling.sh, {Pin}) exten => 9999.5, Verbose (result is: {JITSI})
exten => 9999.6, SIPAddHeader (Jitsi-Conference-Room: {JITSI}) exten => 9999.7, Macro (exten-vm, novm, 9999,0,0,0) exten => 9999.8 (dest), Set (__ PICKUPMARK =) exten => 9999.9, Goto ( {IVR_CONTEXT}, return, 1)
exten => 9999, hint, SIP / 9999 & Custom: DND9999, CustomPresence: 9999

I use asterisk 13 and jigasi 1.0-235.
Outgoing conference calls from jitsi - jigasi work.
Thanks for all help

Hi @ajj75012 :slight_smile:

did you find any solution?
jitisi outgoing calls are working, but when i dial in, then it keeps ringing and jitisi is not taking the call.

Best regards,
Ralph

Hi ralphmuc,

If you have not already done so, check your SIP registration in Asterisk with ‘sip show registry’
I have not yet found a solution. I’m looking for help, I don’t know where to look.

I always have an error in step 7 when there is an incoming call.
Asterisk console:

– Executing [9999@ovh-sip:3] Verbose(“SIP/trunk-ovh-00000001”, “result is: 246460196”) in new stack
result is: 246460196
– Executing [9999@ovh-sip:4] AGI(“SIP/trunk-ovh-00000001”, “jitsi_curling.sh,246460196”) in new stack
– Launched AGI Script /var/lib/asterisk/agi-bin/jitsi_curling.sh
– <SIP/trunk-ovh-00000001>AGI Script jitsi_curling.sh completed, returning 0
– Executing [9999@ovh-sip:5] Verbose(“SIP/trunk-ovh-00000001”, “result is: testxxx”) in new stack
result is: testxxx
– Executing [9999@ovh-sip:6] SIPAddHeader(“SIP/trunk-ovh-00000001”, “Jitsi-Conference-Room: testxxx”) in new stack
[Apr 28 11:43:01] WARNING[1234][C-00000002]: pbx.c:2927 pbx_extension_helper: No application ‘Macro’ for extension (ovh-sip, 9999, 7)
== Spawn extension (ovh-sip, 9999, 7) exited non-zero on ‘SIP/trunk-ovh-00000001’

Thank you :slight_smile:
I was able to fix it… there was a mistake in adding the JITSI Conference Room into the sip header.

Best Regards
Ralph