[sip-comm] Video Quality in SC


#1

Hi

I have been using SIP Communicator for some time now, and have found it to be very good.
Is there a way to improve the Video Quality in SIP Communicator.
I have noticed that H.261 Video Codec is not working at all, and H.264 is not giving me a good Video quality. Whereas, on the same network, when I use X-Lite, I can see a better quality video.

Can you please help me out with some settings I have to make the Video quality better.

I am using a Windows Vista Machine.

TIA.

Regards,
Aman

**************** CAUTION - Disclaimer *****************
This e-mail contains PRIVILEGED AND CONFIDENTIAL INFORMATION intended solely
for the use of the addressee(s). If you are not the intended recipient, please
notify the sender by e-mail and delete the original message. Further, you are not
to copy, disclose, or distribute this e-mail or its contents to any other person and
any such actions are unlawful. This e-mail may contain viruses. Infosys has taken
every reasonable precaution to minimize this risk, but is not liable for any damage
you may sustain as a result of any virus in this e-mail. You should carry out your
own virus checks before opening the e-mail or attachment. Infosys reserves the
right to monitor and review the content of all messages sent to or from this e-mail
address. Messages sent to or from this e-mail address may be stored on the
Infosys e-mail system.
***INFOSYS******** End of Disclaimer ********INFOSYS***


#2

Well its exactly the same as the 2169 build - i did not look at the logs but i have just as many warnings as in 2169.
Maybe worse. The SIP presence doesnt work - at least with our TrixBox (Asterisk) server. 2169 worked in this regard.

I tried with ALSA (no PulseAudio installed). I did not try it with Ubuntu 9.10/PulseAudio yet. But in my opinion it should work with ALSA, because that is the de facto standard linux sound system nowadays. Not all distros (even Kubuntu and Xubuntu have ALSA by default) have PulseAudio as default.


#3

Well its exactly the same as the 2169 build - i did not look at the logs but i have just as many warnings as in 2169.
Maybe worse. The SIP presence doesnt work - at least with our TrixBox (Asterisk) server. 2169 worked in this regard.

I tried with ALSA (no PulseAudio installed). I did not try it with Ubuntu 9.10/PulseAudio yet. But in my opinion it should work with ALSA, because that is the de facto standard linux sound system nowadays. Not all distros (even Kubuntu and Xubuntu have ALSA by default) have PulseAudio as default.

···

--
Kertesz Laszlo <laszlo.kertesz@infobenefic.ro>


#4

I did a test on Xubuntu 9.10. Here i had the following issue:

Some of the text input boxes are not shown at all. I deleted the .sip-communicator folder previously to try it from scratch. But in the first menu, where i was supposed to input the account(s) names/passwords only the passwords fields showed up. The user names had no input boxes at all.
In the previous version there was the same problem, i thought it may be related to the user settings, but they persisted after deleting the .sip-communicator folder and restarting the program.
This is a blocking issue.

Attached screenshot + error log.

I also tested the 2314 build with SIP on ALSA on Ubuntu (Gnome) 9.04 /ALSA (only). All seems well now. The sound level indicator is very responsive, i like it. The sound quality is good. For now i did an echo test only on the local network. Later i will do a VPN test.

sip-communicator0.log.0 (99.1 KB)


#5

I had a conversation in Sip Communicator on Ubuntu 9.04/ALSA, SIP account on local SIP server (Trixbox/Asterisk). The other end was connected via VPN from an Ubuntu 8.10 OS/Linphone. Later i did a call with Sflphone to the same computer.

I observed an issue when talking with Sip Communicator that wasnt present in the Sfplhone conversation, so its not packet loss over VPN/server side issue:

While the overall sound quality was good, there was stuttering/sound "clipping" at times - it lasted only for fractions of seconds and occured mainly on beginning of words, at least thats how i perceived it. It was a bit annoying, at times i didnt understand what he spoke. Echo cancellation/silence detection was off in Sip Communicator.
The call with Sflphone (my side)/Linphone (other side) went without this stuttering issue.

PS. I tried 2315 on the Xubuntu (Xfce) 9.10 machine, with the latest Java ( 6.17, upgraded from 6.15) - its the same outcome, those name input boxes are missing. If i close the first menu and try to add manually users later, the boxes are still missing. In the older versions (2310 if i remember correctly) the boxes were there on Xubuntu.
In Ubuntu 9.04 (Gnome) those boxes were never missing.


#6

Hi Kertesz,

The problem comes from the Sip-Communicator custom LookAndFeel. For more information, you can follow the dev mailing-list and more precisely discussion https://sip-communicator.dev.java.net/servlets/ReadMsg?list=dev&msgNo=7623.

I hope it will be resolved soon.

Regards,
Vincent

Kertesz Laszlo wrote:

···

I did a test on Xubuntu 9.10. Here i had the following issue:

Some of the text input boxes are not shown at all. I deleted the .sip-communicator folder previously to try it from scratch. But in the first menu, where i was supposed to input the account(s) names/passwords only the passwords fields showed up. The user names had no input boxes at all. In the previous version there was the same problem, i thought it may be related to the user settings, but they persisted after deleting the .sip-communicator folder and restarting the program. This is a blocking issue.

Attached screenshot + error log.

I also tested the 2314 build with SIP on ALSA on Ubuntu (Gnome) 9.04 /ALSA (only). All seems well now. The sound level indicator is very responsive, i like it. The sound quality is good. For now i did an echo test only on the local network. Later i will do a VPN test.

------------------------------------------------------------------------

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: users-help@sip-communicator.dev.java.net


#7

Thanks for the response. Is there a simple way to disable the custom look&feel
and to use the default Java look (metal or how it is called)? Editing some config files its ok for me. But not compiling.

Regards,
Kertesz Laszlo

···

On Wed, 06 Jan 2010 10:53:56 +0100 Vincent Lucas <lucas@clarinet.u-strasbg.fr> wrote:

Hi Kertesz,

The problem comes from the Sip-Communicator custom LookAndFeel. For more
information, you can follow the dev mailing-list and more precisely
discussion
https://sip-communicator.dev.java.net/servlets/ReadMsg?list=dev&msgNo=7623.

I hope it will be resolved soon.

Regards,
Vincent

Kertesz Laszlo wrote:
> I did a test on Xubuntu 9.10. Here i had the following issue:
>
> Some of the text input boxes are not shown at all. I deleted the .sip-communicator folder previously to try it from scratch. But in the first menu, where i was supposed to input the account(s) names/passwords only the passwords fields showed up. The user names had no input boxes at all.
> In the previous version there was the same problem, i thought it may be related to the user settings, but they persisted after deleting the .sip-communicator folder and restarting the program.
> This is a blocking issue.
>
> Attached screenshot + error log.
>
>
> I also tested the 2314 build with SIP on ALSA on Ubuntu (Gnome) 9.04 /ALSA (only). All seems well now. The sound level indicator is very responsive, i like it. The sound quality is good. For now i did an echo test only on the local network. Later i will do a VPN test.
>
>
> ------------------------------------------------------------------------
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: users-help@sip-communicator.dev.java.net

--
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

--
Kertesz Laszlo <laszlo.kertesz@infobenefic.ro>


#8

I tested the 2320 on both Xubuntu 9.10 (PulseAudio) and ubuntu 9.04 (ALSA).

The sound quality seems better now (i had the impression the stuttering is gone for the most part), but i cannot say more about it until i test it some more.

The GUI is fixed. On Xubuntu its the default Java look now, all input fields are useable. What i would like is an option to switch looks between the default java and the sip communicator look (when the sip communicator look will be fixed).

Also, i did try to initiate ZRTP crypted conversations - 2 SIP accounts on our local (Trixbox/Asterisk) server. I tried checking the same ZRTP options on both ends, ticking everything but the connetions were made without encryption. I enabled ZRTP transport on both users when logging in.

My question is: how can i initiate ZRTP conversation between 2 SIP accounts?
Is that functionality enabled at all?


#9

Hi,

yes this functionality is enabled and working. In your situation the
problem is asterisk. As asterisk is working as men in the middle :slight_smile: it
doesn't support zrtp and so it truncates zrtp messages and is not
passing through rtp packets, but rewrites them unfortunately for now
zrtp cannot be used with asterisk. There are of course some patches
which aim to make it work :
http://zfoneproject.com/docs/asterisk/man/html/u_guide.html.

damencho

···

On Thu, Jan 7, 2010 at 4:53 PM, Kertesz Laszlo <laszlo.kertesz@infobenefic.ro> wrote:

I tested the 2320 on both Xubuntu 9.10 (PulseAudio) and ubuntu 9.04 (ALSA).

The sound quality seems better now (i had the impression the stuttering is gone for the most part), but i cannot say more about it until i test it some more.

The GUI is fixed. On Xubuntu its the default Java look now, all input fields are useable. What i would like is an option to switch looks between the default java and the sip communicator look (when the sip communicator look will be fixed).

Also, i did try to initiate ZRTP crypted conversations - 2 SIP accounts on our local (Trixbox/Asterisk) server. I tried checking the same ZRTP options on both ends, ticking everything but the connetions were made without encryption. I enabled ZRTP transport on both users when logging in.

My question is: how can i initiate ZRTP conversation between 2 SIP accounts?
Is that functionality enabled at all?

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: users-help@sip-communicator.dev.java.net


#10

I tried ZRTP between 2 registrarless SIP accounts. But nothing happened, just plain unencrypted calls.

If someone can, please explain to me (and the others reading this list) what i am supposed to do exactly.
I set bot users to enable support for call encryption+indicate support of zrtp data. Set standard zrtp on both. Nothing happened.
What else i have to do in order to make it work?


#11

Hi again,

indeed it was a problem coming from one of the latest changes. It
should be ok now - build 2322.

The only thing that should be done is configure the accounts (the
steps you described in your mail). After a successful establishing of
a zrtp session you will hear a beeping sound and on the call window
you can see the phrase which you can confirm with the other side of
the call, if phrases are the same everything is fine. If I'm missing
something others can correct me :slight_smile:

Thanks for testing and spotting the problem
damencho

···

On Thu, Jan 7, 2010 at 5:37 PM, Kertesz Laszlo <laszlo.kertesz@infobenefic.ro> wrote:

I tried ZRTP between 2 registrarless SIP accounts. But nothing happened, just plain unencrypted calls.

If someone can, please explain to me (and the others reading this list) what i am supposed to do exactly.
I set bot users to enable support for call encryption+indicate support of zrtp data. Set standard zrtp on both. Nothing happened.
What else i have to do in order to make it work?

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: users-help@sip-communicator.dev.java.net


#12

Ok, thanks. Its working now. Also, i had 2 SIP accounts on one of the computers: one for the Asterisk server and the one serverless. I found that i have to assign a different port (i assigned 5070) to the serverless SIP account (different from 5060, the one assigned to the Asterisk account) to make it work reliably. Also, i set the other computers serverless account to 5070 also, just in case.

···

On Fri, 8 Jan 2010 11:01:04 +0200 Damian Minkov <damencho@sip-communicator.org> wrote:

Hi again,

indeed it was a problem coming from one of the latest changes. It
should be ok now - build 2322.

The only thing that should be done is configure the accounts (the
steps you described in your mail). After a successful establishing of
a zrtp session you will hear a beeping sound and on the call window
you can see the phrase which you can confirm with the other side of
the call, if phrases are the same everything is fine. If I'm missing
something others can correct me :slight_smile:

Thanks for testing and spotting the problem
damencho

On Thu, Jan 7, 2010 at 5:37 PM, Kertesz Laszlo > <laszlo.kertesz@infobenefic.ro> wrote:
> I tried ZRTP between 2 registrarless SIP accounts. But nothing happened, just plain unencrypted calls.
>
> If someone can, please explain to me (and the others reading this list) what i am supposed to do exactly.
> I set bot users to enable support for call encryption+indicate support of zrtp data. Set standard zrtp on both. Nothing happened.
> What else i have to do in order to make it work?
>
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: users-help@sip-communicator.dev.java.net

--
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

--
Kertesz Laszlo <laszlo.kertesz@infobenefic.ro>


#13

Setup:
SIP/Asterisk server
2 users connected via VPN (different VPN instances, diffrent locations) to the servers network.
I used Sip Communicator (build 2323 on Xubuntu 9.10/PulseAudio - and through bluetooth handsfree), the other his nokia E70 phone's SIP client, both connected to the server.
The connecting from either side was smooth, we heard each other fine, sound quality was very good.
The issue:

After a few minutes i did not hear him anymore. I looked to the Sip Communicators interface, my mic input showed up, but nothing incoming. I saw that both CPUs are fully loaded, the java process was at 180 % according to top.
I killed the process, restarted the program, called him back. He told me he was hearing me fine. After 2-3 minutes the same happened. I killed java again, launched Linphone, called him back again and everything was fine.
So this rules out server/connection-related problems.

I reproduced the issue:

Called the echo test service on the server and let it run. After a few minutes the incoming audio dropped. I did 2 tests: one with bluetooth handsfree, the other with the internal speakers/microphone of the laptop.

The same happened both times, with one difference: When using the built in card, no CPU usage increase happened, in fact the usual java process's ~30% dropped to ~15%, but the rest of the symptoms were the same. So this is not caused by the bluetooth-pulseaudio problem (apart from the CPU increase of the java process).

The first call was made with the PortAudio devices set to default. The rest of them with the devices explicitly set to pulse. I saw (heard) no difference.

I attached the 2 logs i found, but they are very big (~4.8 MB or so). Maybe someone can decypher them...

PS: I have 1 Yahoo, 1 Gmail, 1 Jabber, 1 SIP accounts in Sip Communicator. The logs grow at an alarming rate, most of the messages seem to be SIP related even when idle.

Regards,
Kertesz Laszlo

sip-communicator0.log.1.zip (259 KB)

sip-communicator0.log.2.zip (73.6 KB)


#14

I did some additional testing. I reproduced the issue between 2 computers, serverless accounts.

It only occurs on Ubuntu 9.10 (Xubuntu if thats relevant) with PulseAudio.
Test setup: my laptop (Xubuntu 9.10/PulseAudio/Intel Core2Duo / Sun Java 1.6.0.17) connected via wireless, my desktop computer (Ubuntu 9.04 / 1.6.0.16 / ALSA / AMD). The wireless router and the desktop is connected in the same switch. Serverless accounts on both computers, zrtp on/off made no difference on the outcome.
The test:
1. Sip Communicator - Sip Communicator: Connected the 2 computers, let them be. After 10 minutes or so, the laptop's java process begin to increase in CPU usage (normally was around 30%) - 50% and then 100 and ~180%. Lost the incoming audio, the outgoing was fine. Had to kill the java process.
Tried with and without zrtp, it was th same result. I tested it with bluetooth handsfree and without (internal audio only), no difference.
I looked at the in/out streams of PulseAudio and the incoming was flickering, the outgoing was stable.

2. Sip Communicator - Sflphone: I ran Sflphone on the laptop, Sip Communicator on the desktop (serverless accounts on both computers). After 3 hours i disconnected them. Everything was working fine. So with Ubuntu 9.04 and ALSA the audio handling seems stable.

Conclusion - it requires some more testing as i had access to only 1 Ubuntu 9.10 machine - but it seems something is wrong here, maybe PulseAudio related?


#15

Hi,

The problems you describe are not dependent to zrtp or what is the other client.
Could you please test with build 2326. It looks like portaudio problem
and 2326 claims to fix those problems.

Thanks
damencho

···

On Mon, Jan 11, 2010 at 12:47 PM, Kertesz Laszlo <laszlo.kertesz@infobenefic.ro> wrote:

I did some additional testing. I reproduced the issue between 2 computers, serverless accounts.

It only occurs on Ubuntu 9.10 (Xubuntu if thats relevant) with PulseAudio.
Test setup: my laptop (Xubuntu 9.10/PulseAudio/Intel Core2Duo / Sun Java 1.6.0.17) connected via wireless, my desktop computer (Ubuntu 9.04 / 1.6.0.16 / ALSA / AMD). The wireless router and the desktop is connected in the same switch. Serverless accounts on both computers, zrtp on/off made no difference on the outcome.
The test:
1. Sip Communicator - Sip Communicator: Connected the 2 computers, let them be. After 10 minutes or so, the laptop's java process begin to increase in CPU usage (normally was around 30%) - 50% and then 100 and ~180%. Lost the incoming audio, the outgoing was fine. Had to kill the java process.
Tried with and without zrtp, it was th same result. I tested it with bluetooth handsfree and without (internal audio only), no difference.
I looked at the in/out streams of PulseAudio and the incoming was flickering, the outgoing was stable.

2. Sip Communicator - Sflphone: I ran Sflphone on the laptop, Sip Communicator on the desktop (serverless accounts on both computers). After 3 hours i disconnected them. Everything was working fine. So with Ubuntu 9.04 and ALSA the audio handling seems stable.

Conclusion - it requires some more testing as i had access to only 1 Ubuntu 9.10 machine - but it seems something is wrong here, maybe PulseAudio related?

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: users-help@sip-communicator.dev.java.net


#16

I tested briefly the 2326 build. I connected to echo test, did fine about 30 minutes. The audio losing issue seems fixed.

The issue withe the CPU usage remains, but it is related somehow to powersaving. The fact is that CPU usage of the java process now climbs to about 100% (not 180 like before) if there is a call in progress and the laptops monitor shuts down. When i press a key or whatever to wake it up, the java process is at ~150% and decreases to 100 (more likely a temporary spike). I can close the call but it remains at 100% until i exit the program. (100% on a dual core cpu).

···

On Mon, 11 Jan 2010 12:57:01 +0200 Damian Minkov <damencho@sip-communicator.org> wrote:

Hi,

The problems you describe are not dependent to zrtp or what is the other client.
Could you please test with build 2326. It looks like portaudio problem
and 2326 claims to fix those problems.

Thanks
damencho

On Mon, Jan 11, 2010 at 12:47 PM, Kertesz Laszlo > <laszlo.kertesz@infobenefic.ro> wrote:
> I did some additional testing. I reproduced the issue between 2 computers, serverless accounts.
>
> It only occurs on Ubuntu 9.10 (Xubuntu if thats relevant) with PulseAudio.
> Test setup: my laptop (Xubuntu 9.10/PulseAudio/Intel Core2Duo / Sun Java 1.6.0.17) connected via wireless, my desktop computer (Ubuntu 9.04 / 1.6.0.16 / ALSA / AMD). The wireless router and the desktop is connected in the same switch. Serverless accounts on both computers, zrtp on/off made no difference on the outcome.
> The test:
> 1. Sip Communicator - Sip Communicator: Connected the 2 computers, let them be. After 10 minutes or so, the laptop's java process begin to increase in CPU usage (normally was around 30%) - 50% and then 100 and ~180%. Lost the incoming audio, the outgoing was fine. Had to kill the java process.
> Tried with and without zrtp, it was th same result. I tested it with bluetooth handsfree and without (internal audio only), no difference.
> I looked at the in/out streams of PulseAudio and the incoming was flickering, the outgoing was stable.
>
> 2. Sip Communicator - Sflphone: I ran Sflphone on the laptop, Sip Communicator on the desktop (serverless accounts on both computers). After 3 hours i disconnected them. Everything was working fine. So with Ubuntu 9.04 and ALSA the audio handling seems stable.
>
> Conclusion - it requires some more testing as i had access to only 1 Ubuntu 9.10 machine - but it seems something is wrong here, maybe PulseAudio related?
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: users-help@sip-communicator.dev.java.net

--
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

--
Kertesz Laszlo <laszlo.kertesz@infobenefic.ro>


#17

I did further testing (builds up to 2334) with echo test:

If i used the internal audio (Xubuntu 9.10/PulseAudio/Dell D630) the echo tests worked without problems.
If i used bluetooth-connected handsfree, after a while (8-10 minutes to 20 minutes) the java process started to increase in CPU usage to 100+%. Thre were 2 variations:
- the output stream stopped (only the mic input was shown), no echo was coming back - few cases,
- the sound was ok (both outgoing and receiving) but the CPU usage was above 100% (about 101-110). I found a workaround to this: toggled hold/unhold and everything was back to normal, CPU usage fell back to ~30% . This was in the majority of cases.

Also, when CPU % was above 100%, i could not close the call, nothing happened when i pressed the hang up button. But if i pressed the hang up button then i opened pavucontrol and terminated any of the streams, the call closed instantly.