[sip-comm] Testing Sound


#1

I have just installed SIP Communicator on Ubuntu 9.10 64 bit version and I
am wondering how to go about testing the sound capabilities before trying to
establish a communication session. Testing video was obvious since I could
see my picture on the options screen, but testing audio was not so obvious.
I would have hoped that I could just speak into the microphone and hear my
voice echoed back to me.

Doing this testing is important to me as I have always had problems with
sound on Linux and want to be sure I have it working at least locally.

Regards

Jonathan Gossage


#2

Hello,

Jonathan Gossage wrote:

I have just installed SIP Communicator on Ubuntu 9.10 64 bit version and I am wondering how to go about testing the sound capabilities before trying to establish a communication session. Testing video was obvious since I could see my picture on the options screen, but testing audio was not so obvious. I would have hoped that I could just speak into the microphone and hear my voice echoed back to me.

Doing this testing is important to me as I have always had problems with sound on Linux and want to be sure I have it working at least locally.

I also think that the lack of feedback on the audio setup is problematic in terms of usability. Nevertheless, you can test your configuration by placing a call to a echo-test server, like for example sip:echo@iptel.org.

Cheers,
Martin

···

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: users-help@sip-communicator.dev.java.net


#3

Thanks, that should get me started.

Jonathan Gossage

···

On Thu, Nov 12, 2009 at 6:44 PM, Martin André <mandre@dev.java.net> wrote:

Hello,

Jonathan Gossage wrote:

I have just installed SIP Communicator on Ubuntu 9.10 64 bit version and I
am wondering how to go about testing the sound capabilities before trying to
establish a communication session. Testing video was obvious since I could
see my picture on the options screen, but testing audio was not so obvious.
I would have hoped that I could just speak into the microphone and hear my
voice echoed back to me.

Doing this testing is important to me as I have always had problems with
sound on Linux and want to be sure I have it working at least locally.

I also think that the lack of feedback on the audio setup is problematic in
terms of usability. Nevertheless, you can test your configuration by placing
a call to a echo-test server, like for example sip:echo@iptel.org<sip%3Aecho@iptel.org>
.

Cheers,
Martin

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: users-help@sip-communicator.dev.java.net


#4

I am having serious problems trying to understand how to do anything with
SIP communicator. It was suggested that I place a call to
sip:echo@iptel.com<sip%3Aecho@iptel.com>but I have been completely
unable to figure out how to do this. I have been
unable to create any SIP account and have no idea how to proceed from here.
Is there anything available that can guide me in getting started?

Jonathan Gossage

···

On Thu, Nov 12, 2009 at 7:00 PM, Jonathan Gossage <jgossage@gmail.com>wrote:

Thanks, that should get me started.

Jonathan Gossage

On Thu, Nov 12, 2009 at 6:44 PM, Martin André <mandre@dev.java.net> wrote:

Hello,

Jonathan Gossage wrote:

I have just installed SIP Communicator on Ubuntu 9.10 64 bit version and
I am wondering how to go about testing the sound capabilities before trying
to establish a communication session. Testing video was obvious since I
could see my picture on the options screen, but testing audio was not so
obvious. I would have hoped that I could just speak into the microphone and
hear my voice echoed back to me.

Doing this testing is important to me as I have always had problems with
sound on Linux and want to be sure I have it working at least locally.

I also think that the lack of feedback on the audio setup is problematic
in terms of usability. Nevertheless, you can test your configuration by
placing a call to a echo-test server, like for example sip:echo@iptel.org<sip%3Aecho@iptel.org>
.

Cheers,
Martin

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: users-help@sip-communicator.dev.java.net


#5

Hey again,

Jonathan Gossage wrote:

I am having serious problems trying to understand how to do anything with SIP communicator. It was suggested that I place a call to sip:echo@iptel.com <mailto:sip%3Aecho@iptel.com> but I have been completely unable to figure out how to do this. I have been unable to create any SIP account and have no idea how to proceed from here. Is there anything available that can guide me in getting started?

You'll first have to create an account at some SIP service provider, iptel.org is one of them (I'm personally using ippi.fr, there are plenty of other, I'll let you search the web). Then, configure SIP Communicator to use this newly created account (Tools > Options > Accounts > Add). You should then be able to place SIP calls.

Hope this helps,
Martin

···

Jonathan Gossage

On Thu, Nov 12, 2009 at 7:00 PM, Jonathan Gossage <jgossage@gmail.com > <mailto:jgossage@gmail.com>> wrote:

    Thanks, that should get me started.

    Jonathan Gossage

    On Thu, Nov 12, 2009 at 6:44 PM, Martin André <mandre@dev.java.net > <mailto:mandre@dev.java.net>> wrote:

        Hello,

        Jonathan Gossage wrote:

            I have just installed SIP Communicator on Ubuntu 9.10 64 bit
            version and I am wondering how to go about testing the sound
            capabilities before trying to establish a communication
            session. Testing video was obvious since I could see my
            picture on the options screen, but testing audio was not so
            obvious. I would have hoped that I could just speak into the
            microphone and hear my voice echoed back to me.

            Doing this testing is important to me as I have always had
            problems with sound on Linux and want to be sure I have it
            working at least locally.

        I also think that the lack of feedback on the audio setup is
        problematic in terms of usability. Nevertheless, you can test
        your configuration by placing a call to a echo-test server, like
        for example sip:echo@iptel.org <mailto:sip%3Aecho@iptel.org>.

        Cheers,
        Martin

        ---------------------------------------------------------------------
        To unsubscribe, e-mail:
        users-unsubscribe@sip-communicator.dev.java.net
        <mailto:users-unsubscribe@sip-communicator.dev.java.net>
        For additional commands, e-mail:
        users-help@sip-communicator.dev.java.net
        <mailto:users-help@sip-communicator.dev.java.net>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: users-help@sip-communicator.dev.java.net


#6

Thanks for your response. It was helpful.
I am currently having a problem with SIP Communicator on Linux (Ubuntu 9.10
64 bit). The problem is that when you launch SIP Communicator, the main
window does not appear, only the icon in the system tray. If you right
click, the menu that appears has no entry to display he main window. If you
double click the icon in the system tray in Windows, it will present the
main window but in Linux, nothing happens. This behaviour does not happen
100% of the time since I was able to get the main window the first time
after installing. However, it has failed every time since then, creating a
situation where it is impossible to use SIP Communicator under Linux. Any
suggestions for a work around or should i file a bug report?

Jonathan Gossage

···

On Thu, Nov 12, 2009 at 9:03 PM, Martin André <mandre@dev.java.net> wrote:

Hey again,

Jonathan Gossage wrote:

I am having serious problems trying to understand how to do anything with
SIP communicator. It was suggested that I place a call to
sip:echo@iptel.com <sip%3Aecho@iptel.com> <mailto:sip%3Aecho@iptel.com<sip%253Aecho@iptel.com>>
but I have been completely unable to figure out how to do this. I have been
unable to create any SIP account and have no idea how to proceed from here.
Is there anything available that can guide me in getting started?

You'll first have to create an account at some SIP service provider,
iptel.org is one of them (I'm personally using ippi.fr, there are plenty
of other, I'll let you search the web). Then, configure SIP Communicator to
use this newly created account (Tools > Options > Accounts > Add). You
should then be able to place SIP calls.

Hope this helps,
Martin

Jonathan Gossage

On Thu, Nov 12, 2009 at 7:00 PM, Jonathan Gossage <jgossage@gmail.com<mailto: >> jgossage@gmail.com>> wrote:

   Thanks, that should get me started.

   Jonathan Gossage

   On Thu, Nov 12, 2009 at 6:44 PM, Martin André <mandre@dev.java.net >> <mailto:mandre@dev.java.net>> wrote:

       Hello,

       Jonathan Gossage wrote:

           I have just installed SIP Communicator on Ubuntu 9.10 64 bit
           version and I am wondering how to go about testing the sound
           capabilities before trying to establish a communication
           session. Testing video was obvious since I could see my
           picture on the options screen, but testing audio was not so
           obvious. I would have hoped that I could just speak into the
           microphone and hear my voice echoed back to me.

           Doing this testing is important to me as I have always had
           problems with sound on Linux and want to be sure I have it
           working at least locally.

       I also think that the lack of feedback on the audio setup is
       problematic in terms of usability. Nevertheless, you can test
       your configuration by placing a call to a echo-test server, like
       for example sip:echo@iptel.org <sip%3Aecho@iptel.org> <mailto:
sip%3Aecho@iptel.org <sip%253Aecho@iptel.org>>.

       Cheers,
       Martin

---------------------------------------------------------------------
       To unsubscribe, e-mail:
       users-unsubscribe@sip-communicator.dev.java.net
       <mailto:users-unsubscribe@sip-communicator.dev.java.net>

       For additional commands, e-mail:
       users-help@sip-communicator.dev.java.net
       <mailto:users-help@sip-communicator.dev.java.net>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: users-help@sip-communicator.dev.java.net


#7

Are you using the .deb or the generic linux installer? Use the.deb, it has some linux specific code,
PortAudio support etc.
Also make sure you have Sun Java installed, OpenJDK (the default Java thing on Ubuntu) might create
problems.
One thing to try: uninstall Sip Communicator, delete the ~/.sip-communicator folder (or rename it)
then reinstall the program. Make sure u have the last version (now 2169).
If it doesnt work, remove all logs from ~/.sip-communicator/log/, open a terminal, launch
sip-communicator --debug
When it finished loading interrupt it and attach your log file to a message and post it here. Maybe
Damencho or someone else with knowledge in this matter can help you out.

P.S. I am on Ubuntu 9.10 (Xubuntu) too and Sip Communicator works for me. With PulseAudio its even
better that with ALSA.

Jonathan Gossage wrote:

Thanks for your response. It was helpful.
I am currently having a problem with SIP Communicator on Linux (Ubuntu
9.10 64 bit). The problem is that when you launch SIP Communicator, the
main window does not appear, only the icon in the system tray. If you
right click, the menu that appears has no entry to display he main
window. If you double click the icon in the system tray in Windows, it
will present the main window but in Linux, nothing happens. This
behaviour does not happen 100% of the time since I was able to get the
main window the first time after installing. However, it has failed
every time since then, creating a situation where it is impossible to
use SIP Communicator under Linux. Any suggestions for a work around or
should i file a bug report?

Jonathan Gossage

    Hey again,

    Jonathan Gossage wrote:

        I am having serious problems trying to understand how to do
        anything with SIP communicator. It was suggested that I place a
        call to sip:echo@iptel.com <mailto:sip%3Aecho@iptel.com>
        <mailto:sip%3Aecho@iptel.com <mailto:sip%253Aecho@iptel.com>>
        but I have been completely unable to figure out how to do this.
        I have been unable to create any SIP account and have no idea
        how to proceed from here. Is there anything available that can
        guide me in getting started?

    You'll first have to create an account at some SIP service provider,
    iptel.org <http://iptel.org> is one of them (I'm personally using
    ippi.fr <http://ippi.fr>, there are plenty of other, I'll let you
    search the web). Then, configure SIP Communicator to use this newly
    created account (Tools > Options > Accounts > Add). You should then
    be able to place SIP calls.

    Hope this helps,
    Martin

        Jonathan Gossage

           Thanks, that should get me started.

           Jonathan Gossage

               Hello,

               Jonathan Gossage wrote:

                   I have just installed SIP Communicator on Ubuntu 9.10
        64 bit
                   version and I am wondering how to go about testing
        the sound
                   capabilities before trying to establish a communication
                   session. Testing video was obvious since I could see my
                   picture on the options screen, but testing audio was
        not so
                   obvious. I would have hoped that I could just speak
        into the
                   microphone and hear my voice echoed back to me.

                   Doing this testing is important to me as I have
        always had
                   problems with sound on Linux and want to be sure I
        have it
                   working at least locally.

               I also think that the lack of feedback on the audio setup is
               problematic in terms of usability. Nevertheless, you can test
               your configuration by placing a call to a echo-test
        server, like
               for example sip:echo@iptel.org
        <mailto:sip%3Aecho@iptel.org> <mailto:sip%3Aecho@iptel.org
        <mailto:sip%253Aecho@iptel.org>>.

               Cheers,
               Martin

         ---------------------------------------------------------------------
               To unsubscribe, e-mail:
               users-unsubscribe@sip-communicator.dev.java.net
        <mailto:users-unsubscribe@sip-communicator.dev.java.net>
               <mailto:users-unsubscribe@sip-communicator.dev.java.net
        <mailto:users-unsubscribe@sip-communicator.dev.java.net>>

               For additional commands, e-mail:
               users-help@sip-communicator.dev.java.net
        <mailto:users-help@sip-communicator.dev.java.net>
               <mailto:users-help@sip-communicator.dev.java.net
        <mailto:users-help@sip-communicator.dev.java.net>>

    ---------------------------------------------------------------------
    To unsubscribe, e-mail:
    users-unsubscribe@sip-communicator.dev.java.net
    <mailto:users-unsubscribe@sip-communicator.dev.java.net>
    For additional commands, e-mail:
    users-help@sip-communicator.dev.java.net
    <mailto:users-help@sip-communicator.dev.java.net>

- --
Regards,
Kertesz Laszlo

···

On Thu, Nov 12, 2009 at 9:03 PM, Martin André <mandre@dev.java.net > <mailto:mandre@dev.java.net>> wrote:
        On Thu, Nov 12, 2009 at 7:00 PM, Jonathan Gossage > <jgossage@gmail.com <mailto:jgossage@gmail.com> > <mailto:jgossage@gmail.com <mailto:jgossage@gmail.com>>> wrote:
           On Thu, Nov 12, 2009 at 6:44 PM, Martin André > <mandre@dev.java.net <mailto:mandre@dev.java.net> > <mailto:mandre@dev.java.net <mailto:mandre@dev.java.net>>> wrote:

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: users-help@sip-communicator.dev.java.net


#8

Thanks for your suggestions. First a question. What version of libgtk2.0-0
are you running? On my system (standard 64 bit Ubuntu 9.10) it is 2.18-3. In
2.18-1 the GTK folks introduced new support for client-side
windows<http://library.gnome.org/devel/gtk/unstable/gtk-migrating-ClientSideWindows.html>which
has unfortunately broken some aspects of window handling for many
applications, including the Sun 1.6 JDK and JRE. The problem for
Sip-Communicator is that the listener that should be invoked when a user
clicks on the system tray icon is not being fired. I was able to reproduce
the problem with a small test case and have submitted a bug report to Sun.

The version of OpenJdk included with Ubuntu 9.10 will not work either as it
does not support the system tray if Compiz is used as the window manager.

···

On Sun, Nov 15, 2009 at 9:21 AM, Kertesz Laszlo < laszlo.kertesz@infobenefic.ro> wrote:

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Are you using the .deb or the generic linux installer? Use the.deb, it has
some linux specific code,
PortAudio support etc.
Also make sure you have Sun Java installed, OpenJDK (the default Java thing
on Ubuntu) might create
problems.
One thing to try: uninstall Sip Communicator, delete the
~/.sip-communicator folder (or rename it)
then reinstall the program. Make sure u have the last version (now 2169).
If it doesnt work, remove all logs from ~/.sip-communicator/log/, open a
terminal, launch
sip-communicator --debug
When it finished loading interrupt it and attach your log file to a message
and post it here. Maybe
Damencho or someone else with knowledge in this matter can help you out.

P.S. I am on Ubuntu 9.10 (Xubuntu) too and Sip Communicator works for me.
With PulseAudio its even
better that with ALSA.

Jonathan Gossage wrote:
> Thanks for your response. It was helpful.
> I am currently having a problem with SIP Communicator on Linux (Ubuntu
> 9.10 64 bit). The problem is that when you launch SIP Communicator, the
> main window does not appear, only the icon in the system tray. If you
> right click, the menu that appears has no entry to display he main
> window. If you double click the icon in the system tray in Windows, it
> will present the main window but in Linux, nothing happens. This
> behaviour does not happen 100% of the time since I was able to get the
> main window the first time after installing. However, it has failed
> every time since then, creating a situation where it is impossible to
> use SIP Communicator under Linux. Any suggestions for a work around or
> should i file a bug report?
>
> Jonathan Gossage
>
> On Thu, Nov 12, 2009 at 9:03 PM, Martin André <mandre@dev.java.net > > <mailto:mandre@dev.java.net>> wrote:
>
> Hey again,
>
> Jonathan Gossage wrote:
>
> I am having serious problems trying to understand how to do
> anything with SIP communicator. It was suggested that I place a
> call to sip:echo@iptel.com <sip%3Aecho@iptel.com> <mailto:
sip%3Aecho@iptel.com <sip%253Aecho@iptel.com>>
> <mailto:sip%3Aecho@iptel.com <sip%253Aecho@iptel.com> <mailto:
sip%253Aecho@iptel.com <sip%25253Aecho@iptel.com>>>
> but I have been completely unable to figure out how to do this.
> I have been unable to create any SIP account and have no idea
> how to proceed from here. Is there anything available that can
> guide me in getting started?
>
>
> You'll first have to create an account at some SIP service provider,
> iptel.org <http://iptel.org> is one of them (I'm personally using
> ippi.fr <http://ippi.fr>, there are plenty of other, I'll let you
> search the web). Then, configure SIP Communicator to use this newly
> created account (Tools > Options > Accounts > Add). You should then
> be able to place SIP calls.
>
> Hope this helps,
> Martin
>
> Jonathan Gossage
>
>
> On Thu, Nov 12, 2009 at 7:00 PM, Jonathan Gossage > > <jgossage@gmail.com <mailto:jgossage@gmail.com> > > <mailto:jgossage@gmail.com <mailto:jgossage@gmail.com>>> wrote:
>
> Thanks, that should get me started.
>
> Jonathan Gossage
>
>
> On Thu, Nov 12, 2009 at 6:44 PM, Martin André > > <mandre@dev.java.net <mailto:mandre@dev.java.net> > > <mailto:mandre@dev.java.net <mailto:mandre@dev.java.net>>> > wrote:
>
> Hello,
>
>
> Jonathan Gossage wrote:
>
> I have just installed SIP Communicator on Ubuntu 9.10
> 64 bit
> version and I am wondering how to go about testing
> the sound
> capabilities before trying to establish a
communication
> session. Testing video was obvious since I could see
my
> picture on the options screen, but testing audio was
> not so
> obvious. I would have hoped that I could just speak
> into the
> microphone and hear my voice echoed back to me.
>
> Doing this testing is important to me as I have
> always had
> problems with sound on Linux and want to be sure I
> have it
> working at least locally.
>
>
> I also think that the lack of feedback on the audio setup
is
> problematic in terms of usability. Nevertheless, you can
test
> your configuration by placing a call to a echo-test
> server, like
> for example sip:echo@iptel.org <sip%3Aecho@iptel.org>
> <mailto:sip%3Aecho@iptel.org <sip%253Aecho@iptel.org>> <mailto:
sip%3Aecho@iptel.org <sip%253Aecho@iptel.org>
> <mailto:sip%253Aecho@iptel.org <sip%25253Aecho@iptel.org>>>.
>
>
> Cheers,
> Martin
>
>
>
---------------------------------------------------------------------
> To unsubscribe, e-mail:
> users-unsubscribe@sip-communicator.dev.java.net
> <mailto:users-unsubscribe@sip-communicator.dev.java.net>
> <mailto:users-unsubscribe@sip-communicator.dev.java.net
> <mailto:users-unsubscribe@sip-communicator.dev.java.net>>
>
> For additional commands, e-mail:
> users-help@sip-communicator.dev.java.net
> <mailto:users-help@sip-communicator.dev.java.net>
> <mailto:users-help@sip-communicator.dev.java.net
> <mailto:users-help@sip-communicator.dev.java.net>>
>
>
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail:
> users-unsubscribe@sip-communicator.dev.java.net
> <mailto:users-unsubscribe@sip-communicator.dev.java.net>
> For additional commands, e-mail:
> users-help@sip-communicator.dev.java.net
> <mailto:users-help@sip-communicator.dev.java.net>
>
>

- --
Regards,
Kertesz Laszlo
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQEcBAEBAgAGBQJLAA57AAoJEBnXd/iQ1D2N0VIIAMO53DADQQDZUFVN4FUjnft9
GjXoU2lFw8ugyirTECDWDbVMrqZ/4q3HT/A/712zzyWDWymreV+lX3gJWPZhC8Ml
5sGkSBTu2sXRKn4LuaPwv7p1a4TbP/JzI28uk2rB1OjRjI9bU0HmBYOxUChCaSdr
S10yf9ftdm5hJlT62Lldp5dvZVpor3CAJNtaPSL6r3qVHCPTLu1qmxQGmJ4rD5+C
DT5FzWWvKcfKfjHWY+YGucJCFja3MqrMW6OX+7pmS8Ev/0RjQB/x1rzZd2WCKnvH
2KX9+aRgTbqqom7XF7q9mbV1at7SjFHI/VMJtzGZYzq9rGBn5NYUwjUuXMFzb5c=
=7qmi
-----END PGP SIGNATURE-----

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: users-help@sip-communicator.dev.java.net


#9

First of all i use Xubuntu. This uses the Xfce desktop environment (as opposed to gnome, the default
Ubuntu DE). So there might be some differences, although it is based on some Gnome libraries.
But it does have libgtk2.0-0 and is at version 2.18.3-1. The Sip Communicator application windows do
look different than in Jaunty Gnome (i would say uglier), although it may be related to the gdm themes.
But when i tested the betas and rcs of Ubuntu i used the default version and i used Sip Communicator
as part of the tests - it was working (well, the gui part at least worked perfectly).
And i did encounter one icon/no menu error when i was testing some experimental PortAudio files. It
was related to some app/device initialisation errors not to the issue you pointed out.
It might not be the same issue as yours though.

Regards,
Kertesz Laszlo

Jonathan Gossage wrote:

···

Thanks for your suggestions. First a question. What version of
libgtk2.0-0 are you running? On my system (standard 64 bit Ubuntu 9.10)
it is 2.18-3. In 2.18-1 the GTK folks introduced new support for
client-side windows
<http://library.gnome.org/devel/gtk/unstable/gtk-migrating-ClientSideWindows.html>
which has unfortunately broken some aspects of window handling for many
applications, including the Sun 1.6 JDK and JRE. The problem for
Sip-Communicator is that the listener that should be invoked when a user
clicks on the system tray icon is not being fired. I was able to
reproduce the problem with a small test case and have submitted a bug
report to Sun.

The version of OpenJdk included with Ubuntu 9.10 will not work either as
it does not support the system tray if Compiz is used as the window manager.

On Sun, Nov 15, 2009 at 9:21 AM, Kertesz Laszlo > <laszlo.kertesz@infobenefic.ro <mailto:laszlo.kertesz@infobenefic.ro>> > wrote:

Are you using the .deb or the generic linux installer? Use the.deb,
it has some linux specific code,
PortAudio support etc.
Also make sure you have Sun Java installed, OpenJDK (the default
Java thing on Ubuntu) might create
problems.
One thing to try: uninstall Sip Communicator, delete the
~/.sip-communicator folder (or rename it)
then reinstall the program. Make sure u have the last version (now
2169).
If it doesnt work, remove all logs from ~/.sip-communicator/log/,
open a terminal, launch
sip-communicator --debug
When it finished loading interrupt it and attach your log file to a
message and post it here. Maybe
Damencho or someone else with knowledge in this matter can help you out.

P.S. I am on Ubuntu 9.10 (Xubuntu) too and Sip Communicator works
for me. With PulseAudio its even
better that with ALSA.

Jonathan Gossage wrote:

Thanks for your response. It was helpful.
I am currently having a problem with SIP Communicator on Linux (Ubuntu
9.10 64 bit). The problem is that when you launch SIP Communicator, the
main window does not appear, only the icon in the system tray. If you
right click, the menu that appears has no entry to display he main
window. If you double click the icon in the system tray in Windows, it
will present the main window but in Linux, nothing happens. This
behaviour does not happen 100% of the time since I was able to get the
main window the first time after installing. However, it has failed
every time since then, creating a situation where it is impossible to
use SIP Communicator under Linux. Any suggestions for a work around or
should i file a bug report?

Jonathan Gossage

On Thu, Nov 12, 2009 at 9:03 PM, Martin André <mandre@dev.java.net > <mailto:mandre@dev.java.net> >> <mailto:mandre@dev.java.net <mailto:mandre@dev.java.net>>> wrote:

    Hey again,

    Jonathan Gossage wrote:

        I am having serious problems trying to understand how to do
        anything with SIP communicator. It was suggested that I

place a

        call to sip:echo@iptel.com <mailto:sip%3Aecho@iptel.com>

<mailto:sip%3Aecho@iptel.com <mailto:sip%253Aecho@iptel.com>>

        <mailto:sip%3Aecho@iptel.com

<mailto:sip%253Aecho@iptel.com> <mailto:sip%253Aecho@iptel.com
<mailto:sip%25253Aecho@iptel.com>>>

        but I have been completely unable to figure out how to do

this.

        I have been unable to create any SIP account and have no idea
        how to proceed from here. Is there anything available that can
        guide me in getting started?

    You'll first have to create an account at some SIP service

provider,

    iptel.org <http://iptel.org> <http://iptel.org> is one of them

(I'm personally using

    ippi.fr <http://ippi.fr> <http://ippi.fr>, there are plenty of

other, I'll let you

    search the web). Then, configure SIP Communicator to use this

newly

    created account (Tools > Options > Accounts > Add). You should

then

    be able to place SIP calls.

    Hope this helps,
    Martin

        Jonathan Gossage

        On Thu, Nov 12, 2009 at 7:00 PM, Jonathan Gossage >> <jgossage@gmail.com <mailto:jgossage@gmail.com> > <mailto:jgossage@gmail.com <mailto:jgossage@gmail.com>> >> <mailto:jgossage@gmail.com <mailto:jgossage@gmail.com> > <mailto:jgossage@gmail.com <mailto:jgossage@gmail.com>>>> wrote:

           Thanks, that should get me started.

           Jonathan Gossage

           On Thu, Nov 12, 2009 at 6:44 PM, Martin André
        <mandre@dev.java.net <mailto:mandre@dev.java.net>

<mailto:mandre@dev.java.net <mailto:mandre@dev.java.net>>

           <mailto:mandre@dev.java.net

<mailto:mandre@dev.java.net> <mailto:mandre@dev.java.net
<mailto:mandre@dev.java.net>>>> wrote:

               Hello,

               Jonathan Gossage wrote:

                   I have just installed SIP Communicator on Ubuntu

9.10

        64 bit
                   version and I am wondering how to go about testing
        the sound
                   capabilities before trying to establish a

communication

                   session. Testing video was obvious since I

could see my

                   picture on the options screen, but testing

audio was

        not so
                   obvious. I would have hoped that I could just speak
        into the
                   microphone and hear my voice echoed back to me.

                   Doing this testing is important to me as I have
        always had
                   problems with sound on Linux and want to be sure I
        have it
                   working at least locally.

               I also think that the lack of feedback on the audio

setup is

               problematic in terms of usability. Nevertheless,

you can test

               your configuration by placing a call to a echo-test
        server, like
               for example sip:echo@iptel.org

<mailto:sip%3Aecho@iptel.org>

        <mailto:sip%3Aecho@iptel.org

<mailto:sip%253Aecho@iptel.org>> <mailto:sip%3Aecho@iptel.org
<mailto:sip%253Aecho@iptel.org>

        <mailto:sip%253Aecho@iptel.org

<mailto:sip%25253Aecho@iptel.org>>>.

               Cheers,
               Martin

---------------------------------------------------------------------

               To unsubscribe, e-mail:
               users-unsubscribe@sip-communicator.dev.java.net

<mailto:users-unsubscribe@sip-communicator.dev.java.net>

        <mailto:users-unsubscribe@sip-communicator.dev.java.net

<mailto:users-unsubscribe@sip-communicator.dev.java.net>>

<mailto:users-unsubscribe@sip-communicator.dev.java.net
<mailto:users-unsubscribe@sip-communicator.dev.java.net>

        <mailto:users-unsubscribe@sip-communicator.dev.java.net

<mailto:users-unsubscribe@sip-communicator.dev.java.net>>>

               For additional commands, e-mail:
               users-help@sip-communicator.dev.java.net

<mailto:users-help@sip-communicator.dev.java.net>

        <mailto:users-help@sip-communicator.dev.java.net

<mailto:users-help@sip-communicator.dev.java.net>>

               <mailto:users-help@sip-communicator.dev.java.net

<mailto:users-help@sip-communicator.dev.java.net>

        <mailto:users-help@sip-communicator.dev.java.net

<mailto:users-help@sip-communicator.dev.java.net>>>

---------------------------------------------------------------------

    To unsubscribe, e-mail:
    users-unsubscribe@sip-communicator.dev.java.net

<mailto:users-unsubscribe@sip-communicator.dev.java.net>

    <mailto:users-unsubscribe@sip-communicator.dev.java.net

<mailto:users-unsubscribe@sip-communicator.dev.java.net>>

    For additional commands, e-mail:
    users-help@sip-communicator.dev.java.net

<mailto:users-help@sip-communicator.dev.java.net>

    <mailto:users-help@sip-communicator.dev.java.net

<mailto:users-help@sip-communicator.dev.java.net>>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: users-help@sip-communicator.dev.java.net


#10

I tested Sip Communicator with Xubuntu (Xfce version of ubuntu) 9.10 with PulseAudio. I was
connected via VPN to my work network.
And it works! I used a bt handsfree (connected with blueman to headset service, routed the
PulseAudio input/output to it) - i set all the audio devices to pulse in Sip Communicator and i
could make calls using the headset. Nice work on the PortAudio plugin!

···

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: users-help@sip-communicator.dev.java.net