[sip-comm] rpm install error on start


#1

Hello Adam,

I could never install SC with "yum localinstall", because I get the following error:
Package sip-communicator-1.0-alpha2.nightly.build.676.i386.rpm is not signed
I always install it with "rpm -Uvh ...". How did you manage with yum?

What java do you have installed? Is it JDK ot just JRE? Which version?

Also, I searched for this file '/usr/lib/libaoss.so' on my system (FC6) and I don't have one. I have '/usr/lib/libaoss.so.0' and '/usr/lib/libaoss.so.0.0.0', though.

For now that's all I know about it, but I'll continue investigating the problem. I'll install a fresh Fedore Core 6 with default settings and will try to reproduce your problem. Will keep you posted.

In the meantime, have you tried to build your own from the CVS tree? Can you try that so that we know if the problem is RPM related.

Thanks,
Pavel Tankov

···

----- Original Message ----

From: Adam Dixon <adamtdixon@gmail.com>

To: users@sip-communicator.dev.java.net
Sent: Monday, June 18, 2007 5:07:18 AM
Subject: [sip-comm] rpm install error on start

Hi,

Wanting to try this software (as it looks promising) I downloaded the RPM for fedora6; sip-communicator-1.0-alpha2.nightly.build.676.i386.rpm and ran the command to install it;
yum localinstall sip-communicator-1.0-alpha2.nightly.build.676.i386.rpm

Which installed a alsa-oss package also. OK.

Went to run the program from the menu, it didnt open, then ran on the command line and get the following output;

# sip-communicator
ERROR: ld.so: object '/usr/lib/libaoss.so' from LD_PRELOAD cannot be preloaded: ignored.

ERROR: ld.so: object '/usr/lib/libaoss.so' from LD_PRELOAD cannot be preloaded: ignored.
WARNING: error instantiating 'java.util.logging.FileHandler,' referenced by handlers, class not found
java.lang.ClassNotFoundException
: java.util.logging.FileHandler,
   <<No stacktrace available>>
Exception during runtime initialization
java.lang.ExceptionInInitializerError
   <<No stacktrace available>>
Caused by:
java.lang.NullPointerException
   <<No stacktrace available>>

Am I still missing a package, java problem perhaps?

Thanks for any assistance.

Adam

____________________________________________________________________________________
Looking for earth-friendly autos?
Browse Top Cars by "Green Rating" at Yahoo! Autos' Green Center.
http://autos.yahoo.com/green_center/


#2

Hi Pavel,
Thanks for the reply,

Hello Adam,

I could never install SC with "yum localinstall", because I get the
following error:
Package sip-communicator-1.0-alpha2.nightly.build.676.i386.rpm is not
signed
I always install it with "rpm -Uvh ...". How did you manage with yum?

This is because I have the GPG check disables in /etc/yum.conf;
gpgcheck=0

What java do you have installed? Is it JDK ot just JRE? Which version?

Hmm I have JDK only from sun , and the default fedora java, not too cluey
here, perhaps you can see if this is enaough for sip-comm to run;
[adixon@dixon ~]$ rpm -qa | grep -i jre
[adixon@dixon ~]$ rpm -qa | grep -i jdk
jdk-1.6.0_01-fcs
[adixon@dixon ~]$ rpm -qa | grep -i java
glib-java-0.2.6-3.fc6
java-1.4.2-gcj-compat-1.4.2.0-40jpp.110
openoffice.org-javafilter-2.0.4-5.5.22

Also, I searched for this file '/usr/lib/libaoss.so' on my system (FC6) and

I don't have one. I have '/usr/lib/libaoss.so.0' and
'/usr/lib/libaoss.so.0.0.0', though.

[adixon@dixon lib]$ ls -l /usr/lib | grep oss
[adixon@dixon lib]$ ls -l /usr/lib64/ | grep oss
lrwxrwxrwx 1 root root 20 Jun 17 21:40 libalsatoss.so.0 ->
libalsatoss.so.0.0.0
-rwxr-xr-x 1 root root 40640 Oct 6 2006 libalsatoss.so.0.0.0
lrwxrwxrwx 1 root root 16 Jun 17 21:40 libaoss.so.0 ->
libaoss.so.0.0.0
-rwxr-xr-x 1 root root 19232 Oct 6 2006 libaoss.so.0.0.0

Not being overly cluey on sound subsystems, Im sure fc6 uses alsa.

For now that's all I know about it, but I'll continue investigating the

problem. I'll install a fresh Fedore Core 6 with default settings and will
try to reproduce your problem. Will keep you posted.

In the meantime, have you tried to build your own from the CVS tree? Can
you try that so that we know if the problem is RPM related.

I will pull down the tree later on today perhaps, and try this method.

Thanks,

Adam

···

On 6/18/07, Pavel Tankov <tankov_pavel@yahoo.com> wrote:


#3

Hi guys,

Just a few thoughts:

ERROR: ld.so: object '/usr/lib/libaoss.so' from LD_PRELOAD cannot be preloaded: ignored.

We are using alsa-oss to make java output and capture audio through alsa and not its default oss. The libaoss.so preload was first defined on debian as this is how the lib is called there. Judging from what Pavel said earlier, it might be deployed under a slightly different name on Fedora (i.e. libaoss.so.0 or libaoss.so.0.0.0). In this case simply replacing the LD_PRELOAD declaration in the sip-communicator shell script that comes with the rpm package should fix the issue.

Having said that, I don't think this is what's preventing SC from starting. In your first mail, Adam, you reported the following issue:

WARNING: error instantiating 'java.util.logging.FileHandler,' referenced by handlers, class not found
java.lang.ClassNotFoundException : java.util.logging.FileHandler,
   <<No stacktrace available>>
Exception during runtime initialization
java.lang.ExceptionInInitializerError
   <<No stacktrace available>>
Caused by: java.lang.NullPointerException
   <<No stacktrace available>>

This is a completely different thing and it looks like a missing import statement in one of the bundle-manifests (though that would be quite bizarre since we're using the same bundles on all linux distros (and even mac an win) ) and we haven't had the issue anywhere else. I guess a complete copy of your output as well as your log files (located in $HOME/.sip-communicator/log) would help better diagnose the problem.

Thanks for your report!
Emil

Adam Dixon wrote:

···

Hi Pavel,
Thanks for the reply,

On 6/18/07, *Pavel Tankov* <tankov_pavel@yahoo.com > <mailto:tankov_pavel@yahoo.com>> wrote:

    Hello Adam,

    I could never install SC with "yum localinstall", because I get the
    following error:
    Package sip-communicator-1.0-alpha2.nightly.build.676.i386.rpm is
    not signed
    I always install it with "rpm -Uvh ...". How did you manage with yum?

This is because I have the GPG check disables in /etc/yum.conf;
gpgcheck=0

    What java do you have installed? Is it JDK ot just JRE? Which version?

Hmm I have JDK only from sun , and the default fedora java, not too cluey here, perhaps you can see if this is enaough for sip-comm to run;
[adixon@dixon ~] rpm \-qa | grep \-i jre \[adixon@dixon \~\] rpm -qa | grep -i jdk
jdk-1.6.0_01-fcs
[adixon@dixon ~]$ rpm -qa | grep -i java
glib-java-0.2.6-3.fc6
java-1.4.2-gcj-compat-1.4.2.0-40jpp.110
openoffice.org-javafilter-2.0.4-5.5.22

    Also, I searched for this file '/usr/lib/libaoss.so' on my system
    (FC6) and I don't have one. I have '/usr/lib/libaoss.so.0' and
    '/usr/lib/libaoss.so.0.0.0', though.

[adixon@dixon lib] ls \-l /usr/lib | grep oss \[adixon@dixon lib\] ls -l /usr/lib64/ | grep oss
lrwxrwxrwx 1 root root 20 Jun 17 21:40 libalsatoss.so.0 -> libalsatoss.so.0.0.0
-rwxr-xr-x 1 root root 40640 Oct 6 2006 libalsatoss.so.0.0.0
lrwxrwxrwx 1 root root 16 Jun 17 21:40 libaoss.so.0 -> libaoss.so.0.0.0
-rwxr-xr-x 1 root root 19232 Oct 6 2006 libaoss.so.0.0.0

Not being overly cluey on sound subsystems, Im sure fc6 uses alsa.

    For now that's all I know about it, but I'll continue investigating
    the problem. I'll install a fresh Fedore Core 6 with default
    settings and will try to reproduce your problem. Will keep you posted.

    In the meantime, have you tried to build your own from the CVS tree?
    Can you try that so that we know if the problem is RPM related.

I will pull down the tree later on today perhaps, and try this method.

Thanks,

Adam

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: users-help@sip-communicator.dev.java.net


#4

By the way, I just realized I had installed jre 1.6u1 however my fc6 install
was still set to use the default.

/usr/sbin/alternatives --install /usr/bin/java java
/usr/java/jre1.6.0_01/bin/java 1601

Fixed it straight away.

Thanks for the replies.

Adam