[sip-comm] Re: Sip communicator with Netbeans


#1

Komin Antony wrote:

I'd a few problems with compiling the SIP communicator code using netbeans with the documentation provided in the website.
The thing is, even though I follow all the steps accurately, I'm getting a build.xml not found error.

If I try to create a new project using the sources, a bunch of compilation errors pop up.
Do you know how might I get it working?

Btw, I use netbeans 6.0.1, so there shouldn't be any non-compatible version problems.

Komin,

I haven't tried to build or run the project in the last 6 months. There have been a lot of changes to the build and the netbeans classpaths that I haven't had time to verify... other developers try to keep the netbeans aspects up to date when they make changes, but they usually don't have a suitable environment to test properly.

If you are REALLY getting "build.xml" not found, then you have a very basic problem. When you open the Project under either the Files or Projects view, you should see build.xml in the project base directory. If not, I suggest that you do a command-line cvs checkout to create a new sandbox and start to configure the project again under netbeans.

If, on the other hand, you can see build.xml in the project base directory, then I think your problem lies with netbeans customisation... did you remember to copy ide/netbeans/project.xml into netbeans/project.xml?

Let me know what you find. I might be able to spare some time over the weekend to verify the latest build matches the instructions.

Regards,

Brian

···

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: users-help@sip-communicator.dev.java.net


#2

Oops. I was making a foolish mistake over and over again.
I copied the .xml files to /netbeans while netbeans IDE was running.
I'm a total netbeans noob so I didn't realize the mistake until I read the
comments for project.xml file.

Works like a charm now.
Thanks,
Komin

···

On Thu, Oct 15, 2009 at 11:20 AM, Brian Burch <brian@pingtoo.com> wrote:

Komin Antony wrote:

I'd a few problems with compiling the SIP communicator code using netbeans
with the documentation provided in the website.
The thing is, even though I follow all the steps accurately, I'm getting a
build.xml not found error.

If I try to create a new project using the sources, a bunch of compilation
errors pop up.
Do you know how might I get it working?

Btw, I use netbeans 6.0.1, so there shouldn't be any non-compatible
version problems.

Komin,

I haven't tried to build or run the project in the last 6 months. There
have been a lot of changes to the build and the netbeans classpaths that I
haven't had time to verify... other developers try to keep the netbeans
aspects up to date when they make changes, but they usually don't have a
suitable environment to test properly.

If you are REALLY getting "build.xml" not found, then you have a very basic
problem. When you open the Project under either the Files or Projects view,
you should see build.xml in the project base directory. If not, I suggest
that you do a command-line cvs checkout to create a new sandbox and start to
configure the project again under netbeans.

If, on the other hand, you can see build.xml in the project base directory,
then I think your problem lies with netbeans customisation... did you
remember to copy ide/netbeans/project.xml into netbeans/project.xml?

Let me know what you find. I might be able to spare some time over the
weekend to verify the latest build matches the instructions.

Regards,

Brian

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: users-help@sip-communicator.dev.java.net