[sip-comm] Re: [nist-sip] How to force sip-communicator to use a CODEC ?


#1

Hello Shahed,

Try editing the sip-communicator.xml file. You have a PREFERRED_AUDIO_CODEC and PREFERED_VIDEO_CODEC option. You can change those, The ULAW value is 0.

Cheers
Emil

Shahed Moolji wrote:

> I have a hardware SIP phone, and 2 software phones (sip-communicator &
> X-Lite http://support.xten.net/)
>
> I am unable to get sip-communicator & my hardware sip phone to work using
> G.711.
> It only works with G.723.
>
> However, with X-Lite, I am able to get the 2 to work with G.711 uLaw.
>
> I am wondering if this is a JMF limitation, or something to do with the SDP
> negotiations ?
>
> When I go and remove all codecs other than G.711 from the JMF registry,
> I get an error saying that no media format can be negotiated between
> sip-communicator and
> my hardware device.
>
> I am currently studying the traces of the 2 sessions and trying to see why

ยทยทยท

one works and not the

> other.
>
> Any clues ??
>
> Thanks
> Shahed
>
> _______________________________________________
> nist-sip mailing list
> nist-sip@antd.nist.gov
> http://www.antd.nist.gov/mailman/listinfo/nist-sip
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: users-help@sip-communicator.dev.java.net