[sip-comm] Problem with SIP-Communicator in Debian


#1

Hello,

I want to use SIP-Communicator with Debian testing (squeeze). I installed the deb-package of the last version, SIP Communicator 1.0-alpha3-nightly.build.2385. My Java version is Java(TM) SE Runtime Environment (build 1.6.0_16-b01).

I can start SIP-Communicator but I can't connect with any account (ICQ, Jabber, SIP and RSS are not working I didn't test the rest). When I enter user name and password I get a message, something like connection can't be established, check your network connection (I translated this

Any ideas what I can do?

Thanks for your help.

Johannes

···

from my German version).

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: users-help@sip-communicator.dev.java.net


#2

Hi,

there is an issue about this and a solution :
https://sip-communicator.dev.java.net/issues/show_bug.cgi?id=751

"It is due to the introduction of bindv6only=1 by default in GNU/Linux
Debian

Squeeze. You could check it at /proc/sys/net/ipv6/bindv6only and
/etc/sysctl.d/bindv6only.conf.

"Setting bindv6only to 0 (echo 0 > /proc/sys/net/ipv6/bindv6only or set 0 in
/etc/sysctl.d/bindv6only.conf file) solve the problem."

Cheers
damencho

···

On Wed, Feb 10, 2010 at 2:45 PM, Johannes Werner <w.johannes@googlemail.com>wrote:

Hello,

I want to use SIP-Communicator with Debian testing (squeeze). I installed
the deb-package of the last version, SIP Communicator
1.0-alpha3-nightly.build.2385. My Java version is Java(TM) SE Runtime
Environment (build 1.6.0_16-b01).

I can start SIP-Communicator but I can't connect with any account (ICQ,
Jabber, SIP and RSS are not working I didn't test the rest). When I enter
user name and password I get a message, something like connection can't be
established, check your network connection (I translated this from my German
version).

Any ideas what I can do?

Thanks for your help.

Johannes

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: users-help@sip-communicator.dev.java.net


#3

Disable ipv6. Execute as root:

sysctl -w net.ipv6.conf.all.disable_ipv6=1

I had exactly the same problem and this fixed it. Also you have to execute it on network
initialisation. I put a script in /etc/network/if-pre-up.d/ on my machine with fixed net connection:

/etc/network/if-pre-up.d/ipv6-off

that contained:

#!/bin/bash
sysctl -w net.ipv6.conf.all.disable_ipv6=1

I use wicd on my laptop and i put this script as pre init and works well (you have to do it for
every connection profile, be it wired or wireless). But if you use network manager its a more
complicated issue.

- --
Regards,
Kertesz Laszlo

Johannes Werner wrote:

···

Hello,

I want to use SIP-Communicator with Debian testing (squeeze). I
installed the deb-package of the last version, SIP Communicator
1.0-alpha3-nightly.build.2385. My Java version is Java(TM) SE Runtime
Environment (build 1.6.0_16-b01).

I can start SIP-Communicator but I can't connect with any account (ICQ,
Jabber, SIP and RSS are not working I didn't test the rest). When I
enter user name and password I get a message, something like connection
can't be established, check your network connection (I translated this
from my German version).

Any ideas what I can do?

Thanks for your help.

Johannes

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: users-help@sip-communicator.dev.java.net

--
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: users-help@sip-communicator.dev.java.net


#4

Damian Minkov schrieb:

Hi,

there is an issue about this and a solution :
https://sip-communicator.dev.java.net/issues/show_bug.cgi?id=751

"It is due to the introduction of bindv6only=1 by default in GNU/Linux Debian

Squeeze. You could check it at /proc/sys/net/ipv6/bindv6only and
/etc/sysctl.d/bindv6only.conf.

"Setting bindv6only to 0 (echo 0 > /proc/sys/net/ipv6/bindv6only or set 0 in
/etc/sysctl.d/bindv6only.conf file) solve the problem."

Cheers
damencho

    Hello,

    I want to use SIP-Communicator with Debian testing (squeeze). I
    installed the deb-package of the last version, SIP Communicator
    1.0-alpha3-nightly.build.2385. My Java version is Java(TM) SE
    Runtime Environment (build 1.6.0_16-b01).

    I can start SIP-Communicator but I can't connect with any account
    (ICQ, Jabber, SIP and RSS are not working I didn't test the rest).
    When I enter user name and password I get a message, something
    like connection can't be established, check your network
    connection (I translated this from my German version).

    Any ideas what I can do?

    Thanks for your help.

    Johannes

    ---------------------------------------------------------------------
    To unsubscribe, e-mail:
    users-unsubscribe@sip-communicator.dev.java.net
    <mailto:users-unsubscribe@sip-communicator.dev.java.net>
    For additional commands, e-mail:
    users-help@sip-communicator.dev.java.net
    <mailto:users-help@sip-communicator.dev.java.net>

Thank you for your help. It's working now. :slight_smile:

···

On Wed, Feb 10, 2010 at 2:45 PM, Johannes Werner > <w.johannes@googlemail.com <mailto:w.johannes@googlemail.com>> wrote:

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: users-help@sip-communicator.dev.java.net