[sip-comm] how to set up a media connection?


#1

I tried to setup a phone call between two instances of SIP communicator. On both parties, the phone call is labeled as connected, the consoles also show that the inviteOK and ACK have been successfully processed. But I can not hear voice. openMediaStreams has also been successfully returned. I used proxy01sipphone.com as the default domain and use username/password from it.

The detail of my configuration is like that

<?xml version="1.0" encoding="UTF-8"?>
<sip>

  <communicator>

      <FIRST_LAUNCH value="false"/>

      <ENABLE_SIMPLE value="false"/>

      <media>
          <PREFERRED_AUDIO_ENCODING value="0"/>

          <PREFERRED_VIDEO_ENCODING value="26"/>

        <MEDIA_SOURCE value=""/>

        <MEDIA_BUFFER_LENGTH value="100"/>

        <IP_ADDRESS value=""/>

        <AUDIO_PORT value=""/>

        <VIDEO_PORT value=""/>

    </media>

    <sip>

        <PUBLIC_ADDRESS value="**sip:17476086821@proxy01.sipphone.com"**/>

        <TRANSPORT value=""/>

        <REGISTRAR_ADDRESS value="**proxy01.sipphone.com**"/>

        <USER_NAME value="**17476086821**"/>

        <STACK_PATH value="gov.nist"/>

        <PREFERRED_LOCAL_PORT value=""/>

        <DISPLAY_NAME value="Li Shu Qiang"/>

        <REGISTRAR_TRANSPORT value="UDP"/>

        <REGISTRATIONS_EXPIRATION value="3600"/>

        <REGISTRAR_PORT value="5060"/>

        <FAIL_CALLS_ON_DEST_USER_MISMATCH value="false"/>

        <DEMAND_PASSWORD_PRIOR_TO_FIRST_REGISTER value="true"/>



        <DEFAULT_DOMAIN_NAME value="**proxy01.sipphone.com**"/>

        <DEFAULT_AUTHENTICATION_REALM value=**"proxy01.sipphone.com"**/>

        <WAIT_UNREGISTGRATION_FOR value="1100"/>

        <SAME_USER_EVERYWHERE value="true"/>

        <simple>

            <CONTACT_LIST_FILE value="contact-list.xml"/>

            <SUBSCRIPTION_EXP_TIME value="600"/>

            <MIN_EXP_TIME value="120"/>

            <LAST_SELECTED_OPEN_STATUS value="online"/>

        </simple>

    <EXCESSIVE_URI_CHARACTERS value="( )-"/>
    <sipphone>

        <IS_RUNNING_SIPPHONE value="**true**"/>

        <MY_SIPPHONE_URL value="http://my.sipphone.com"/>

    </sipphone>



    <gui>

        <AUTH_WIN_TITLE value="SIP Authentication!"/>

        <AUTHENTICATION_PROMPT value="Please enter login name and password for the specified realm:"/>

        <USER_NAME_LABEL value="User Name:"/>

        <USER_NAME_EXAMPLE value="Example: 1-747-555-1212"/>

        <PASSWORD_LABEL value="Password:"/>

        <GUI_MODE value="PhoneUiMode"/>

        <!--GUI_MODE value="ImUiMode"/-->

                 <DISPLAY_CONTROLS value="true"/>

        <imp>

            <CONTACT_LIST_X value="-4"/>

            <CONTACT_LIST_Y value="-4"/>

            <CONTACT_LIST_WIDTH value="1032"/>

            <CONTACT_LIST_HEIGHT value="748"/>

        </imp>

    </gui>

    <common>

        <PREFERRED_NETWORK_INTERFACE value="Intel(R) PRO/100 VE Network Connection"/>

        <PREFERRED_NETWORK_ADDRESS value="192.168.1.17"/>

    </common>



    <STUN_SERVER_ADDRESS value="**stun01.sipphone.com**"/>

    <STUN_SERVER_PORT value="3478"/>

    <VOICE_MAIL_ADDRESS value=""/>
</sip>
<gov>

<nist>

    <javax>

        <sip>

            <SERVER_LOG value="log/sip-communicator.stack.log"/>

            <TRACE_LEVEL value="16"/>

        </sip>

    </javax>

</nist>
<sip>

    <IP_ADDRESS value="192.168.1.17"/>

    <STACK_NAME value="sip-communicator"/>

    <ROUTER_PATH value="net.java.sip.communicator.sip.SipCommRouter"/>

    <OUTBOUND_PROXY value=""/>

    <RETRANSMISSON_FILTER value=""/>

    <EXTENSION_METHODS value=""/>

    <RETRANSMISSION_FILTER value="true"/>

</sip>
<net>

    <preferIPv4Stack system="true" value="true"/>

    <preferIPv6Addresses system="true" value="false"/>

</net>

Do I have to make any changes of any default properties? I think there is no problem on registration and message processing. There are possibly problems on media session setup.
best regards.

···

������� MSN Explorer
--------------------------------------------------------------------- To unsubscribe, e-mail: users-unsubscribe@sip-communicator.dev.java.net For additional commands, e-mail: users-help@sip-communicator.dev.java.net


#2

Disable the stun server

li shuqiang <lishuqiang@hotmail.com> a �crit :

I tried to setup a phone call between two instances of SIP communicator. On both parties, the phone call is labeled as connected, the consoles also show that the inviteOK and ACK have been successfully processed. But I can not hear voice. openMediaStreams has also been successfully returned. I used proxy01sipphone.com as the default domain and use username/password from it.

The detail of my configuration is like that

<?xml version="1.0" encoding="UTF-8"?>

<configuration>

<net>

  <java>

    <sip>

      <communicator>

          <FIRST_LAUNCH value="false"/>

          <ENABLE_SIMPLE value="false"/>

          <media>

<!--- <PREFERRED_AUDIO_ENCODING system="false" value=""/> -->

              <PREFERRED_AUDIO_ENCODING value="0"/>

              <PREFERRED_VIDEO_ENCODING value="26"/>

            <MEDIA_SOURCE value=""/>

            <MEDIA_BUFFER_LENGTH value="100"/>

            <IP_ADDRESS value=""/>

            <AUDIO_PORT value=""/>

            <VIDEO_PORT value=""/>

        </media>

        <sip>

            <PUBLIC_ADDRESS value="sip:17476086821@proxy01.sipphone.com"/>

            <TRANSPORT value=""/>

            <REGISTRAR_ADDRESS value="proxy01.sipphone.com"/>

            <USER_NAME value="17476086821"/>

            <STACK_PATH value="gov.nist"/>

            <PREFERRED_LOCAL_PORT value=""/>

            <DISPLAY_NAME value="Li Shu Qiang"/>

            <REGISTRAR_TRANSPORT value="UDP"/>

            <REGISTRATIONS_EXPIRATION value="3600"/>

            <REGISTRAR_PORT value="5060"/>

            <FAIL_CALLS_ON_DEST_USER_MISMATCH value="false"/>

            <DEMAND_PASSWORD_PRIOR_TO_FIRST_REGISTER value="true"/>

            <DEFAULT_DOMAIN_NAME value="proxy01.sipphone.com"/>

            <DEFAULT_AUTHENTICATION_REALM value="proxy01.sipphone.com"/>

            <WAIT_UNREGISTGRATION_FOR value="1100"/>

            <SAME_USER_EVERYWHERE value="true"/>

            <simple>

                <CONTACT_LIST_FILE value="contact-list.xml"/>

                <SUBSCRIPTION_EXP_TIME value="600"/>

                <MIN_EXP_TIME value="120"/>

                <LAST_SELECTED_OPEN_STATUS value="online"/>

            </simple>

        <EXCESSIVE_URI_CHARACTERS value="( )-"/>

</sip>

        <sipphone>

            <IS_RUNNING_SIPPHONE value="true"/>

            <MY_SIPPHONE_URL value=“http://my.sipphone.com”/>

        </sipphone>

        <gui>

            <AUTH_WIN_TITLE value="SIP Authentication!"/>

            <AUTHENTICATION_PROMPT value="Please enter login name and password for the specified realm:"/>

            <USER_NAME_LABEL value="User Name:"/>

            <USER_NAME_EXAMPLE value="Example: 1-747-555-1212"/>

            <PASSWORD_LABEL value="Password:"/>

            <GUI_MODE value="PhoneUiMode"/>

            <!--GUI_MODE value="ImUiMode"/-->

                     <DISPLAY_CONTROLS value="true"/>

            <imp>

                <CONTACT_LIST_X value="-4"/>

                <CONTACT_LIST_Y value="-4"/>

                <CONTACT_LIST_WIDTH value="1032"/>

                <CONTACT_LIST_HEIGHT value="748"/>

            </imp>

        </gui>

        <common>

            <PREFERRED_NETWORK_INTERFACE value="Intel(R) PRO/100 VE Network Connection"/>

            <PREFERRED_NETWORK_ADDRESS value="192.168.1.17"/>

        </common>

        <STUN_SERVER_ADDRESS value="stun01.sipphone.com"/>

        <STUN_SERVER_PORT value="3478"/>

        <VOICE_MAIL_ADDRESS value=""/>

</communicator>

    </sip>

  </java>

</net>

    <gov>

    <nist>

        <javax>

            <sip>

                <SERVER_LOG value="log/sip-communicator.stack.log"/>

                <TRACE_LEVEL value="16"/>

            </sip>

        </javax>

    </nist>

</gov>

<javax>

    <sip>

        <IP_ADDRESS value="192.168.1.17"/>

        <STACK_NAME value="sip-communicator"/>

        <ROUTER_PATH value="net.java.sip.communicator.sip.SipCommRouter"/>

        <OUTBOUND_PROXY value=""/>

        <RETRANSMISSON_FILTER value=""/>

        <EXTENSION_METHODS value=""/>

        <RETRANSMISSION_FILTER value="true"/>

    </sip>

</javax>

<java>

    <net>

        <preferIPv4Stack system="true" value="true"/>

        <preferIPv6Addresses system="true" value="false"/>

    </net>

</java>

</configuration>

Do I have to make any changes of any default properties? I think there is no problem on registration and message processing. There are possibly problems on media session setup.
best regards.

···

---------------------------------
������� MSN Explorer --------------------------------------------------------------------- To unsubscribe, e-mail: users-unsubscribe@sip-communicator.dev.java.net For additional commands, e-mail: users-help@sip-communicator.dev.java.net
    
---------------------------------
Appel audio GRATUIT partout dans le monde avec le nouveau Yahoo! Messenger
T�l�chargez le ici !