[sip-comm-dev] ZRTP


#1

How do I initiate ZRTP calls? I've enabled all the options (mandatory in
the ZRTP panel and the two checkboxes in the SIP account). I'm
connecting to another person on the same asterisk server with the same
nightly build of SIP Communicator

Tynan

···

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#2

Hello,
The Asterisk server wont let zrtp encryption through with default install. We have at work an Asterisk (Trixbox) server and it doesnt work with zrtp.
You have to patch the server.

You should try it in ip to ip call to see if it works.

Regards,

Kertesz Laszlo

···

On Wed, 26 May 2010 20:53:14 +0300, Tynan <tynan@tynan.net> wrote:

How do I initiate ZRTP calls? I've enabled all the options (mandatory in
the ZRTP panel and the two checkboxes in the SIP account). I'm
connecting to another person on the same asterisk server with the same
nightly build of SIP Communicator

Tynan

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

--
Using Opera's revolutionary e-mail client: http://www.opera.com/mail/

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#3

Hi,

Asterix often decodes/re-encodes the RTP packets, for example to midify the
codecs. I'm not a specialist in Asterix but ZRTP only works in real
end-to-end scenarios where the RTP packets are not modified by some network
element. Same is true for SRTP as well.

DOes Asterix provide an configuration option to "switch off" RTP processing,
i.e. either step aside after SIP negotiated the parameters or put RTP
packets through without modifying them.

Regards,
Werner

···

Am 26.05.2010 20:28, schrieb Kertesz Laszlo:

Hello,
The Asterisk server wont let zrtp encryption through with default
install. We have at work an Asterisk (Trixbox) server and it doesnt work
with zrtp.
You have to patch the server.

You should try it in ip to ip call to see if it works.

Regards,

Kertesz Laszlo

On Wed, 26 May 2010 20:53:14 +0300, Tynan <tynan@tynan.net> wrote:

How do I initiate ZRTP calls? I've enabled all the options (mandatory in
the ZRTP panel and the two checkboxes in the SIP account). I'm
connecting to another person on the same asterisk server with the same
nightly build of SIP Communicator

Tynan

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net