[sip-comm-dev] Where's the main class??


#1

Hi all,

I'm trying to use the sip-communicator-release1 source with eclipse and it
compiles correctly but when I try to run the project, I can't find the main
"org.apache.felix.main.Main" so I'm not able to launch the application. But
when I use command line and use the "ant rebuild run" the application runs
and I can use my softphone correctly.

Hope someone can help me.

Thanks all.


#2

Hello Asmouta

I can't find the main "org.apache.felix.main.Main"

Make sure that both

./bundle/org.apache.felix.servicebinder-0.8.0-SNAPSHOT.jar
and
./felix.jar

are in yourr classpath
Cheers
Emil

asmouta wrote:

···

Hi all,

I'm trying to use the sip-communicator-release1 source with eclipse and it compiles correctly but when I try to run the project, I can't find the main "org.apache.felix.main.Main" so I'm not able to launch the application. But when I use command line and use the "ant rebuild run" the application runs and I can use my softphone correctly.

Hope someone can help me.

Thanks all.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#3

Hi Emil,

Thanks for the reply, yes the two jar files are within the lib directory and
are in the .classpath of the the project. Is there anything else to verify??

Best regards.

···

On 4/23/07, Emil Ivov <emcho@emcho.com> wrote:

Hello Asmouta

> I can't find the main "org.apache.felix.main.Main"

Make sure that both

./bundle/org.apache.felix.servicebinder-0.8.0-SNAPSHOT.jar
and
./felix.jar

are in yourr classpath
Cheers
Emil

asmouta wrote:
> Hi all,
>
> I'm trying to use the sip-communicator-release1 source with eclipse and
> it compiles correctly but when I try to run the project, I can't find
> the main "org.apache.felix.main.Main" so I'm not able to launch the
> application. But when I use command line and use the "ant rebuild run"
> the application runs and I can use my softphone correctly.
>
> Hope someone can help me.
>
> Thanks all.
>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net