[sip-comm-dev] [VOTE] Alan Kelly for Committer


#1

Hello all,

I would like to call a vote for granting commit rights (java.net
Developer role) to Alan Kelly.

Alan, got involved with SIP Communicator in 2008 and has so far made the
following list of contributions:

* Contributed a patch that fixes adding of plugin components in the main
window toolbar.
* Submitted a fix for the way the Whiteboard access menu item was being
registered with the application.
* Submitted a patch that allows us avoiding DNS queries by the SIP
package when using raw IP addresses.
* Improved code for resolving SIP and XMPP addresses though SRV queries.
Made the tabs in the configuration frame scrollable.
* Changed some important UI strings to improve consistency.
* Contributed modifications of all application resources to match the
new resource convention.
* Removed the tool tips of the main menu items.

Therefore, according to the procedure described in "Becoming a SIP
Communicator Committer" :
http://www.sip-communicator.org/index.php/Documentation/CommitAccess

I am calling this vote on granting him the java.net Developer role.

[ ] +1 Accept Alan as a committer.
[ ] 0 Does not matter to me.
[ ] -1 Reject Alan as a committer.

Note: Votes from non-developers (non-binding votes) are encouraged since
they show the general opinion of the SIP Communicator community.

Emil

···

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#2

+1

-> richard

Emil Ivov wrote:

···

Hello all,

I would like to call a vote for granting commit rights (java.net
Developer role) to Alan Kelly.

Alan, got involved with SIP Communicator in 2008 and has so far made the
following list of contributions:

* Contributed a patch that fixes adding of plugin components in the main
window toolbar.
* Submitted a fix for the way the Whiteboard access menu item was being
registered with the application.
* Submitted a patch that allows us avoiding DNS queries by the SIP
package when using raw IP addresses.
* Improved code for resolving SIP and XMPP addresses though SRV queries.
Made the tabs in the configuration frame scrollable.
* Changed some important UI strings to improve consistency.
* Contributed modifications of all application resources to match the
new resource convention.
* Removed the tool tips of the main menu items.

Therefore, according to the procedure described in "Becoming a SIP
Communicator Committer" :
http://www.sip-communicator.org/index.php/Documentation/CommitAccess

I am calling this vote on granting him the java.net Developer role.

[ ] +1 Accept Alan as a committer.
[ ] 0 Does not matter to me.
[ ] -1 Reject Alan as a committer.

Note: Votes from non-developers (non-binding votes) are encouraged since
they show the general opinion of the SIP Communicator community.

Emil

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#3

Nice contributions list! Thanks Alan!

romain

···

On 2009/01/20, at 10:45, Emil Ivov wrote:

[ X ] +1 Accept Alan as a committer.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#4

+1 (non-binding)

···

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#5

[ X ] +1 Accept Alan as a committer.

···

On Tue, Jan 20, 2009 at 10:45 AM, Emil Ivov <emcho@sip-communicator.org> wrote:
--
Sébastien Mazy

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#6

[x] +1 Accept Alan as a committer.

Cheers
Michael Koch

···

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#7

+1 Accept Alan as a committer.

Alain, thanks for taking care of so tedious issues like changing the resources!!

Emil Ivov wrote:

···

Hello all,

I would like to call a vote for granting commit rights (java.net
Developer role) to Alan Kelly.

Alan, got involved with SIP Communicator in 2008 and has so far made the
following list of contributions:

* Contributed a patch that fixes adding of plugin components in the main
window toolbar.
* Submitted a fix for the way the Whiteboard access menu item was being
registered with the application.
* Submitted a patch that allows us avoiding DNS queries by the SIP
package when using raw IP addresses.
* Improved code for resolving SIP and XMPP addresses though SRV queries.
Made the tabs in the configuration frame scrollable.
* Changed some important UI strings to improve consistency.
* Contributed modifications of all application resources to match the
new resource convention.
* Removed the tool tips of the main menu items.

Therefore, according to the procedure described in "Becoming a SIP
Communicator Committer" :
http://www.sip-communicator.org/index.php/Documentation/CommitAccess

I am calling this vote on granting him the java.net Developer role.

[ ] +1 Accept Alan as a committer.
[ ] 0 Does not matter to me.
[ ] -1 Reject Alan as a committer.

Note: Votes from non-developers (non-binding votes) are encouraged since
they show the general opinion of the SIP Communicator community.

Emil

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#8

[ x ] +1 Accept Alan as a committer.
[ ] 0 Does not matter to me.
[ ] -1 Reject Alan as a committer.

···

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#9

[ x ] +1 Accept Alan as a committer.
[ ] 0 Does not matter to me.
[ ] -1 Reject Alan as a committer.

···

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#10

+1 Accept Alan as a committer.

···

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#11

[x] +1 Accept Alan as a committer.

Vincent

···

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#12

+1

Emil

Emil Ivov wrote:

···

Hello all,

I would like to call a vote for granting commit rights (java.net
Developer role) to Alan Kelly.

Alan, got involved with SIP Communicator in 2008 and has so far made the
following list of contributions:

* Contributed a patch that fixes adding of plugin components in the main
window toolbar.
* Submitted a fix for the way the Whiteboard access menu item was being
registered with the application.
* Submitted a patch that allows us avoiding DNS queries by the SIP
package when using raw IP addresses.
* Improved code for resolving SIP and XMPP addresses though SRV queries.
Made the tabs in the configuration frame scrollable.
* Changed some important UI strings to improve consistency.
* Contributed modifications of all application resources to match the
new resource convention.
* Removed the tool tips of the main menu items.

Therefore, according to the procedure described in "Becoming a SIP
Communicator Committer" :
http://www.sip-communicator.org/index.php/Documentation/CommitAccess

I am calling this vote on granting him the java.net Developer role.

[ ] +1 Accept Alan as a committer.
[ ] 0 Does not matter to me.
[ ] -1 Reject Alan as a committer.

Note: Votes from non-developers (non-binding votes) are encouraged since
they show the general opinion of the SIP Communicator community.

Emil

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#13

[x] +1 Accept Alan as a committer.

Cheers,
Dai

···

On Tue, Jan 20, 2009 at 5:45 PM, Emil Ivov <emcho@sip-communicator.org>wrote:

Hello all,

I would like to call a vote for granting commit rights (java.net
Developer role) to Alan Kelly.

Alan, got involved with SIP Communicator in 2008 and has so far made the
following list of contributions:

* Contributed a patch that fixes adding of plugin components in the main
window toolbar.
* Submitted a fix for the way the Whiteboard access menu item was being
registered with the application.
* Submitted a patch that allows us avoiding DNS queries by the SIP
package when using raw IP addresses.
* Improved code for resolving SIP and XMPP addresses though SRV queries.
Made the tabs in the configuration frame scrollable.
* Changed some important UI strings to improve consistency.
* Contributed modifications of all application resources to match the
new resource convention.
* Removed the tool tips of the main menu items.

Therefore, according to the procedure described in "Becoming a SIP
Communicator Committer" :
http://www.sip-communicator.org/index.php/Documentation/CommitAccess

I am calling this vote on granting him the java.net Developer role.

[ ] +1 Accept Alan as a committer.
[ ] 0 Does not matter to me.
[ ] -1 Reject Alan as a committer.

Note: Votes from non-developers (non-binding votes) are encouraged since
they show the general opinion of the SIP Communicator community.

Emil

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#14

Hey folks,

Time to close this one.

Here's the vote summary:

+1 Accept Alan as a committer: Romain Kuntz, Marcel Offermans, Emanuel
Onica, Sebastien Mazy, Damian Minkov, Lubomir Marinov, Michael Koch,
Yana Stamcheva, Vincent Lucas, Dai Zhiwei, Emil Ivov, Earl, Richard Hall.

0 Does not matter to me: 0

-1 Reject Alan as a committer: 0

Congratulations Alan! You're now officially a SIP Communicator
developer. Welcome to the team!

Cheers,
Emil

Emil Ivov wrote:

···

Hello all,

I would like to call a vote for granting commit rights (java.net
Developer role) to Alan Kelly.

Alan, got involved with SIP Communicator in 2008 and has so far made the
following list of contributions:

* Contributed a patch that fixes adding of plugin components in the main
window toolbar.
* Submitted a fix for the way the Whiteboard access menu item was being
registered with the application.
* Submitted a patch that allows us avoiding DNS queries by the SIP
package when using raw IP addresses.
* Improved code for resolving SIP and XMPP addresses though SRV queries.
Made the tabs in the configuration frame scrollable.
* Changed some important UI strings to improve consistency.
* Contributed modifications of all application resources to match the
new resource convention.
* Removed the tool tips of the main menu items.

Therefore, according to the procedure described in "Becoming a SIP
Communicator Committer" :
http://www.sip-communicator.org/index.php/Documentation/CommitAccess

I am calling this vote on granting him the java.net Developer role.

[ ] +1 Accept Alan as a committer.
[ ] 0 Does not matter to me.
[ ] -1 Reject Alan as a committer.

Note: Votes from non-developers (non-binding votes) are encouraged since
they show the general opinion of the SIP Communicator community.

Emil

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#15

Hello all

I successfully installed SC in debian, and its working ok.

But when i launch it, i allways get this "GLIBC_2.4" Exception.

And i cant find this package for Debian, only the 2.3.

Where can i get it , what package should i install, why doesnt it come
with "apt-get install sip-communicator" ???

You can see the exception below.

Thanks

Carlos

···

************************************************************************
*************************************************

19:00:2009-19:52:46.400 WARNING: fmj.addCaptureDevices()
com.lti.civil.CaptureException: java.lang.UnsatisfiedLinkError:
/mnt/vcs/nav-communicator/lib/native/linux/libcivil.so:
/lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4' not found (required by
/mnt/vcs/nav-communicator/lib/native/linux/libcivil.so)

com.lti.civil.CaptureException: java.lang.UnsatisfiedLinkError:
/mnt/vcs/nav-communicator/lib/native/linux/libcivil.so:
/lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4' not found (required by
/mnt/vcs/nav-communicator/lib/native/linux/libcivil.so)

      at
com.lti.civil.impl.jni.NativeCaptureSystemFactory.createCaptureSystem(Na
tiveCaptureSystemFactory.java:24)

      at
net.sf.fmj.media.cdp.civil.CaptureDevicePlugger.addCaptureDevices(Captur
eDevicePlugger.java:37)

      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

      at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.jav
a:39)

      at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessor
Impl.java:25)

      at java.lang.reflect.Method.invoke(Method.java:597)

      at
net.java.sip.communicator.impl.media.device.FMJCivilVideoAuto.<init>(FMJ
CivilVideoAuto.java:33)

      at
net.java.sip.communicator.impl.media.device.JmfDeviceDetector.detectCapt
ureDevices(JmfDeviceDetector.java:234)

      at
net.java.sip.communicator.impl.media.device.JmfDeviceDetector.initialize
(JmfDeviceDetector.java:119)

      at
net.java.sip.communicator.impl.media.device.JmfDeviceDetector.setupJMF(J
mfDeviceDetector.java:364)

      at
net.java.sip.communicator.impl.media.device.JmfDeviceDetector.detectAndC
onfigureCaptureDevices(JmfDeviceDetector.java:412)

      at
net.java.sip.communicator.impl.media.device.DeviceConfiguration.initiali
ze(DeviceConfiguration.java:125)

      at
net.java.sip.communicator.impl.media.MediaServiceImpl$DeviceConfiguratio
nThread.run(MediaServiceImpl.java:408)

Caused by: java.lang.UnsatisfiedLinkError:
/mnt/vcs/nav-communicator/lib/native/linux/libcivil.so:
/lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4' not found (required by
/mnt/vcs/nav-communicator/lib/native/linux/libcivil.so)

      at java.lang.ClassLoader$NativeLibrary.load(Native Method)

      at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1751)

      at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1676)

      at java.lang.Runtime.loadLibrary0(Runtime.java:823)

      at java.lang.System.loadLibrary(System.java:1030)

      at
com.lti.civil.impl.jni.NativeCaptureSystemFactory.createCaptureSystem(Na
tiveCaptureSystemFactory.java:21)

      ... 12 more


#16

+1 Accept Alan as a committer.

Earl

···

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#17

Thanks, everyone! :slight_smile: I appreciate it, and I'll use the power wisely.

I just committed a few fixes for some minor bugs that have been bothering me... I'll wait to make sure everything's ok, then I have a few more coming.

-Alan

···

----- Original Message -----

From: Emil Ivov <emcho@sip-communicator.org>

Date: Wednesday, January 21, 2009 11:27 am
Subject: Re: [sip-comm-dev] [VOTE] Alan Kelly for Committer

Hey folks,

Time to close this one.

Here's the vote summary:

+1 Accept Alan as a committer: Romain Kuntz, Marcel Offermans, Emanuel
Onica, Sebastien Mazy, Damian Minkov, Lubomir Marinov, Michael Koch,
Yana Stamcheva, Vincent Lucas, Dai Zhiwei, Emil Ivov, Earl,
Richard Hall.

0 Does not matter to me: 0

-1 Reject Alan as a committer: 0

Congratulations Alan! You're now officially a SIP Communicator
developer. Welcome to the team!

Cheers,
Emil

Emil Ivov wrote:
> Hello all,
>
> I would like to call a vote for granting commit rights (java.net
> Developer role) to Alan Kelly.
>
> Alan, got involved with SIP Communicator in 2008 and has so far
made the
> following list of contributions:
>
> * Contributed a patch that fixes adding of plugin components in
the main
> window toolbar.
> * Submitted a fix for the way the Whiteboard access menu item
was being
> registered with the application.
> * Submitted a patch that allows us avoiding DNS queries by the SIP
> package when using raw IP addresses.
> * Improved code for resolving SIP and XMPP addresses though SRV
queries.> Made the tabs in the configuration frame scrollable.
> * Changed some important UI strings to improve consistency.
> * Contributed modifications of all application resources to
match the
> new resource convention.
> * Removed the tool tips of the main menu items.
>
> Therefore, according to the procedure described in "Becoming a SIP
> Communicator Committer" :
> http://www.sip-communicator.org/index.php/Documentation/CommitAccess
>
> I am calling this vote on granting him the java.net Developer role.
>
>
> [ ] +1 Accept Alan as a committer.
> [ ] 0 Does not matter to me.
> [ ] -1 Reject Alan as a committer.
>
> Note: Votes from non-developers (non-binding votes) are
encouraged since
> they show the general opinion of the SIP Communicator community.
>
> Emil
>
>
> -----------------------------------------------------------------
----
> To unsubscribe, e-mail: dev-unsubscribe@sip-
communicator.dev.java.net> For additional commands, e-mail: dev-
help@sip-communicator.dev.java.net
>
>

-------------------------------------------------------------------
--
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-
communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#18

Hi Carlos,

it seems that the problem comes from loading the civil native code.
But as I was looking at the svn history of the file I saw that I have modified it. Modification was due to an exception
which Lubomir has fixed. Obviously I had compiled it with newer versions and it fails on your machine. And my fault is that I hadn't send the patch to fmj list. But I'll do it right now. Will fix it as soon as possible, in the mean while can you say which Debian version are you using ?

damencho

Carlos Alexandre wrote:

···

Hello all

I successfully installed SC in debian, and its working ok.

But when i launch it, i allways get this �GLIBC_2.4� Exception.

And i cant find this package for Debian, only the 2.3.

Where can i get it , what package should i install, why doesnt it come with �apt-get install sip-communicator� ???

You can see the exception below.

Thanks

Carlos

*************************************************************************************************************************

19:00:2009-19:52:46.400 WARNING: fmj.addCaptureDevices() com.lti.civil.CaptureException: java.lang.UnsatisfiedLinkError: /mnt/vcs/nav-communicator/lib/native/linux/libcivil.so: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4' not found (required by /mnt/vcs/nav-communicator/lib/native/linux/libcivil.so)

com.lti.civil.CaptureException: java.lang.UnsatisfiedLinkError: /mnt/vcs/nav-communicator/lib/native/linux/libcivil.so: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4' not found (required by /mnt/vcs/nav-communicator/lib/native/linux/libcivil.so)

at com.lti.civil.impl.jni.NativeCaptureSystemFactory.createCaptureSystem(NativeCaptureSystemFactory.java:24)

at net.sf.fmj.media.cdp.civil.CaptureDevicePlugger.addCaptureDevices(CaptureDevicePlugger.java:37)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

at java.lang.reflect.Method.invoke(Method.java:597)

at net.java.sip.communicator.impl.media.device.FMJCivilVideoAuto.<init>(FMJCivilVideoAuto.java:33)

at net.java.sip.communicator.impl.media.device.JmfDeviceDetector.detectCaptureDevices(JmfDeviceDetector.java:234)

at net.java.sip.communicator.impl.media.device.JmfDeviceDetector.initialize(JmfDeviceDetector.java:119)

at net.java.sip.communicator.impl.media.device.JmfDeviceDetector.setupJMF(JmfDeviceDetector.java:364)

at net.java.sip.communicator.impl.media.device.JmfDeviceDetector.detectAndConfigureCaptureDevices(JmfDeviceDetector.java:412)

at net.java.sip.communicator.impl.media.device.DeviceConfiguration.initialize(DeviceConfiguration.java:125)

at net.java.sip.communicator.impl.media.MediaServiceImpl$DeviceConfigurationThread.run(MediaServiceImpl.java:408)

Caused by: java.lang.UnsatisfiedLinkError: /mnt/vcs/nav-communicator/lib/native/linux/libcivil.so: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4' not found (required by /mnt/vcs/nav-communicator/lib/native/linux/libcivil.so)

at java.lang.ClassLoader$NativeLibrary.load(Native Method)

at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1751)

at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1676)

at java.lang.Runtime.loadLibrary0(Runtime.java:823)

at java.lang.System.loadLibrary(System.java:1030)

at com.lti.civil.impl.jni.NativeCaptureSystemFactory.createCaptureSystem(NativeCaptureSystemFactory.java:21)

... 12 more

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#19

hi

Im using theese Debian versions:
2.6.18-6-686
2.6.18-5-686

Thanks

Carlos

···

-----Original Message-----

From: Damian Minkov [mailto:damencho@damencho.com]

Sent: terça-feira, 20 de Janeiro de 2009 13:38
To: dev@sip-communicator.dev.java.net
Subject: Re: [sip-comm-dev] GLIBC_2.4 Exception

Hi Carlos,

it seems that the problem comes from loading the civil native code.
But as I was looking at the svn history of the file I saw that I have
modified it. Modification was due to an exception
which Lubomir has fixed. Obviously I had compiled it with newer versions
and it fails on your machine. And my fault is that I hadn't send the
patch to fmj list. But I'll do it right now. Will fix it as soon as
possible, in the mean while can you say which Debian version are you using ?

damencho

Carlos Alexandre wrote:

Hello all

I successfully installed SC in debian, and its working ok.

But when i launch it, i allways get this "GLIBC_2.4" Exception.

And i cant find this package for Debian, only the 2.3.

Where can i get it , what package should i install, why doesnt it come
with "apt-get install sip-communicator" ???

You can see the exception below.

Thanks

Carlos

*************************************************************************************************************************

19:00:2009-19:52:46.400 WARNING: fmj.addCaptureDevices()
com.lti.civil.CaptureException: java.lang.UnsatisfiedLinkError:
/mnt/vcs/nav-communicator/lib/native/linux/libcivil.so:
/lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4' not found (required
by /mnt/vcs/nav-communicator/lib/native/linux/libcivil.so)

com.lti.civil.CaptureException: java.lang.UnsatisfiedLinkError:
/mnt/vcs/nav-communicator/lib/native/linux/libcivil.so:
/lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4' not found (required
by /mnt/vcs/nav-communicator/lib/native/linux/libcivil.so)

at
com.lti.civil.impl.jni.NativeCaptureSystemFactory.createCaptureSystem(NativeCaptureSystemFactory.java:24)

at
net.sf.fmj.media.cdp.civil.CaptureDevicePlugger.addCaptureDevices(CaptureDevicePlugger.java:37)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

at java.lang.reflect.Method.invoke(Method.java:597)

at
net.java.sip.communicator.impl.media.device.FMJCivilVideoAuto.<init>(FMJCivilVideoAuto.java:33)

at
net.java.sip.communicator.impl.media.device.JmfDeviceDetector.detectCaptureDevices(JmfDeviceDetector.java:234)

at
net.java.sip.communicator.impl.media.device.JmfDeviceDetector.initialize(JmfDeviceDetector.java:119)

at
net.java.sip.communicator.impl.media.device.JmfDeviceDetector.setupJMF(JmfDeviceDetector.java:364)

at
net.java.sip.communicator.impl.media.device.JmfDeviceDetector.detectAndConfigureCaptureDevices(JmfDeviceDetector.java:412)

at
net.java.sip.communicator.impl.media.device.DeviceConfiguration.initialize(DeviceConfiguration.java:125)

at
net.java.sip.communicator.impl.media.MediaServiceImpl$DeviceConfigurationThread.run(MediaServiceImpl.java:408)

Caused by: java.lang.UnsatisfiedLinkError:
/mnt/vcs/nav-communicator/lib/native/linux/libcivil.so:
/lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4' not found (required
by /mnt/vcs/nav-communicator/lib/native/linux/libcivil.so)

at java.lang.ClassLoader$NativeLibrary.load(Native Method)

at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1751)

at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1676)

at java.lang.Runtime.loadLibrary0(Runtime.java:823)

at java.lang.System.loadLibrary(System.java:1030)

at
com.lti.civil.impl.jni.NativeCaptureSystemFactory.createCaptureSystem(NativeCaptureSystemFactory.java:21)

... 12 more

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#20

Hi Carlos,

I've just committed new version of lti-civil native lib, which caused your problems.
Could you test and report is it ok now - its in latest source or will be available in build 1651.

damencho

Carlos Alexandre wrote:

···

hi

Im using theese Debian versions:
2.6.18-6-686
2.6.18-5-686

Thanks

Carlos

-----Original Message-----
From: Damian Minkov [mailto:damencho@damencho.com] Sent: ter�a-feira, 20 de Janeiro de 2009 13:38
To: dev@sip-communicator.dev.java.net
Subject: Re: [sip-comm-dev] GLIBC_2.4 Exception

Hi Carlos,

it seems that the problem comes from loading the civil native code.
But as I was looking at the svn history of the file I saw that I have modified it. Modification was due to an exception
which Lubomir has fixed. Obviously I had compiled it with newer versions and it fails on your machine. And my fault is that I hadn't send the patch to fmj list. But I'll do it right now. Will fix it as soon as possible, in the mean while can you say which Debian version are you using ?

damencho

Carlos Alexandre wrote:
  

Hello all

I successfully installed SC in debian, and its working ok.

But when i launch it, i allways get this "GLIBC_2.4" Exception.

And i cant find this package for Debian, only the 2.3.

Where can i get it , what package should i install, why doesnt it come with "apt-get install sip-communicator" ???

You can see the exception below.

Thanks

Carlos

*************************************************************************************************************************

19:00:2009-19:52:46.400 WARNING: fmj.addCaptureDevices() com.lti.civil.CaptureException: java.lang.UnsatisfiedLinkError: /mnt/vcs/nav-communicator/lib/native/linux/libcivil.so: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4' not found (required by /mnt/vcs/nav-communicator/lib/native/linux/libcivil.so)

com.lti.civil.CaptureException: java.lang.UnsatisfiedLinkError: /mnt/vcs/nav-communicator/lib/native/linux/libcivil.so: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4' not found (required by /mnt/vcs/nav-communicator/lib/native/linux/libcivil.so)

at com.lti.civil.impl.jni.NativeCaptureSystemFactory.createCaptureSystem(NativeCaptureSystemFactory.java:24)

at net.sf.fmj.media.cdp.civil.CaptureDevicePlugger.addCaptureDevices(CaptureDevicePlugger.java:37)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

at java.lang.reflect.Method.invoke(Method.java:597)

at net.java.sip.communicator.impl.media.device.FMJCivilVideoAuto.<init>(FMJCivilVideoAuto.java:33)

at net.java.sip.communicator.impl.media.device.JmfDeviceDetector.detectCaptureDevices(JmfDeviceDetector.java:234)

at net.java.sip.communicator.impl.media.device.JmfDeviceDetector.initialize(JmfDeviceDetector.java:119)

at net.java.sip.communicator.impl.media.device.JmfDeviceDetector.setupJMF(JmfDeviceDetector.java:364)

at net.java.sip.communicator.impl.media.device.JmfDeviceDetector.detectAndConfigureCaptureDevices(JmfDeviceDetector.java:412)

at net.java.sip.communicator.impl.media.device.DeviceConfiguration.initialize(DeviceConfiguration.java:125)

at net.java.sip.communicator.impl.media.MediaServiceImpl$DeviceConfigurationThread.run(MediaServiceImpl.java:408)

Caused by: java.lang.UnsatisfiedLinkError: /mnt/vcs/nav-communicator/lib/native/linux/libcivil.so: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.4' not found (required by /mnt/vcs/nav-communicator/lib/native/linux/libcivil.so)

at java.lang.ClassLoader$NativeLibrary.load(Native Method)

at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1751)

at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1676)

at java.lang.Runtime.loadLibrary0(Runtime.java:823)

at java.lang.System.loadLibrary(System.java:1030)

at com.lti.civil.impl.jni.NativeCaptureSystemFactory.createCaptureSystem(NativeCaptureSystemFactory.java:21)

... 12 more

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net