[sip-comm-dev] video capture on sip-communicator.


#1

Hi,

I have installed sip communicator on my fedora machine.
duirng testing voice works, but video fails.

my webcam is logitech QuickCam Express.

I individually tested webcam, it is working.
Also, i tested it with skype and linphone, both are working fine.

When i try to run sip-communicator, i get following errors and unable to see
the video preview.

run:
     [java]
     [java] Welcome to Felix.
     [java] =================
     [java]
     [java] fg2_open failed
     [java] 22:54:08.506 WARNING: fmj.addCaptureDevices()
com.lti.civil.CaptureException: VIDIOC_G_FMT failed: 22
     [java] com.lti.civil.CaptureException: VIDIOC_G_FMT failed: 22
     [java] at
com.lti.civil.impl.jni.NativeCaptureSystem.openCaptureDeviceStream(Native
Method)
     [java] at
net.sf.fmj.media.cdp.civil.CaptureDevicePlugger.getFormats(CaptureDevicePlugger.java:87)
     [java] at
net.sf.fmj.media.cdp.civil.CaptureDevicePlugger.addCaptureDevices(CaptureDevicePlugger.java:58)
     [java] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native
Method)
     [java] at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
     [java] at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
     [java] at java.lang.reflect.Method.invoke(Method.java:597)
     [java] at
net.java.sip.communicator.impl.media.device.FMJCivilVideoAuto.<init>(FMJCivilVideoAuto.java:33)

Regards,
HarishKumar.V


#2

Hi,

I haven't seen such an error, strange. Could you send the output of the command $v4l-info.

damencho

Harishkumar V wrote:

···

Hi,

I have installed sip communicator on my fedora machine.
duirng testing voice works, but video fails.

my webcam is logitech QuickCam Express.

I individually tested webcam, it is working.
Also, i tested it with skype and linphone, both are working fine.

When i try to run sip-communicator, i get following errors and unable to see the video preview.

run:
     [java]
     [java] Welcome to Felix.
     [java] =================
     [java]
     [java] fg2_open failed
     [java] 22:54:08.506 WARNING: fmj.addCaptureDevices() com.lti.civil.CaptureException: VIDIOC_G_FMT failed: 22
     [java] com.lti.civil.CaptureException: VIDIOC_G_FMT failed: 22
     [java] at com.lti.civil.impl.jni.NativeCaptureSystem.openCaptureDeviceStream(Native Method)
     [java] at net.sf.fmj.media.cdp.civil.CaptureDevicePlugger.getFormats(CaptureDevicePlugger.java:87)
     [java] at net.sf.fmj.media.cdp.civil.CaptureDevicePlugger.addCaptureDevices(CaptureDevicePlugger.java:58)
     [java] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
     [java] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
     [java] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
     [java] at java.lang.reflect.Method.invoke(Method.java:597)
     [java] at net.java.sip.communicator.impl.media.device.FMJCivilVideoAuto.<init>(FMJCivilVideoAuto.java:33)

Regards,
HarishKumar.V

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#3

Damencho,

This is my output of v4l-info

#v4l-info

### video4linux device info [/dev/video0] ###
general info
    VIDIOCGCAP
        name : "Logitech QuickCam EC"
        type : 0x1 [CAPTURE]
        channels : 1
        audios : 0
        maxwidth : 352
        maxheight : 288
        minwidth : 160
        minheight : 120

channels
    VIDIOCGCHAN(0)
        channel : 0
        name : "SPCA561"
        tuners : 0
        flags : 0x0 []
        type : CAMERA
        norm : 0

tuner
ioctl VIDIOCGTUNER: Invalid argument

audio
ioctl VIDIOCGAUDIO: Invalid argument

picture
    VIDIOCGPICT
        brightness : 16384
        hue : 0
        colour : 0
        contrast : 8192
        whiteness : 0
        depth : 24
        palette : RGB24

buffer
    VIDIOCGFBUF
        base : (nil)
        height : 0
        width : 0
        depth : 0
        bytesperline : 0

window
    VIDIOCGWIN
        x : 0
        y : 0
        width : 160
        height : 120
        chromakey : 0
        flags : 0

Regards,
HarishKumar.V

···

On Tue, Mar 17, 2009 at 6:15 PM, Damian Minkov <damencho@damencho.com>wrote:

Hi,

I haven't seen such an error, strange. Could you send the output of the
command $v4l-info.

damencho

Harishkumar V wrote:

Hi,

I have installed sip communicator on my fedora machine.
duirng testing voice works, but video fails.

my webcam is logitech QuickCam Express.

I individually tested webcam, it is working.
Also, i tested it with skype and linphone, both are working fine.

When i try to run sip-communicator, i get following errors and unable to
see the video preview.

run:
    [java]
    [java] Welcome to Felix.
    [java] =================
    [java]
    [java] fg2_open failed
    [java] 22:54:08.506 WARNING: fmj.addCaptureDevices()
com.lti.civil.CaptureException: VIDIOC_G_FMT failed: 22
    [java] com.lti.civil.CaptureException: VIDIOC_G_FMT failed: 22
    [java] at
com.lti.civil.impl.jni.NativeCaptureSystem.openCaptureDeviceStream(Native
Method)
    [java] at
net.sf.fmj.media.cdp.civil.CaptureDevicePlugger.getFormats(CaptureDevicePlugger.java:87)
    [java] at
net.sf.fmj.media.cdp.civil.CaptureDevicePlugger.addCaptureDevices(CaptureDevicePlugger.java:58)
    [java] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native
Method)
    [java] at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    [java] at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    [java] at java.lang.reflect.Method.invoke(Method.java:597)
    [java] at
net.java.sip.communicator.impl.media.device.FMJCivilVideoAuto.<init>(FMJCivilVideoAuto.java:33)

Regards,
HarishKumar.V

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#4

Hi,

my svn revision is 5146.

i am building sip-communicator using ant,

cd sip-communicator,

ant clean
ant rebuild
ant run

Regards,
HarishKumar.V

···

On Tue, Mar 17, 2009 at 6:44 PM, Harishkumar V <harishpresent@gmail.com>wrote:

Damencho,

This is my output of v4l-info

#v4l-info

### video4linux device info [/dev/video0] ###
general info
    VIDIOCGCAP
        name : "Logitech QuickCam EC"
        type : 0x1 [CAPTURE]
        channels : 1
        audios : 0
        maxwidth : 352
        maxheight : 288
        minwidth : 160
        minheight : 120

channels
    VIDIOCGCHAN(0)
        channel : 0
        name : "SPCA561"
        tuners : 0
        flags : 0x0 []
        type : CAMERA
        norm : 0

tuner
ioctl VIDIOCGTUNER: Invalid argument

audio
ioctl VIDIOCGAUDIO: Invalid argument

picture
    VIDIOCGPICT
        brightness : 16384
        hue : 0
        colour : 0
        contrast : 8192
        whiteness : 0
        depth : 24
        palette : RGB24

buffer
    VIDIOCGFBUF
        base : (nil)
        height : 0
        width : 0
        depth : 0
        bytesperline : 0

window
    VIDIOCGWIN
        x : 0
        y : 0
        width : 160
        height : 120
        chromakey : 0
        flags : 0

Regards,
HarishKumar.V

On Tue, Mar 17, 2009 at 6:15 PM, Damian Minkov <damencho@damencho.com>wrote:

Hi,

I haven't seen such an error, strange. Could you send the output of the
command $v4l-info.

damencho

Harishkumar V wrote:

Hi,

I have installed sip communicator on my fedora machine.
duirng testing voice works, but video fails.

my webcam is logitech QuickCam Express.

I individually tested webcam, it is working.
Also, i tested it with skype and linphone, both are working fine.

When i try to run sip-communicator, i get following errors and unable to
see the video preview.

run:
    [java]
    [java] Welcome to Felix.
    [java] =================
    [java]
    [java] fg2_open failed
    [java] 22:54:08.506 WARNING: fmj.addCaptureDevices()
com.lti.civil.CaptureException: VIDIOC_G_FMT failed: 22
    [java] com.lti.civil.CaptureException: VIDIOC_G_FMT failed: 22
    [java] at
com.lti.civil.impl.jni.NativeCaptureSystem.openCaptureDeviceStream(Native
Method)
    [java] at
net.sf.fmj.media.cdp.civil.CaptureDevicePlugger.getFormats(CaptureDevicePlugger.java:87)
    [java] at
net.sf.fmj.media.cdp.civil.CaptureDevicePlugger.addCaptureDevices(CaptureDevicePlugger.java:58)
    [java] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native
Method)
    [java] at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    [java] at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    [java] at java.lang.reflect.Method.invoke(Method.java:597)
    [java] at
net.java.sip.communicator.impl.media.device.FMJCivilVideoAuto.<init>(FMJCivilVideoAuto.java:33)

Regards,
HarishKumar.V

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#5

Hi,

as I can see your webcam is using v4l. For video capture we are using lti-civil which supports v4l2.
Maybe you can check which module you are using for the webcam and search is there another one which suports v4l2.

damencho

Harishkumar V wrote:

···

Damencho,

This is my output of v4l-info

#v4l-info

### video4linux device info [/dev/video0] ###
general info
    VIDIOCGCAP
        name : "Logitech QuickCam EC"
        type : 0x1 [CAPTURE]
        channels : 1
        audios : 0
        maxwidth : 352
        maxheight : 288
        minwidth : 160
        minheight : 120

channels
    VIDIOCGCHAN(0)
        channel : 0
        name : "SPCA561"
        tuners : 0
        flags : 0x0 []
        type : CAMERA
        norm : 0

tuner
ioctl VIDIOCGTUNER: Invalid argument

audio
ioctl VIDIOCGAUDIO: Invalid argument

picture
    VIDIOCGPICT
        brightness : 16384
        hue : 0
        colour : 0
        contrast : 8192
        whiteness : 0
        depth : 24
        palette : RGB24

buffer
    VIDIOCGFBUF
        base : (nil)
        height : 0
        width : 0
        depth : 0
        bytesperline : 0

window
    VIDIOCGWIN
        x : 0
        y : 0
        width : 160
        height : 120
        chromakey : 0
        flags : 0

Regards,
HarishKumar.V

On Tue, Mar 17, 2009 at 6:15 PM, Damian Minkov <damencho@damencho.com > <mailto:damencho@damencho.com>> wrote:

    Hi,

    I haven't seen such an error, strange. Could you send the output
    of the command $v4l-info.

    damencho

    Harishkumar V wrote:

        Hi,

        I have installed sip communicator on my fedora machine.
        duirng testing voice works, but video fails.

        my webcam is logitech QuickCam Express.

        I individually tested webcam, it is working.
        Also, i tested it with skype and linphone, both are working fine.

        When i try to run sip-communicator, i get following errors and
        unable to see the video preview.

        run:
            [java]
            [java] Welcome to Felix.
            [java] =================
            [java]
            [java] fg2_open failed
            [java] 22:54:08.506 WARNING: fmj.addCaptureDevices()
        com.lti.civil.CaptureException: VIDIOC_G_FMT failed: 22
            [java] com.lti.civil.CaptureException: VIDIOC_G_FMT failed: 22
            [java] at
        com.lti.civil.impl.jni.NativeCaptureSystem.openCaptureDeviceStream(Native
        Method)
            [java] at
        net.sf.fmj.media.cdp.civil.CaptureDevicePlugger.getFormats(CaptureDevicePlugger.java:87)
            [java] at
        net.sf.fmj.media.cdp.civil.CaptureDevicePlugger.addCaptureDevices(CaptureDevicePlugger.java:58)
            [java] at
        sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
            [java] at
        sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
            [java] at
        sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
            [java] at java.lang.reflect.Method.invoke(Method.java:597)
            [java] at
        net.java.sip.communicator.impl.media.device.FMJCivilVideoAuto.<init>(FMJCivilVideoAuto.java:33)

        Regards,
        HarishKumar.V

    ---------------------------------------------------------------------
    To unsubscribe, e-mail:
    dev-unsubscribe@sip-communicator.dev.java.net
    <mailto:dev-unsubscribe@sip-communicator.dev.java.net>
    For additional commands, e-mail:
    dev-help@sip-communicator.dev.java.net
    <mailto:dev-help@sip-communicator.dev.java.net>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#6

Damencho,

The module supports v4l1.
I cross-checked with gstreamer-properties. v4l1 test passes but v4l2 test
fails.

my webcam is logitech QuickCam Express.

vendor id is 0x046d
product id is 0x092f.

The v4l2 driver is not available it seems. i have only gspcav1 version.

Is there any alternative. Can i make sip-communicator to work with v4l1 by
opening lti-civil.

Is that source is open. Any suggestions how to do will be helpful.

Regards,
HarishKumar.V

···

On Wed, Mar 18, 2009 at 4:11 PM, Damian Minkov <damencho@damencho.com>wrote:

Hi,

as I can see your webcam is using v4l. For video capture we are using
lti-civil which supports v4l2.
Maybe you can check which module you are using for the webcam and search
is there another one which suports v4l2.

damencho

Harishkumar V wrote:

Damencho,

This is my output of v4l-info

#v4l-info

### video4linux device info [/dev/video0] ###
general info
   VIDIOCGCAP
       name : "Logitech QuickCam EC"
       type : 0x1 [CAPTURE]
       channels : 1
       audios : 0
       maxwidth : 352
       maxheight : 288
       minwidth : 160
       minheight : 120

channels
   VIDIOCGCHAN(0)
       channel : 0
       name : "SPCA561"
       tuners : 0
       flags : 0x0 []
       type : CAMERA
       norm : 0

tuner
ioctl VIDIOCGTUNER: Invalid argument

audio
ioctl VIDIOCGAUDIO: Invalid argument

picture
   VIDIOCGPICT
       brightness : 16384
       hue : 0
       colour : 0
       contrast : 8192
       whiteness : 0
       depth : 24
       palette : RGB24

buffer
   VIDIOCGFBUF
       base : (nil)
       height : 0
       width : 0
       depth : 0
       bytesperline : 0

window
   VIDIOCGWIN
       x : 0
       y : 0
       width : 160
       height : 120
       chromakey : 0
       flags : 0

Regards,
HarishKumar.V

On Tue, Mar 17, 2009 at 6:15 PM, Damian Minkov <damencho@damencho.com<mailto: >> damencho@damencho.com>> wrote:

   Hi,

   I haven't seen such an error, strange. Could you send the output
   of the command $v4l-info.

   damencho

   Harishkumar V wrote:

       Hi,

       I have installed sip communicator on my fedora machine.
       duirng testing voice works, but video fails.

       my webcam is logitech QuickCam Express.

       I individually tested webcam, it is working.
       Also, i tested it with skype and linphone, both are working fine.

       When i try to run sip-communicator, i get following errors and
       unable to see the video preview.

       run:
           [java]
           [java] Welcome to Felix.
           [java] =================
           [java]
           [java] fg2_open failed
           [java] 22:54:08.506 WARNING: fmj.addCaptureDevices()
       com.lti.civil.CaptureException: VIDIOC_G_FMT failed: 22
           [java] com.lti.civil.CaptureException: VIDIOC_G_FMT failed: 22
           [java] at

com.lti.civil.impl.jni.NativeCaptureSystem.openCaptureDeviceStream(Native
       Method)
           [java] at

net.sf.fmj.media.cdp.civil.CaptureDevicePlugger.getFormats(CaptureDevicePlugger.java:87)
           [java] at

net.sf.fmj.media.cdp.civil.CaptureDevicePlugger.addCaptureDevices(CaptureDevicePlugger.java:58)
           [java] at
       sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
           [java] at

sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
           [java] at

sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
           [java] at java.lang.reflect.Method.invoke(Method.java:597)
           [java] at

net.java.sip.communicator.impl.media.device.FMJCivilVideoAuto.<init>(FMJCivilVideoAuto.java:33)

       Regards,
       HarishKumar.V

   ---------------------------------------------------------------------
   To unsubscribe, e-mail:
   dev-unsubscribe@sip-communicator.dev.java.net
   <mailto:dev-unsubscribe@sip-communicator.dev.java.net>
   For additional commands, e-mail:
   dev-help@sip-communicator.dev.java.net
   <mailto:dev-help@sip-communicator.dev.java.net>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#7

Hi,

yes lti-civil is open. What you can do is to check it out from http://lti-civil.org/.
There is some code which is not used anymore its for v4l. There is some commented lines in the ant file and in the targets compiling the native code.
And you can simply make tests with compiling the native part and running the lt-civil test programs.
They are in lti-civil/sh/linux/ - "capturecontrol.sh".

damencho

Harishkumar V wrote:

···

Damencho,

The module supports v4l1.
I cross-checked with gstreamer-properties. v4l1 test passes but v4l2 test fails.

my webcam is logitech QuickCam Express.

vendor id is 0x046d
product id is 0x092f.

The v4l2 driver is not available it seems. i have only gspcav1 version.

Is there any alternative. Can i make sip-communicator to work with v4l1 by opening lti-civil.

Is that source is open. Any suggestions how to do will be helpful.

Regards,
HarishKumar.V

On Wed, Mar 18, 2009 at 4:11 PM, Damian Minkov <damencho@damencho.com > <mailto:damencho@damencho.com>> wrote:

    Hi,

    as I can see your webcam is using v4l. For video capture we are
    using lti-civil which supports v4l2.
    Maybe you can check which module you are using for the webcam and
    search is there another one which suports v4l2.

    damencho

    Harishkumar V wrote:

        Damencho,

        This is my output of v4l-info

        #v4l-info

        ### video4linux device info [/dev/video0] ###
        general info
           VIDIOCGCAP
               name : "Logitech QuickCam EC"
               type : 0x1 [CAPTURE]
               channels : 1
               audios : 0
               maxwidth : 352
               maxheight : 288
               minwidth : 160
               minheight : 120

        channels
           VIDIOCGCHAN(0)
               channel : 0
               name : "SPCA561"
               tuners : 0
               flags : 0x0 []
               type : CAMERA
               norm : 0

        tuner
        ioctl VIDIOCGTUNER: Invalid argument

        audio
        ioctl VIDIOCGAUDIO: Invalid argument

        picture
           VIDIOCGPICT
               brightness : 16384
               hue : 0
               colour : 0
               contrast : 8192
               whiteness : 0
               depth : 24
               palette : RGB24

        buffer
           VIDIOCGFBUF
               base : (nil)
               height : 0
               width : 0
               depth : 0
               bytesperline : 0

        window
           VIDIOCGWIN
               x : 0
               y : 0
               width : 160
               height : 120
               chromakey : 0
               flags : 0

        Regards,
        HarishKumar.V

        On Tue, Mar 17, 2009 at 6:15 PM, Damian Minkov > <damencho@damencho.com <mailto:damencho@damencho.com> > <mailto:damencho@damencho.com <mailto:damencho@damencho.com>>> > wrote:

           Hi,

           I haven't seen such an error, strange. Could you send the
        output
           of the command $v4l-info.

           damencho

           Harishkumar V wrote:

               Hi,

               I have installed sip communicator on my fedora machine.
               duirng testing voice works, but video fails.

               my webcam is logitech QuickCam Express.

               I individually tested webcam, it is working.
               Also, i tested it with skype and linphone, both are
        working fine.

               When i try to run sip-communicator, i get following
        errors and
               unable to see the video preview.

               run:
                   [java]
                   [java] Welcome to Felix.
                   [java] =================
                   [java]
                   [java] fg2_open failed
                   [java] 22:54:08.506 WARNING: fmj.addCaptureDevices()
               com.lti.civil.CaptureException: VIDIOC_G_FMT failed: 22
                   [java] com.lti.civil.CaptureException: VIDIOC_G_FMT
        failed: 22
                   [java] at
                      com.lti.civil.impl.jni.NativeCaptureSystem.openCaptureDeviceStream(Native
               Method)
                   [java] at
                      net.sf.fmj.media.cdp.civil.CaptureDevicePlugger.getFormats(CaptureDevicePlugger.java:87)
                   [java] at
                      net.sf.fmj.media.cdp.civil.CaptureDevicePlugger.addCaptureDevices(CaptureDevicePlugger.java:58)
                   [java] at
               sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                   [java] at
                      sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
                   [java] at
                      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
                   [java] at
        java.lang.reflect.Method.invoke(Method.java:597)
                   [java] at
                      net.java.sip.communicator.impl.media.device.FMJCivilVideoAuto.<init>(FMJCivilVideoAuto.java:33)

               Regards,
               HarishKumar.V

                  ---------------------------------------------------------------------
           To unsubscribe, e-mail:
           dev-unsubscribe@sip-communicator.dev.java.net
        <mailto:dev-unsubscribe@sip-communicator.dev.java.net>
           <mailto:dev-unsubscribe@sip-communicator.dev.java.net
        <mailto:dev-unsubscribe@sip-communicator.dev.java.net>>

           For additional commands, e-mail:
           dev-help@sip-communicator.dev.java.net
        <mailto:dev-help@sip-communicator.dev.java.net>
           <mailto:dev-help@sip-communicator.dev.java.net
        <mailto:dev-help@sip-communicator.dev.java.net>>

    ---------------------------------------------------------------------
    To unsubscribe, e-mail:
    dev-unsubscribe@sip-communicator.dev.java.net
    <mailto:dev-unsubscribe@sip-communicator.dev.java.net>
    For additional commands, e-mail:
    dev-help@sip-communicator.dev.java.net
    <mailto:dev-help@sip-communicator.dev.java.net>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#8

Damencho,

Thanks, but eventually got gspca v4l2 driver with the linux2.6.27 onwards.

after compiling and installing the driver. the webcam was claimed by
gspca_spca561 driver.

using v4l-info, i am able to make sure it has both v4l2 and v4l1 interface.
i also attached the v4l-info-output.

Then, i tried sip-communicator, it failed. but with different warning.

Buildfile: build.xml

deploy-os-specific-bundles:

run:
     [java]
     [java] Welcome to Felix.
     [java] =================
     [java]
     [java] 22:34:10.913 WARNING: fmj.addCaptureDevices()
com.lti.civil.CaptureException: unknown or unsupported format: 825636179
     [java] com.lti.civil.CaptureException: unknown or unsupported format:
825636179
     [java] at
com.lti.civil.impl.jni.NativeCaptureSystem.openCaptureDeviceStream(Native
Method)
     [java] at
net.sf.fmj.media.cdp.civil.CaptureDevicePlugger.getFormats(CaptureDevicePlugger.java:87)
     [java] at
net.sf.fmj.media.cdp.civil.CaptureDevicePlugger.addCaptureDevices(CaptureDevicePlugger.java:58)
     [java] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native
Method)
     [java] at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
     [java] at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
     [java] at java.lang.reflect.Method.invoke(Method.java:623)
     [java] at
net.java.sip.communicator.impl.media.device.FMJCivilVideoAuto.<init>(FMJCivilVideoAuto.java:33)
     [java] at
net.java.sip.communicator.impl.media.device.JmfDeviceDetector.detectCaptureDevices(JmfDeviceDetector.java:234)
     [java] at
net.java.sip.communicator.impl.media.device.JmfDeviceDetector.initialize(JmfDeviceDetector.java:119)
     [java] at
net.java.sip.communicator.impl.media.device.JmfDeviceDetector.setupJMF(JmfDeviceDetector.java:364)
     [java] at
net.java.sip.communicator.impl.media.device.JmfDeviceDetector.detectAndConfigureCaptureDevices(JmfDeviceDetector.java:436)
     [java] at
net.java.sip.communicator.impl.media.device.DeviceConfiguration.initialize(DeviceConfiguration.java:88)
     [java] at
net.java.sip.communicator.impl.media.MediaServiceImpl$DeviceConfigurationThread.run(MediaServiceImpl.java:407)
     [java] opened v4l2 device
     [java] Found Camera card with spca561 v4l2 driver
     [java] discover_inputs()
     [java] Found sources: 1
     [java] 0 - spca561 (2)
     [java] unknown or unsupported format: 825636179

Then, i tried to do this,
export LD_PRELOAD=/usr/local/lib/libv4l/v4l2convert.so

now i tried,
1) ekiga - it worked fine with v4l2 plugin.
(Edit->Preferences->VideoDevices)
2) skype - it worked fine
3) Sip-communicator , then also same warning. no result.

How to fix this.

Regards,
HarishKumar.V

v4linfo-output.txt (2.94 KB)

···

On Thu, Mar 19, 2009 at 2:43 PM, Damian Minkov <damencho@damencho.com>wrote:

Hi,

yes lti-civil is open. What you can do is to check it out from
http://lti-civil.org/.
There is some code which is not used anymore its for v4l. There is some
commented lines in the ant file and in the targets compiling the native
code.
And you can simply make tests with compiling the native part and running
the lt-civil test programs.
They are in lti-civil/sh/linux/ - "capturecontrol.sh".

damencho

Harishkumar V wrote:

Damencho,

The module supports v4l1.
I cross-checked with gstreamer-properties. v4l1 test passes but v4l2 test
fails.

my webcam is logitech QuickCam Express.

vendor id is 0x046d
product id is 0x092f.

The v4l2 driver is not available it seems. i have only gspcav1 version.

Is there any alternative. Can i make sip-communicator to work with v4l1 by
opening lti-civil.

Is that source is open. Any suggestions how to do will be helpful.

Regards,
HarishKumar.V

On Wed, Mar 18, 2009 at 4:11 PM, Damian Minkov <damencho@damencho.com<mailto: >> damencho@damencho.com>> wrote:

   Hi,

   as I can see your webcam is using v4l. For video capture we are
   using lti-civil which supports v4l2.
   Maybe you can check which module you are using for the webcam and
   search is there another one which suports v4l2.

   damencho

   Harishkumar V wrote:

       Damencho,

       This is my output of v4l-info

       #v4l-info

       ### video4linux device info [/dev/video0] ###
       general info
          VIDIOCGCAP
              name : "Logitech QuickCam EC"
              type : 0x1 [CAPTURE]
              channels : 1
              audios : 0
              maxwidth : 352
              maxheight : 288
              minwidth : 160
              minheight : 120

       channels
          VIDIOCGCHAN(0)
              channel : 0
              name : "SPCA561"
              tuners : 0
              flags : 0x0 []
              type : CAMERA
              norm : 0

       tuner
       ioctl VIDIOCGTUNER: Invalid argument

       audio
       ioctl VIDIOCGAUDIO: Invalid argument

       picture
          VIDIOCGPICT
              brightness : 16384
              hue : 0
              colour : 0
              contrast : 8192
              whiteness : 0
              depth : 24
              palette : RGB24

       buffer
          VIDIOCGFBUF
              base : (nil)
              height : 0
              width : 0
              depth : 0
              bytesperline : 0

       window
          VIDIOCGWIN
              x : 0
              y : 0
              width : 160
              height : 120
              chromakey : 0
              flags : 0

       Regards,
       HarishKumar.V

       On Tue, Mar 17, 2009 at 6:15 PM, Damian Minkov >> <damencho@damencho.com <mailto:damencho@damencho.com> >> <mailto:damencho@damencho.com <mailto:damencho@damencho.com>>> >> >> wrote:

          Hi,

          I haven't seen such an error, strange. Could you send the
       output
          of the command $v4l-info.

          damencho

          Harishkumar V wrote:

              Hi,

              I have installed sip communicator on my fedora machine.
              duirng testing voice works, but video fails.

              my webcam is logitech QuickCam Express.

              I individually tested webcam, it is working.
              Also, i tested it with skype and linphone, both are
       working fine.

              When i try to run sip-communicator, i get following
       errors and
              unable to see the video preview.

              run:
                  [java]
                  [java] Welcome to Felix.
                  [java] =================
                  [java]
                  [java] fg2_open failed
                  [java] 22:54:08.506 WARNING: fmj.addCaptureDevices()
              com.lti.civil.CaptureException: VIDIOC_G_FMT failed: 22
                  [java] com.lti.civil.CaptureException: VIDIOC_G_FMT
       failed: 22
                  [java] at

com.lti.civil.impl.jni.NativeCaptureSystem.openCaptureDeviceStream(Native
              Method)
                  [java] at

net.sf.fmj.media.cdp.civil.CaptureDevicePlugger.getFormats(CaptureDevicePlugger.java:87)
                  [java] at

net.sf.fmj.media.cdp.civil.CaptureDevicePlugger.addCaptureDevices(CaptureDevicePlugger.java:58)
                  [java] at
              sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                  [java] at

sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
                  [java] at

sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
                  [java] at
       java.lang.reflect.Method.invoke(Method.java:597)
                  [java] at

net.java.sip.communicator.impl.media.device.FMJCivilVideoAuto.<init>(FMJCivilVideoAuto.java:33)

              Regards,
              HarishKumar.V

---------------------------------------------------------------------
          To unsubscribe, e-mail:
          dev-unsubscribe@sip-communicator.dev.java.net
       <mailto:dev-unsubscribe@sip-communicator.dev.java.net>
          <mailto:dev-unsubscribe@sip-communicator.dev.java.net
       <mailto:dev-unsubscribe@sip-communicator.dev.java.net>>

          For additional commands, e-mail:
          dev-help@sip-communicator.dev.java.net
       <mailto:dev-help@sip-communicator.dev.java.net>
          <mailto:dev-help@sip-communicator.dev.java.net
       <mailto:dev-help@sip-communicator.dev.java.net>>

   ---------------------------------------------------------------------
   To unsubscribe, e-mail:
   dev-unsubscribe@sip-communicator.dev.java.net
   <mailto:dev-unsubscribe@sip-communicator.dev.java.net>
   For additional commands, e-mail:
   dev-help@sip-communicator.dev.java.net
   <mailto:dev-help@sip-communicator.dev.java.net>

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#9

Hi,

It seems another format which is not supported in lti-civil.
I will look at this issue in the weekend and will contact you to test it together.
Recently we were adding a lot of other formats to lti-civil. Now we can test with you and add another one :slight_smile:
Can you just tell me is you system i386 or amd64 (what binary to send you for testing).

damencho

Harishkumar V wrote:

···

Damencho,

Thanks, but eventually got gspca v4l2 driver with the linux2.6.27 onwards.

after compiling and installing the driver. the webcam was claimed by gspca_spca561 driver.

using v4l-info, i am able to make sure it has both v4l2 and v4l1 interface. i also attached the v4l-info-output.

Then, i tried sip-communicator, it failed. but with different warning.

Buildfile: build.xml

deploy-os-specific-bundles:

run:
     [java]
     [java] Welcome to Felix.
     [java] =================
     [java]
     [java] 22:34:10.913 WARNING: fmj.addCaptureDevices() com.lti.civil.CaptureException: unknown or unsupported format: 825636179
     [java] com.lti.civil.CaptureException: unknown or unsupported format: 825636179
     [java] at com.lti.civil.impl.jni.NativeCaptureSystem.openCaptureDeviceStream(Native Method)
     [java] at net.sf.fmj.media.cdp.civil.CaptureDevicePlugger.getFormats(CaptureDevicePlugger.java:87)
     [java] at net.sf.fmj.media.cdp.civil.CaptureDevicePlugger.addCaptureDevices(CaptureDevicePlugger.java:58)
     [java] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
     [java] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
     [java] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
     [java] at java.lang.reflect.Method.invoke(Method.java:623)
     [java] at net.java.sip.communicator.impl.media.device.FMJCivilVideoAuto.<init>(FMJCivilVideoAuto.java:33)
     [java] at net.java.sip.communicator.impl.media.device.JmfDeviceDetector.detectCaptureDevices(JmfDeviceDetector.java:234)
     [java] at net.java.sip.communicator.impl.media.device.JmfDeviceDetector.initialize(JmfDeviceDetector.java:119)
     [java] at net.java.sip.communicator.impl.media.device.JmfDeviceDetector.setupJMF(JmfDeviceDetector.java:364)
     [java] at net.java.sip.communicator.impl.media.device.JmfDeviceDetector.detectAndConfigureCaptureDevices(JmfDeviceDetector.java:436)
     [java] at net.java.sip.communicator.impl.media.device.DeviceConfiguration.initialize(DeviceConfiguration.java:88)
     [java] at net.java.sip.communicator.impl.media.MediaServiceImpl$DeviceConfigurationThread.run(MediaServiceImpl.java:407)
     [java] opened v4l2 device
     [java] Found Camera card with spca561 v4l2 driver
     [java] discover_inputs()
     [java] Found sources: 1
     [java] 0 - spca561 (2)
     [java] unknown or unsupported format: 825636179

Then, i tried to do this,
export LD_PRELOAD=/usr/local/lib/libv4l/v4l2convert.so

now i tried,
1) ekiga - it worked fine with v4l2 plugin. (Edit->Preferences->VideoDevices)
2) skype - it worked fine
3) Sip-communicator , then also same warning. no result.

How to fix this.

Regards,
HarishKumar.V

On Thu, Mar 19, 2009 at 2:43 PM, Damian Minkov <damencho@damencho.com > <mailto:damencho@damencho.com>> wrote:

    Hi,

    yes lti-civil is open. What you can do is to check it out from
    http://lti-civil.org/.
    There is some code which is not used anymore its for v4l. There is
    some commented lines in the ant file and in the targets compiling
    the native code.
    And you can simply make tests with compiling the native part and
    running the lt-civil test programs.
    They are in lti-civil/sh/linux/ - "capturecontrol.sh".

    damencho

    Harishkumar V wrote:

        Damencho,

        The module supports v4l1.
        I cross-checked with gstreamer-properties. v4l1 test passes
        but v4l2 test fails.

        my webcam is logitech QuickCam Express.

        vendor id is 0x046d
        product id is 0x092f.

        The v4l2 driver is not available it seems. i have only gspcav1
        version.

        Is there any alternative. Can i make sip-communicator to work
        with v4l1 by opening lti-civil.

        Is that source is open. Any suggestions how to do will be helpful.

        Regards,
        HarishKumar.V

        On Wed, Mar 18, 2009 at 4:11 PM, Damian Minkov > <damencho@damencho.com <mailto:damencho@damencho.com> > <mailto:damencho@damencho.com <mailto:damencho@damencho.com>>> > wrote:

           Hi,

           as I can see your webcam is using v4l. For video capture we are
           using lti-civil which supports v4l2.
           Maybe you can check which module you are using for the
         webcam and
           search is there another one which suports v4l2.

           damencho

           Harishkumar V wrote:

               Damencho,

               This is my output of v4l-info

               #v4l-info

               ### video4linux device info [/dev/video0] ###
               general info
                  VIDIOCGCAP
                      name : "Logitech QuickCam EC"
                      type : 0x1 [CAPTURE]
                      channels : 1
                      audios : 0
                      maxwidth : 352
                      maxheight : 288
                      minwidth : 160
                      minheight : 120

               channels
                  VIDIOCGCHAN(0)
                      channel : 0
                      name : "SPCA561"
                      tuners : 0
                      flags : 0x0 []
                      type : CAMERA
                      norm : 0

               tuner
               ioctl VIDIOCGTUNER: Invalid argument

               audio
               ioctl VIDIOCGAUDIO: Invalid argument

               picture
                  VIDIOCGPICT
                      brightness : 16384
                      hue : 0
                      colour : 0
                      contrast : 8192
                      whiteness : 0
                      depth : 24
                      palette : RGB24

               buffer
                  VIDIOCGFBUF
                      base : (nil)
                      height : 0
                      width : 0
                      depth : 0
                      bytesperline : 0

               window
                  VIDIOCGWIN
                      x : 0
                      y : 0
                      width : 160
                      height : 120
                      chromakey : 0
                      flags : 0

               Regards,
               HarishKumar.V

               On Tue, Mar 17, 2009 at 6:15 PM, Damian Minkov
               <damencho@damencho.com <mailto:damencho@damencho.com>
        <mailto:damencho@damencho.com <mailto:damencho@damencho.com>>
               <mailto:damencho@damencho.com
        <mailto:damencho@damencho.com> <mailto:damencho@damencho.com
        <mailto:damencho@damencho.com>>>>

               wrote:

                  Hi,

                  I haven't seen such an error, strange. Could you
        send the
               output
                  of the command $v4l-info.

                  damencho

                  Harishkumar V wrote:

                      Hi,

                      I have installed sip communicator on my fedora
        machine.
                      duirng testing voice works, but video fails.

                      my webcam is logitech QuickCam Express.

                      I individually tested webcam, it is working.
                      Also, i tested it with skype and linphone, both are
               working fine.

                      When i try to run sip-communicator, i get following
               errors and
                      unable to see the video preview.

                      run:
                          [java]
                          [java] Welcome to Felix.
                          [java] =================
                          [java]
                          [java] fg2_open failed
                          [java] 22:54:08.506 WARNING:
        fmj.addCaptureDevices()
                      com.lti.civil.CaptureException: VIDIOC_G_FMT
        failed: 22
                          [java] com.lti.civil.CaptureException:
        VIDIOC_G_FMT
               failed: 22
                          [java] at
                                   com.lti.civil.impl.jni.NativeCaptureSystem.openCaptureDeviceStream(Native
                      Method)
                          [java] at
                                   net.sf.fmj.media.cdp.civil.CaptureDevicePlugger.getFormats(CaptureDevicePlugger.java:87)
                          [java] at
                                   net.sf.fmj.media.cdp.civil.CaptureDevicePlugger.addCaptureDevices(CaptureDevicePlugger.java:58)
                          [java] at
                             sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                          [java] at
                                   sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
                          [java] at
                                   sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
                          [java] at
               java.lang.reflect.Method.invoke(Method.java:597)
                          [java] at
                                   net.java.sip.communicator.impl.media.device.FMJCivilVideoAuto.<init>(FMJCivilVideoAuto.java:33)

                      Regards,
                      HarishKumar.V

                               ---------------------------------------------------------------------
                  To unsubscribe, e-mail:
                  dev-unsubscribe@sip-communicator.dev.java.net
        <mailto:dev-unsubscribe@sip-communicator.dev.java.net>
               <mailto:dev-unsubscribe@sip-communicator.dev.java.net
        <mailto:dev-unsubscribe@sip-communicator.dev.java.net>>
                         <mailto:dev-unsubscribe@sip-communicator.dev.java.net
        <mailto:dev-unsubscribe@sip-communicator.dev.java.net>
               <mailto:dev-unsubscribe@sip-communicator.dev.java.net
        <mailto:dev-unsubscribe@sip-communicator.dev.java.net>>>

                  For additional commands, e-mail:
                  dev-help@sip-communicator.dev.java.net
        <mailto:dev-help@sip-communicator.dev.java.net>
               <mailto:dev-help@sip-communicator.dev.java.net
        <mailto:dev-help@sip-communicator.dev.java.net>>
                  <mailto:dev-help@sip-communicator.dev.java.net
        <mailto:dev-help@sip-communicator.dev.java.net>
               <mailto:dev-help@sip-communicator.dev.java.net
        <mailto:dev-help@sip-communicator.dev.java.net>>>

                  ---------------------------------------------------------------------
           To unsubscribe, e-mail:
           dev-unsubscribe@sip-communicator.dev.java.net
        <mailto:dev-unsubscribe@sip-communicator.dev.java.net>
           <mailto:dev-unsubscribe@sip-communicator.dev.java.net
        <mailto:dev-unsubscribe@sip-communicator.dev.java.net>>
           For additional commands, e-mail:
           dev-help@sip-communicator.dev.java.net
        <mailto:dev-help@sip-communicator.dev.java.net>
           <mailto:dev-help@sip-communicator.dev.java.net
        <mailto:dev-help@sip-communicator.dev.java.net>>

    ---------------------------------------------------------------------
    To unsubscribe, e-mail:
    dev-unsubscribe@sip-communicator.dev.java.net
    <mailto:dev-unsubscribe@sip-communicator.dev.java.net>
    For additional commands, e-mail:
    dev-help@sip-communicator.dev.java.net
    <mailto:dev-help@sip-communicator.dev.java.net>

------------------------------------------------------------------------

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#10

Damencho,

Ah ..
My Pc is i386 architecture running Fedora Core 8 OS.

I am pleased to do that. I also in a way contribute SIP-Communicator
project.

Regards,
HarishKumar.V

···

On Fri, Mar 20, 2009 at 6:35 PM, Damian Minkov <damencho@damencho.com>wrote:

Hi,

It seems another format which is not supported in lti-civil.
I will look at this issue in the weekend and will contact you to test it
together.
Recently we were adding a lot of other formats to lti-civil. Now we can
test with you and add another one :slight_smile:
Can you just tell me is you system i386 or amd64 (what binary to send you
for testing).

damencho

Harishkumar V wrote:

Damencho,

Thanks, but eventually got gspca v4l2 driver with the linux2.6.27 onwards.

after compiling and installing the driver. the webcam was claimed by
gspca_spca561 driver.

using v4l-info, i am able to make sure it has both v4l2 and v4l1
interface. i also attached the v4l-info-output.

Then, i tried sip-communicator, it failed. but with different warning.

Buildfile: build.xml

deploy-os-specific-bundles:

run:
    [java]
    [java] Welcome to Felix.
    [java] =================
    [java]
    [java] 22:34:10.913 WARNING: fmj.addCaptureDevices()
com.lti.civil.CaptureException: unknown or unsupported format: 825636179
    [java] com.lti.civil.CaptureException: unknown or unsupported format:
825636179
    [java] at
com.lti.civil.impl.jni.NativeCaptureSystem.openCaptureDeviceStream(Native
Method)
    [java] at
net.sf.fmj.media.cdp.civil.CaptureDevicePlugger.getFormats(CaptureDevicePlugger.java:87)
    [java] at
net.sf.fmj.media.cdp.civil.CaptureDevicePlugger.addCaptureDevices(CaptureDevicePlugger.java:58)
    [java] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native
Method)
    [java] at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
    [java] at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    [java] at java.lang.reflect.Method.invoke(Method.java:623)
    [java] at
net.java.sip.communicator.impl.media.device.FMJCivilVideoAuto.<init>(FMJCivilVideoAuto.java:33)
    [java] at
net.java.sip.communicator.impl.media.device.JmfDeviceDetector.detectCaptureDevices(JmfDeviceDetector.java:234)
    [java] at
net.java.sip.communicator.impl.media.device.JmfDeviceDetector.initialize(JmfDeviceDetector.java:119)
    [java] at
net.java.sip.communicator.impl.media.device.JmfDeviceDetector.setupJMF(JmfDeviceDetector.java:364)
    [java] at
net.java.sip.communicator.impl.media.device.JmfDeviceDetector.detectAndConfigureCaptureDevices(JmfDeviceDetector.java:436)
    [java] at
net.java.sip.communicator.impl.media.device.DeviceConfiguration.initialize(DeviceConfiguration.java:88)
    [java] at
net.java.sip.communicator.impl.media.MediaServiceImpl$DeviceConfigurationThread.run(MediaServiceImpl.java:407)
    [java] opened v4l2 device
    [java] Found Camera card with spca561 v4l2 driver
    [java] discover_inputs()
    [java] Found sources: 1
    [java] 0 - spca561 (2)
    [java] unknown or unsupported format: 825636179

Then, i tried to do this,
export LD_PRELOAD=/usr/local/lib/libv4l/v4l2convert.so

now i tried,
1) ekiga - it worked fine with v4l2 plugin.
(Edit->Preferences->VideoDevices)
2) skype - it worked fine
3) Sip-communicator , then also same warning. no result.

How to fix this.

Regards,
HarishKumar.V

On Thu, Mar 19, 2009 at 2:43 PM, Damian Minkov <damencho@damencho.com<mailto: >> damencho@damencho.com>> wrote:

   Hi,

   yes lti-civil is open. What you can do is to check it out from
   http://lti-civil.org/.
   There is some code which is not used anymore its for v4l. There is
   some commented lines in the ant file and in the targets compiling
   the native code.
   And you can simply make tests with compiling the native part and
   running the lt-civil test programs.
   They are in lti-civil/sh/linux/ - "capturecontrol.sh".

   damencho

   Harishkumar V wrote:

       Damencho,

       The module supports v4l1.
       I cross-checked with gstreamer-properties. v4l1 test passes
       but v4l2 test fails.

       my webcam is logitech QuickCam Express.

       vendor id is 0x046d
       product id is 0x092f.

       The v4l2 driver is not available it seems. i have only gspcav1
       version.

       Is there any alternative. Can i make sip-communicator to work
       with v4l1 by opening lti-civil.

       Is that source is open. Any suggestions how to do will be helpful.

       Regards,
       HarishKumar.V

       On Wed, Mar 18, 2009 at 4:11 PM, Damian Minkov >> <damencho@damencho.com <mailto:damencho@damencho.com> >> <mailto:damencho@damencho.com <mailto:damencho@damencho.com>>> >> wrote:

          Hi,

          as I can see your webcam is using v4l. For video capture we are
          using lti-civil which supports v4l2.
          Maybe you can check which module you are using for the
        webcam and
          search is there another one which suports v4l2.

          damencho

          Harishkumar V wrote:

              Damencho,

              This is my output of v4l-info

              #v4l-info

              ### video4linux device info [/dev/video0] ###
              general info
                 VIDIOCGCAP
                     name : "Logitech QuickCam EC"
                     type : 0x1 [CAPTURE]
                     channels : 1
                     audios : 0
                     maxwidth : 352
                     maxheight : 288
                     minwidth : 160
                     minheight : 120

              channels
                 VIDIOCGCHAN(0)
                     channel : 0
                     name : "SPCA561"
                     tuners : 0
                     flags : 0x0 []
                     type : CAMERA
                     norm : 0

              tuner
              ioctl VIDIOCGTUNER: Invalid argument

              audio
              ioctl VIDIOCGAUDIO: Invalid argument

              picture
                 VIDIOCGPICT
                     brightness : 16384
                     hue : 0
                     colour : 0
                     contrast : 8192
                     whiteness : 0
                     depth : 24
                     palette : RGB24

              buffer
                 VIDIOCGFBUF
                     base : (nil)
                     height : 0
                     width : 0
                     depth : 0
                     bytesperline : 0

              window
                 VIDIOCGWIN
                     x : 0
                     y : 0
                     width : 160
                     height : 120
                     chromakey : 0
                     flags : 0

              Regards,
              HarishKumar.V

              On Tue, Mar 17, 2009 at 6:15 PM, Damian Minkov
              <damencho@damencho.com <mailto:damencho@damencho.com>
       <mailto:damencho@damencho.com <mailto:damencho@damencho.com>>
              <mailto:damencho@damencho.com
       <mailto:damencho@damencho.com> <mailto:damencho@damencho.com
       <mailto:damencho@damencho.com>>>>

              wrote:

                 Hi,

                 I haven't seen such an error, strange. Could you
       send the
              output
                 of the command $v4l-info.

                 damencho

                 Harishkumar V wrote:

                     Hi,

                     I have installed sip communicator on my fedora
       machine.
                     duirng testing voice works, but video fails.

                     my webcam is logitech QuickCam Express.

                     I individually tested webcam, it is working.
                     Also, i tested it with skype and linphone, both are
              working fine.

                     When i try to run sip-communicator, i get following
              errors and
                     unable to see the video preview.

                     run:
                         [java]
                         [java] Welcome to Felix.
                         [java] =================
                         [java]
                         [java] fg2_open failed
                         [java] 22:54:08.506 WARNING:
       fmj.addCaptureDevices()
                     com.lti.civil.CaptureException: VIDIOC_G_FMT
       failed: 22
                         [java] com.lti.civil.CaptureException:
       VIDIOC_G_FMT
              failed: 22
                         [java] at

com.lti.civil.impl.jni.NativeCaptureSystem.openCaptureDeviceStream(Native
                     Method)
                         [java] at

net.sf.fmj.media.cdp.civil.CaptureDevicePlugger.getFormats(CaptureDevicePlugger.java:87)
                         [java] at

net.sf.fmj.media.cdp.civil.CaptureDevicePlugger.addCaptureDevices(CaptureDevicePlugger.java:58)
                         [java] at

sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                         [java] at

sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
                         [java] at

sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
                         [java] at
              java.lang.reflect.Method.invoke(Method.java:597)
                         [java] at

net.java.sip.communicator.impl.media.device.FMJCivilVideoAuto.<init>(FMJCivilVideoAuto.java:33)

                     Regards,
                     HarishKumar.V

---------------------------------------------------------------------
                 To unsubscribe, e-mail:
                 dev-unsubscribe@sip-communicator.dev.java.net
       <mailto:dev-unsubscribe@sip-communicator.dev.java.net>
              <mailto:dev-unsubscribe@sip-communicator.dev.java.net
       <mailto:dev-unsubscribe@sip-communicator.dev.java.net>>
                       <mailto:
dev-unsubscribe@sip-communicator.dev.java.net
       <mailto:dev-unsubscribe@sip-communicator.dev.java.net>
              <mailto:dev-unsubscribe@sip-communicator.dev.java.net
       <mailto:dev-unsubscribe@sip-communicator.dev.java.net>>>

                 For additional commands, e-mail:
                 dev-help@sip-communicator.dev.java.net
       <mailto:dev-help@sip-communicator.dev.java.net>
              <mailto:dev-help@sip-communicator.dev.java.net
       <mailto:dev-help@sip-communicator.dev.java.net>>
                 <mailto:dev-help@sip-communicator.dev.java.net
       <mailto:dev-help@sip-communicator.dev.java.net>
              <mailto:dev-help@sip-communicator.dev.java.net
       <mailto:dev-help@sip-communicator.dev.java.net>>>

---------------------------------------------------------------------
          To unsubscribe, e-mail:
          dev-unsubscribe@sip-communicator.dev.java.net
       <mailto:dev-unsubscribe@sip-communicator.dev.java.net>
          <mailto:dev-unsubscribe@sip-communicator.dev.java.net
       <mailto:dev-unsubscribe@sip-communicator.dev.java.net>>
          For additional commands, e-mail:
          dev-help@sip-communicator.dev.java.net
       <mailto:dev-help@sip-communicator.dev.java.net>
          <mailto:dev-help@sip-communicator.dev.java.net
       <mailto:dev-help@sip-communicator.dev.java.net>>

   ---------------------------------------------------------------------
   To unsubscribe, e-mail:
   dev-unsubscribe@sip-communicator.dev.java.net
   <mailto:dev-unsubscribe@sip-communicator.dev.java.net>
   For additional commands, e-mail:
   dev-help@sip-communicator.dev.java.net
   <mailto:dev-help@sip-communicator.dev.java.net>

------------------------------------------------------------------------

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net