[sip-comm-dev] Username problems


#1

Hello list,

I'm testing SIP communicator for use with the Faunhofer Open IMS, and ran into username related problems. When I enter the user identity into the configuration dialog, bob@domain.tld, it gets shortened to bob, and the realm set to domain.tld. The registration then fails, because the username field in the Authentication: header in the authenticated REGISTER message is set to bob instead of bob@domain.tld. I tested this by setting the username to username+"@"+realm in SipSecurityManager.getAuthorizationHeader(), and the REGISTER then worked.

Hmmm ... I can live with changing the source to make it work with my installation, but I'm not sure how to resolve this generally. Maybe add another field in the server settings, automatically set to username, that can be changed to username@realm.

Regards,
Wolfram

···

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#2

Hello Wolfram,

(Sorry for the late reply)

I just answered a mail in a thread called "Some bugs" which is related
to this issue. I'd be curious to also have your opinion on it.

Cheers
Emil

Wolfram Schroeder написа:

···

Hello list,

I'm testing SIP communicator for use with the Faunhofer Open IMS, and
ran into username related problems. When I enter the user identity into
the configuration dialog, bob@domain.tld, it gets shortened to bob, and
the realm set to domain.tld. The registration then fails, because the
username field in the Authentication: header in the authenticated
REGISTER message is set to bob instead of bob@domain.tld. I tested this
by setting the username to username+"@"+realm in
SipSecurityManager.getAuthorizationHeader(), and the REGISTER then worked.

Hmmm ... I can live with changing the source to make it work with my
installation, but I'm not sure how to resolve this generally. Maybe add
another field in the server settings, automatically set to username,
that can be changed to username@realm.

Regards,
Wolfram

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#3

Jeroen,

Right, however I still don't see any better way for a generic UA to
handle this, other than letting the user edit the name field in an
authorization window. Would there be any other options?

Cheers
Emil

Jeroen van Bemmel написа:

···

Emil,

In the IMS world it is actually quite common to have a username (PRID)
different from the SIP AoR (PUID)

Also, the allowed characters in a username are different than those the
SIP AoR; the username may contain multiple '@' for example (it is an
opaque string)

Regards,
Jeroen

Emil Ivov wrote:

Hello Wolfram,

(Sorry for the late reply)

I just answered a mail in a thread called "Some bugs" which is related
to this issue. I'd be curious to also have your opinion on it.

Cheers
Emil

Wolfram Schroeder написа:

Hello list,

I'm testing SIP communicator for use with the Faunhofer Open IMS, and
ran into username related problems. When I enter the user identity into
the configuration dialog, bob-ps1yJmh03mYq8ddH4TG6mw@public.gmane.org, it gets shortened to bob, and
the realm set to domain.tld. The registration then fails, because the
username field in the Authentication: header in the authenticated
REGISTER message is set to bob instead of bob-ps1yJmh03maabSvGr5RuNQ@public.gmane.org I tested this
by setting the username to username+"@"+realm in
SipSecurityManager.getAuthorizationHeader(), and the REGISTER then worked.

Hmmm ... I can live with changing the source to make it work with my
installation, but I'm not sure how to resolve this generally. Maybe add
another field in the server settings, automatically set to username,
that can be changed to username@realm.

Regards,
Wolfram

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe-e4b6q1WrAvqNT/shq6UTL0xKC0JgDi2LF4cvauC391I@public.gmane.org
For additional commands, e-mail: dev-help-e4b6q1WrAvqNT/shq6UTL0xKC0JgDi2LF4cvauC391I@public.gmane.org

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net