[sip-comm-dev] upgrading to Ubuntu 9.04 breaks java video capture


#1

Hi,

this is to inform the SC devs of my bug report at:
https://bugs.launchpad.net/ubuntu/+bug/365979

here is the content of the bug report:

TEST: using SIP-COMMUNICATOR build 1864
with kernel 2.6.27-11-generic, as SIP-COMMUNICATOR loads into memory, it searches for a video device which causes the Webcam LED to flash quickly. Later under options, clicking on the media tab will activate the Webcam and show local video in a window.

Upgrading to 9.04 results in kernel 2.6.28-11-generic breaking the video capture. The Webcam LED does not flash on loading, nor does the Webcam work after loading the program.

For both kernels, I have extracted all lines with the word civil from the log files.
SIP-COMMUNICATOR is written in java and the video device is found at civil:/dev/video0:0.

···

===================
log with kernel 2.6.28-11-generic #42 Ubuntu 9.04 updated+upgraded to 24 March 2009
this kernel breaks java video capture, kernel 2.6.27-11-generic works ok

FINE: fmj.addCaptureDevices() CaptureDevicePlugger: Added civil:/dev/video0
10:19:40.816 FINEST: impl.media.device.JmfDeviceDetector.setupJMF().368 [exit] setupJMF
10:19:40.817 INFO: impl.media.device.DeviceConfiguration.extractConfiguredCaptureDevices().106 Scanning for configured Audio Devices.
10:19:40.819 FINE: impl.media.device.DeviceConfiguration.extractConfiguredCaptureDevices().118 Found 1 capture devices: [Ljavax.media.CaptureDeviceInfo;@16f3619
10:19:40.820 INFO: impl.media.device.DeviceConfiguration.extractConfiguredCaptureDevices().137 Found JavaSound audio capture as an audio capture device.
10:19:40.820 INFO: impl.media.device.DeviceConfiguration.extractConfiguredCaptureDevices().145 Scanning for configured Video Devices.
10:19:40.822 INFO: impl.media.device.DeviceConfiguration.extractConfiguredVideoCaptureDevice().186 Found civil:/dev/video0:0 as an RGB Video Device.

10:19:41.481 INFO: impl.media.MediaControl.createDataSource().582 Creating datasource for:civil:/dev/video0
10:19:41.497 FINE: fmj.connect() civil: connect
10:19:41.500 FINE: fmj.connect() Opening /dev/video0

10:19:42.154 FINE: fmj.connect() civil: connect

10:19:43.261 FINE: fmj.start() civil: start
10:19:43.265 FINE: lti-civil.run() NativeCaptureStreamThread running
10:19:43.272 FINE: fmj.stop() civil: stop
10:19:43.282 FINER: impl.configuration.ConfigurationServiceImpl.setProperty().153 net.java.sip.communicator.impl.protocol.sip.acc1240265069692.PROXY_PORT( oldValue=5060, newValue=5060.
10:19:43.284 SEVERE: lti-civil.run() com.lti.civil.CaptureException: fg2_startCapture failed: -1
com.lti.civil.CaptureException: fg2_startCapture failed: -1
    at com.lti.civil.impl.jni.NativeCaptureStream.threadMain(Native Method)
    at com.lti.civil.impl.jni.NativeCaptureStream$NativeCaptureStreamThread.run(NativeCaptureStream.java:94)
10:19:43.285 FINE: lti-civil.run() NativeCaptureStreamThread exiting

10:20:04.094 FINE: fmj.connect() civil: connect
10:20:04.097 FINE: fmj.connect() Opening /dev/video0
10:20:04.212 FINE: fmj.start() civil: start
10:20:04.234 FINE: lti-civil.run() NativeCaptureStreamThread running
10:20:04.236 SEVERE: lti-civil.run() com.lti.civil.CaptureException: fg2_startCapture failed: -1
com.lti.civil.CaptureException: fg2_startCapture failed: -1
    at com.lti.civil.impl.jni.NativeCaptureStream.threadMain(Native Method)
    at com.lti.civil.impl.jni.NativeCaptureStream$NativeCaptureStreamThread.run(NativeCaptureStream.java:94)
10:20:04.237 FINE: lti-civil.run() NativeCaptureStreamThread exiting
10:20:04.239 FINE: fmj.stop() civil: stop
10:20:04.456 FINE: fmj.stop() civil: stop
10:20:04.458 FINE: fmj.start() civil: start
10:20:11.627 FINER: impl.configuration.ConfigurationServiceImpl.setProperty().153 net.java.sip.communicator.impl.gui.main.configforms.ConfigurationFrame.width( oldValue=653, newValue=653.
10:20:11.646 FINER: impl.configuration.ConfigurationServiceImpl.setProperty().153 net.java.sip.communicator.impl.gui.main.configforms.ConfigurationFrame.height( oldValue=550, newValue=550.
10:20:11.662 FINER: impl.configuration.ConfigurationServiceImpl.setProperty().153 net.java.sip.communicator.impl.gui.main.configforms.ConfigurationFrame.x( oldValue=367, newValue=367.
10:20:11.678 FINER: impl.configuration.ConfigurationServiceImpl.setProperty().153 net.java.sip.communicator.impl.gui.main.configforms.ConfigurationFrame.y( oldValue=25, newValue=25.
10:20:11.695 FINE: fmj.stop() civil: stop
10:20:11.699 FINE: fmj.stop() civil: stop
10:20:11.710 FINE: fmj.stop() civil: stop
10:20:11.712 FINE: fmj.disconnect() civil: disconnect
10:20:11.714 FINE: fmj.stop() civil: stop

10:20:20.329 FINE: fmj.stop() civil: stop

=====================================
log with 2.6.27-11-generic #42 Ubuntu 9.04 updated+upgraded to 24 March 2009

10:38:19.370 FINE: fmj.addCaptureDevices() CaptureDevicePlugger: Added civil:/dev/video0
10:38:19.377 INFO: impl.media.device.DeviceConfiguration.extractConfiguredVideoCaptureDevice().186 Found civil:/dev/video0:0 as an RGB Video Device.
10:38:19.375 INFO: impl.media.device.DeviceConfiguration.extractConfiguredCaptureDevices().145 Scanning for configured Video Devices.
10:38:19.377 INFO: impl.media.device.DeviceConfiguration.extractConfiguredVideoCaptureDevice().186 Found civil:/dev/video0:0 as an RGB Video Device.
10:38:19.630 INFO: impl.media.MediaControl.createDataSource().582 Creating datasource for:civil:/dev/video0
10:38:19.645 FINE: fmj.connect() civil: connect
10:38:19.649 FINE: fmj.connect() Opening /dev/video0
10:38:20.092 FINE: fmj.connect() civil: connect
10:38:20.783 FINE: fmj.start() civil: start
10:38:20.800 FINE: impl.protocol.sip.OperationSetPresenceSipImpl.<init>().272 presence initialized with :true, true, 30, 3600 for null
10:38:20.818 FINE: lti-civil.run() NativeCaptureStreamThread running
10:38:20.842 FINE: fmj.stop() civil: stop
10:38:42.506 FINE: fmj.connect() civil: connect
10:38:42.508 FINE: fmj.connect() Opening /dev/video0
10:38:42.533 FINE: fmj.start() civil: start
10:38:42.536 FINE: lti-civil.run() NativeCaptureStreamThread running
10:38:42.537 FINE: fmj.stop() civil: stop
10:38:42.830 FINE: fmj.stop() civil: stop
10:38:42.832 FINE: fmj.start() civil: start
10:38:50.585 FINE: fmj.stop() civil: stop
10:38:50.610 FINE: fmj.stop() civil: stop
10:38:50.611 FINE: fmj.stop() civil: stop
10:38:50.613 FINE: fmj.disconnect() civil: disconnect
10:38:50.614 FINE: fmj.stop() civil: stop
10:38:50.728 FINE: lti-civil.run() NativeCaptureStreamThread exiting
10:38:59.435 FINE: fmj.stop() civil: stop

Regards, Earl

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#2

Hi Earl,

Thank you!

I just wanted to note though that they'll likely need more information
about your webcam because the MacBook with Apple iSight + Ubuntu 9.04
I'm running SIP Communicator on works for me like a charm.

Regards,
Lubo

···

On Fri, Apr 24, 2009 at 1:39 PM, Earl <Large.Files@gmx.net> wrote:

Hi,

this is to inform the SC devs of my bug report at:
https://bugs.launchpad.net/ubuntu/+bug/365979

here is the content of the bug report:

TEST: using SIP-COMMUNICATOR build 1864
with kernel 2.6.27-11-generic, as SIP-COMMUNICATOR loads into memory, it
searches for a video device which causes the Webcam LED to flash quickly.
Later under options, clicking on the media tab will activate the Webcam and
show local video in a window.

Upgrading to 9.04 results in kernel 2.6.28-11-generic breaking the video
capture. The Webcam LED does not flash on loading, nor does the Webcam work
after loading the program.

For both kernels, I have extracted all lines with the word civil from the
log files.
SIP-COMMUNICATOR is written in java and the video device is found at
civil:/dev/video0:0.

log with kernel 2.6.28-11-generic #42 Ubuntu 9.04 updated+upgraded to 24
March 2009
this kernel breaks java video capture, kernel 2.6.27-11-generic works ok

FINE: fmj.addCaptureDevices() CaptureDevicePlugger: Added civil:/dev/video0
10:19:40.816 FINEST: impl.media.device.JmfDeviceDetector.setupJMF().368
[exit] setupJMF
10:19:40.817 INFO:
impl.media.device.DeviceConfiguration.extractConfiguredCaptureDevices().106
Scanning for configured Audio Devices.
10:19:40.819 FINE:
impl.media.device.DeviceConfiguration.extractConfiguredCaptureDevices().118
Found 1 capture devices: [Ljavax.media.CaptureDeviceInfo;@16f3619
10:19:40.820 INFO:
impl.media.device.DeviceConfiguration.extractConfiguredCaptureDevices().137
Found JavaSound audio capture as an audio capture device.
10:19:40.820 INFO:
impl.media.device.DeviceConfiguration.extractConfiguredCaptureDevices().145
Scanning for configured Video Devices.
10:19:40.822 INFO:
impl.media.device.DeviceConfiguration.extractConfiguredVideoCaptureDevice().186
Found civil:/dev/video0:0 as an RGB Video Device.

10:19:41.481 INFO: impl.media.MediaControl.createDataSource().582 Creating
datasource for:civil:/dev/video0
10:19:41.497 FINE: fmj.connect() civil: connect
10:19:41.500 FINE: fmj.connect() Opening /dev/video0

10:19:42.154 FINE: fmj.connect() civil: connect

10:19:43.261 FINE: fmj.start() civil: start
10:19:43.265 FINE: lti-civil.run() NativeCaptureStreamThread running
10:19:43.272 FINE: fmj.stop() civil: stop
10:19:43.282 FINER:
impl.configuration.ConfigurationServiceImpl.setProperty().153
net.java.sip.communicator.impl.protocol.sip.acc1240265069692.PROXY_PORT(
oldValue=5060, newValue=5060.
10:19:43.284 SEVERE: lti-civil.run() com.lti.civil.CaptureException:
fg2_startCapture failed: -1
com.lti.civil.CaptureException: fg2_startCapture failed: -1
at com.lti.civil.impl.jni.NativeCaptureStream.threadMain(Native Method)
at
com.lti.civil.impl.jni.NativeCaptureStream$NativeCaptureStreamThread.run(NativeCaptureStream.java:94)
10:19:43.285 FINE: lti-civil.run() NativeCaptureStreamThread exiting

10:20:04.094 FINE: fmj.connect() civil: connect
10:20:04.097 FINE: fmj.connect() Opening /dev/video0
10:20:04.212 FINE: fmj.start() civil: start
10:20:04.234 FINE: lti-civil.run() NativeCaptureStreamThread running
10:20:04.236 SEVERE: lti-civil.run() com.lti.civil.CaptureException:
fg2_startCapture failed: -1
com.lti.civil.CaptureException: fg2_startCapture failed: -1
at com.lti.civil.impl.jni.NativeCaptureStream.threadMain(Native Method)
at
com.lti.civil.impl.jni.NativeCaptureStream$NativeCaptureStreamThread.run(NativeCaptureStream.java:94)
10:20:04.237 FINE: lti-civil.run() NativeCaptureStreamThread exiting
10:20:04.239 FINE: fmj.stop() civil: stop
10:20:04.456 FINE: fmj.stop() civil: stop
10:20:04.458 FINE: fmj.start() civil: start
10:20:11.627 FINER:
impl.configuration.ConfigurationServiceImpl.setProperty().153
net.java.sip.communicator.impl.gui.main.configforms.ConfigurationFrame.width(
oldValue=653, newValue=653.
10:20:11.646 FINER:
impl.configuration.ConfigurationServiceImpl.setProperty().153
net.java.sip.communicator.impl.gui.main.configforms.ConfigurationFrame.height(
oldValue=550, newValue=550.
10:20:11.662 FINER:
impl.configuration.ConfigurationServiceImpl.setProperty().153
net.java.sip.communicator.impl.gui.main.configforms.ConfigurationFrame.x(
oldValue=367, newValue=367.
10:20:11.678 FINER:
impl.configuration.ConfigurationServiceImpl.setProperty().153
net.java.sip.communicator.impl.gui.main.configforms.ConfigurationFrame.y(
oldValue=25, newValue=25.
10:20:11.695 FINE: fmj.stop() civil: stop
10:20:11.699 FINE: fmj.stop() civil: stop
10:20:11.710 FINE: fmj.stop() civil: stop
10:20:11.712 FINE: fmj.disconnect() civil: disconnect
10:20:11.714 FINE: fmj.stop() civil: stop

10:20:20.329 FINE: fmj.stop() civil: stop

=====================================
log with 2.6.27-11-generic #42 Ubuntu 9.04 updated+upgraded to 24 March 2009

10:38:19.370 FINE: fmj.addCaptureDevices() CaptureDevicePlugger: Added
civil:/dev/video0
10:38:19.377 INFO:
impl.media.device.DeviceConfiguration.extractConfiguredVideoCaptureDevice().186
Found civil:/dev/video0:0 as an RGB Video Device.
10:38:19.375 INFO:
impl.media.device.DeviceConfiguration.extractConfiguredCaptureDevices().145
Scanning for configured Video Devices.
10:38:19.377 INFO:
impl.media.device.DeviceConfiguration.extractConfiguredVideoCaptureDevice().186
Found civil:/dev/video0:0 as an RGB Video Device.
10:38:19.630 INFO: impl.media.MediaControl.createDataSource().582 Creating
datasource for:civil:/dev/video0
10:38:19.645 FINE: fmj.connect() civil: connect
10:38:19.649 FINE: fmj.connect() Opening /dev/video0
10:38:20.092 FINE: fmj.connect() civil: connect
10:38:20.783 FINE: fmj.start() civil: start
10:38:20.800 FINE:
impl.protocol.sip.OperationSetPresenceSipImpl.<init>().272 presence
initialized with :true, true, 30, 3600 for null
10:38:20.818 FINE: lti-civil.run() NativeCaptureStreamThread running
10:38:20.842 FINE: fmj.stop() civil: stop
10:38:42.506 FINE: fmj.connect() civil: connect
10:38:42.508 FINE: fmj.connect() Opening /dev/video0
10:38:42.533 FINE: fmj.start() civil: start
10:38:42.536 FINE: lti-civil.run() NativeCaptureStreamThread running
10:38:42.537 FINE: fmj.stop() civil: stop
10:38:42.830 FINE: fmj.stop() civil: stop
10:38:42.832 FINE: fmj.start() civil: start
10:38:50.585 FINE: fmj.stop() civil: stop
10:38:50.610 FINE: fmj.stop() civil: stop
10:38:50.611 FINE: fmj.stop() civil: stop
10:38:50.613 FINE: fmj.disconnect() civil: disconnect
10:38:50.614 FINE: fmj.stop() civil: stop
10:38:50.728 FINE: lti-civil.run() NativeCaptureStreamThread exiting
10:38:59.435 FINE: fmj.stop() civil: stop

Regards, Earl

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#3

Just to inform you: I saw similar problems and error messages
and a similar behaviour on my Linux openSuse 11.1 . The kernel
is a 2.26.27-21 default on a X86_64 CPU. I use the v4l2 packages
and ucv driver which supports my Philips NC 1030 WebCam.

I've opened an issue for SC, issue number #660 and also a video
problem running SC under XP, issue #659.

Regards,
Werner

Earl schrieb:

···

Hi,

this is to inform the SC devs of my bug report at:
https://bugs.launchpad.net/ubuntu/+bug/365979

here is the content of the bug report:

TEST: using SIP-COMMUNICATOR build 1864
with kernel 2.6.27-11-generic, as SIP-COMMUNICATOR loads into memory, it
searches for a video device which causes the Webcam LED to flash
quickly. Later under options, clicking on the media tab will activate
the Webcam and show local video in a window.

Upgrading to 9.04 results in kernel 2.6.28-11-generic breaking the video
capture. The Webcam LED does not flash on loading, nor does the Webcam
work after loading the program.

For both kernels, I have extracted all lines with the word civil from
the log files.
SIP-COMMUNICATOR is written in java and the video device is found at
civil:/dev/video0:0.

log with kernel 2.6.28-11-generic #42 Ubuntu 9.04 updated+upgraded to 24
March 2009
this kernel breaks java video capture, kernel 2.6.27-11-generic works ok

FINE: fmj.addCaptureDevices() CaptureDevicePlugger: Added civil:/dev/video0
10:19:40.816 FINEST: impl.media.device.JmfDeviceDetector.setupJMF().368
[exit] setupJMF
10:19:40.817 INFO:
impl.media.device.DeviceConfiguration.extractConfiguredCaptureDevices().106
Scanning for configured Audio Devices.
10:19:40.819 FINE:
impl.media.device.DeviceConfiguration.extractConfiguredCaptureDevices().118
Found 1 capture devices: [Ljavax.media.CaptureDeviceInfo;@16f3619
10:19:40.820 INFO:
impl.media.device.DeviceConfiguration.extractConfiguredCaptureDevices().137
Found JavaSound audio capture as an audio capture device.
10:19:40.820 INFO:
impl.media.device.DeviceConfiguration.extractConfiguredCaptureDevices().145
Scanning for configured Video Devices.
10:19:40.822 INFO:
impl.media.device.DeviceConfiguration.extractConfiguredVideoCaptureDevice().186
Found civil:/dev/video0:0 as an RGB Video Device.

10:19:41.481 INFO: impl.media.MediaControl.createDataSource().582
Creating datasource for:civil:/dev/video0
10:19:41.497 FINE: fmj.connect() civil: connect
10:19:41.500 FINE: fmj.connect() Opening /dev/video0

10:19:42.154 FINE: fmj.connect() civil: connect

10:19:43.261 FINE: fmj.start() civil: start
10:19:43.265 FINE: lti-civil.run() NativeCaptureStreamThread running
10:19:43.272 FINE: fmj.stop() civil: stop
10:19:43.282 FINER:
impl.configuration.ConfigurationServiceImpl.setProperty().153
net.java.sip.communicator.impl.protocol.sip.acc1240265069692.PROXY_PORT(
oldValue=5060, newValue=5060.
10:19:43.284 SEVERE: lti-civil.run() com.lti.civil.CaptureException:
fg2_startCapture failed: -1
com.lti.civil.CaptureException: fg2_startCapture failed: -1
   at com.lti.civil.impl.jni.NativeCaptureStream.threadMain(Native Method)
   at
com.lti.civil.impl.jni.NativeCaptureStream$NativeCaptureStreamThread.run(NativeCaptureStream.java:94)

10:19:43.285 FINE: lti-civil.run() NativeCaptureStreamThread exiting

10:20:04.094 FINE: fmj.connect() civil: connect
10:20:04.097 FINE: fmj.connect() Opening /dev/video0
10:20:04.212 FINE: fmj.start() civil: start
10:20:04.234 FINE: lti-civil.run() NativeCaptureStreamThread running
10:20:04.236 SEVERE: lti-civil.run() com.lti.civil.CaptureException:
fg2_startCapture failed: -1
com.lti.civil.CaptureException: fg2_startCapture failed: -1
   at com.lti.civil.impl.jni.NativeCaptureStream.threadMain(Native Method)
   at
com.lti.civil.impl.jni.NativeCaptureStream$NativeCaptureStreamThread.run(NativeCaptureStream.java:94)

10:20:04.237 FINE: lti-civil.run() NativeCaptureStreamThread exiting
10:20:04.239 FINE: fmj.stop() civil: stop
10:20:04.456 FINE: fmj.stop() civil: stop
10:20:04.458 FINE: fmj.start() civil: start
10:20:11.627 FINER:
impl.configuration.ConfigurationServiceImpl.setProperty().153
net.java.sip.communicator.impl.gui.main.configforms.ConfigurationFrame.width(
oldValue=653, newValue=653.
10:20:11.646 FINER:
impl.configuration.ConfigurationServiceImpl.setProperty().153
net.java.sip.communicator.impl.gui.main.configforms.ConfigurationFrame.height(
oldValue=550, newValue=550.
10:20:11.662 FINER:
impl.configuration.ConfigurationServiceImpl.setProperty().153
net.java.sip.communicator.impl.gui.main.configforms.ConfigurationFrame.x(
oldValue=367, newValue=367.
10:20:11.678 FINER:
impl.configuration.ConfigurationServiceImpl.setProperty().153
net.java.sip.communicator.impl.gui.main.configforms.ConfigurationFrame.y(
oldValue=25, newValue=25.
10:20:11.695 FINE: fmj.stop() civil: stop
10:20:11.699 FINE: fmj.stop() civil: stop
10:20:11.710 FINE: fmj.stop() civil: stop
10:20:11.712 FINE: fmj.disconnect() civil: disconnect
10:20:11.714 FINE: fmj.stop() civil: stop

10:20:20.329 FINE: fmj.stop() civil: stop

=====================================
log with 2.6.27-11-generic #42 Ubuntu 9.04 updated+upgraded to 24 March
2009

10:38:19.370 FINE: fmj.addCaptureDevices() CaptureDevicePlugger: Added
civil:/dev/video0
10:38:19.377 INFO:
impl.media.device.DeviceConfiguration.extractConfiguredVideoCaptureDevice().186
Found civil:/dev/video0:0 as an RGB Video Device.
10:38:19.375 INFO:
impl.media.device.DeviceConfiguration.extractConfiguredCaptureDevices().145
Scanning for configured Video Devices.
10:38:19.377 INFO:
impl.media.device.DeviceConfiguration.extractConfiguredVideoCaptureDevice().186
Found civil:/dev/video0:0 as an RGB Video Device.
10:38:19.630 INFO: impl.media.MediaControl.createDataSource().582
Creating datasource for:civil:/dev/video0
10:38:19.645 FINE: fmj.connect() civil: connect
10:38:19.649 FINE: fmj.connect() Opening /dev/video0
10:38:20.092 FINE: fmj.connect() civil: connect
10:38:20.783 FINE: fmj.start() civil: start
10:38:20.800 FINE:
impl.protocol.sip.OperationSetPresenceSipImpl.<init>().272 presence
initialized with :true, true, 30, 3600 for null
10:38:20.818 FINE: lti-civil.run() NativeCaptureStreamThread running
10:38:20.842 FINE: fmj.stop() civil: stop
10:38:42.506 FINE: fmj.connect() civil: connect
10:38:42.508 FINE: fmj.connect() Opening /dev/video0
10:38:42.533 FINE: fmj.start() civil: start
10:38:42.536 FINE: lti-civil.run() NativeCaptureStreamThread running
10:38:42.537 FINE: fmj.stop() civil: stop
10:38:42.830 FINE: fmj.stop() civil: stop
10:38:42.832 FINE: fmj.start() civil: start
10:38:50.585 FINE: fmj.stop() civil: stop
10:38:50.610 FINE: fmj.stop() civil: stop
10:38:50.611 FINE: fmj.stop() civil: stop
10:38:50.613 FINE: fmj.disconnect() civil: disconnect
10:38:50.614 FINE: fmj.stop() civil: stop
10:38:50.728 FINE: lti-civil.run() NativeCaptureStreamThread exiting
10:38:59.435 FINE: fmj.stop() civil: stop

Regards, Earl

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#4

Hi Lubo,

what command(s) can I use to find out more info on the internal Webcam type?

Regards, Earl

Lubomir Marinov wrote:

···

Hi Earl,

Thank you!

I just wanted to note though that they'll likely need more information
about your webcam because the MacBook with Apple iSight + Ubuntu 9.04
I'm running SIP Communicator on works for me like a charm.

Regards,
Lubo

On Fri, Apr 24, 2009 at 1:39 PM, Earl <Large.Files@gmx.net> wrote:
  

Hi,

this is to inform the SC devs of my bug report at:
https://bugs.launchpad.net/ubuntu/+bug/365979

here is the content of the bug report:[snip]
    
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#5

Hi Earl,

can you install "cheese" application and run it to test is camera working at all.
For info about the camera you can run command v4l-info as root.

Cheers
damencho

Earl wrote:

···

Hi Lubo,

what command(s) can I use to find out more info on the internal Webcam type?

Regards, Earl

Lubomir Marinov wrote:

Hi Earl,

Thank you!

I just wanted to note though that they'll likely need more information
about your webcam because the MacBook with Apple iSight + Ubuntu 9.04
I'm running SIP Communicator on works for me like a charm.

Regards,
Lubo

On Fri, Apr 24, 2009 at 1:39 PM, Earl <Large.Files@gmx.net> wrote:

Hi,

this is to inform the SC devs of my bug report at:
https://bugs.launchpad.net/ubuntu/+bug/365979

here is the content of the bug report:[snip]
    
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#6

Damian,

the command v41-info is "not found"v41*. Ran as root in terminal.
A search for v41* in my file system found nothing.

regards, Earl

Damian Minkov wrote:

···

Hi Earl,

can you install "cheese" application and run it to test is camera working at all.
For info about the camera you can run command v4l-info as root.

Cheers
damencho

Earl wrote:

Hi Lubo,

what command(s) can I use to find out more info on the internal Webcam type?

Regards, Earl

Lubomir Marinov wrote:

Hi Earl,

Thank you!

I just wanted to note though that they'll likely need more information
about your webcam because the MacBook with Apple iSight + Ubuntu 9.04
I'm running SIP Communicator on works for me like a charm.

Regards,
Lubo

On Fri, Apr 24, 2009 at 1:39 PM, Earl <Large.Files@gmx.net> wrote:

Hi,

this is to inform the SC devs of my bug report at:
https://bugs.launchpad.net/ubuntu/+bug/365979

here is the content of the bug report:[snip]

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#7

Hi,

you must install the package v4l-conf.

damencho

Earl wrote:

···

Damian,

the command v41-info is "not found"v41*. Ran as root in terminal.
A search for v41* in my file system found nothing.

regards, Earl

Damian Minkov wrote:

Hi Earl,

can you install "cheese" application and run it to test is camera working at all.
For info about the camera you can run command v4l-info as root.

Cheers
damencho

Earl wrote:

Hi Lubo,

what command(s) can I use to find out more info on the internal Webcam type?

Regards, Earl

Lubomir Marinov wrote:

Hi Earl,

Thank you!

I just wanted to note though that they'll likely need more information
about your webcam because the MacBook with Apple iSight + Ubuntu 9.04
I'm running SIP Communicator on works for me like a charm.

Regards,
Lubo

On Fri, Apr 24, 2009 at 1:39 PM, Earl <Large.Files@gmx.net> wrote:

Hi,

this is to inform the SC devs of my bug report at:
https://bugs.launchpad.net/ubuntu/+bug/365979

here is the content of the bug report:[snip]

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#8

Thanks for the help.

Cheese works just fine, however it would be nice if it could adjust the brightness
level.

# v4l-info

### v4l2 device info [/dev/video0] ###
general info
    VIDIOC_QUERYCAP
    driver : "uvcvideo"
    card : "Laptop_Integrated_Webcam_0.3M"
    bus_info : "0000:00:1d.7"
    version : 0.1.0
    capabilities : 0x4000001 [VIDEO_CAPTURE,STREAMING]

standards

inputs
    VIDIOC_ENUMINPUT(0)
    index : 0
    name : "Camera 1"
    type : CAMERA
    audioset : 0
    tuner : 0
    std : 0x0 []
    status : 0x0 []

video capture
    VIDIOC_ENUM_FMT(0,VIDEO_CAPTURE)
    index : 0
    type : VIDEO_CAPTURE
    flags : 0
    description : "YUV 4:2:2 (YUYV)"
    pixelformat : 0x56595559 [YUYV]
    VIDIOC_G_FMT(VIDEO_CAPTURE)
    type : VIDEO_CAPTURE
    fmt.pix.width : 352
    fmt.pix.height : 288
    fmt.pix.pixelformat : 0x56595559 [YUYV]
    fmt.pix.field : NONE
    fmt.pix.bytesperline : 704
    fmt.pix.sizeimage : 202752
    fmt.pix.colorspace : SRGB
    fmt.pix.priv : 0

controls
    VIDIOC_QUERYCTRL(BASE+0)
    id : 9963776
    type : INTEGER
    name : "Brightness"
    minimum : -64
    maximum : 64
    step : 1
    default_value : 0
    flags : 0
    VIDIOC_QUERYCTRL(BASE+1)
    id : 9963777
    type : INTEGER
    name : "Contrast"
    minimum : 0
    maximum : 95
    step : 1
    default_value : 0
    flags : 0
    VIDIOC_QUERYCTRL(BASE+2)
    id : 9963778
    type : INTEGER
    name : "Saturation"
    minimum : 0
    maximum : 100
    step : 1
    default_value : 64
    flags : 0
    VIDIOC_QUERYCTRL(BASE+3)
    id : 9963779
    type : INTEGER
    name : "Hue"
    minimum : -2000
    maximum : 2000
    step : 1
    default_value : 0
    flags : 0

### video4linux device info [/dev/video0] ###
general info
    VIDIOCGCAP
    name : "Laptop_Integrated_Webcam_0.3M"
    type : 0x1 [CAPTURE]
    channels : 1
    audios : 0
    maxwidth : 640
    maxheight : 480
    minwidth : 48
    minheight : 32

channels
ioctl VIDIOCGCHAN: Invalid argument

tuner
ioctl VIDIOCGTUNER: Invalid argument

audio
ioctl VIDIOCGAUDIO: Invalid argument

picture
    VIDIOCGPICT
    brightness : 32768
    hue : 32768
    colour : 41942
    contrast : 0
    whiteness : 0
    depth : 16
    palette : YUYV

buffer
ioctl VIDIOCGFBUF: Invalid argument

window
    VIDIOCGWIN
    x : 0
    y : 0
    width : 352
    height : 288
    chromakey : 0
    flags : 0
root@EL-Mini-9:~#

So it looks like the Webcam is working, but that there is a problem
still to be found.

Anyone have any ideas?

Regards, Earl

Damian Minkov wrote:

···

Hi,

you must install the package v4l-conf.

damencho

Earl wrote:

Damian,

the command v41-info is "not found"v41*. Ran as root in terminal.
A search for v41* in my file system found nothing.

regards, Earl

Damian Minkov wrote:

Hi Earl,

can you install "cheese" application and run it to test is camera working at all.
For info about the camera you can run command v4l-info as root.

Cheers
damencho

Earl wrote:

Hi Lubo,

what command(s) can I use to find out more info on the internal Webcam type?

Regards, Earl

Lubomir Marinov wrote:

Hi Earl,

Thank you!

I just wanted to note though that they'll likely need more information
about your webcam because the MacBook with Apple iSight + Ubuntu 9.04
I'm running SIP Communicator on works for me like a charm.

Regards,
Lubo

On Fri, Apr 24, 2009 at 1:39 PM, Earl <Large.Files@gmx.net> wrote:

Hi,

this is to inform the SC devs of my bug report at:
https://bugs.launchpad.net/ubuntu/+bug/365979

here is the content of the bug report:[snip]

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#9

I just noticed that with the latest build of SC, that I can now see video
preview in Linux Ubuntu 9.04.

Does this mean that the problem was found in SC and corrected?

Can I close the bug report on Ubuntu Launchpad?

Regards, Earl

Earl wrote:

···

Thanks for the help.

Cheese works just fine, however it would be nice if it could adjust the brightness
level.

# v4l-info

### v4l2 device info [/dev/video0] ###
general info
   VIDIOC_QUERYCAP
   driver : "uvcvideo"
   card : "Laptop_Integrated_Webcam_0.3M"
   bus_info : "0000:00:1d.7"
   version : 0.1.0
   capabilities : 0x4000001 [VIDEO_CAPTURE,STREAMING]

standards

inputs
   VIDIOC_ENUMINPUT(0)
   index : 0
   name : "Camera 1"
   type : CAMERA
   audioset : 0
   tuner : 0
   std : 0x0 []
   status : 0x0 []

video capture
   VIDIOC_ENUM_FMT(0,VIDEO_CAPTURE)
   index : 0
   type : VIDEO_CAPTURE
   flags : 0
   description : "YUV 4:2:2 (YUYV)"
   pixelformat : 0x56595559 [YUYV]
   VIDIOC_G_FMT(VIDEO_CAPTURE)
   type : VIDEO_CAPTURE
   fmt.pix.width : 352
   fmt.pix.height : 288
   fmt.pix.pixelformat : 0x56595559 [YUYV]
   fmt.pix.field : NONE
   fmt.pix.bytesperline : 704
   fmt.pix.sizeimage : 202752
   fmt.pix.colorspace : SRGB
   fmt.pix.priv : 0

controls
   VIDIOC_QUERYCTRL(BASE+0)
   id : 9963776
   type : INTEGER
   name : "Brightness"
   minimum : -64
   maximum : 64
   step : 1
   default_value : 0
   flags : 0
   VIDIOC_QUERYCTRL(BASE+1)
   id : 9963777
   type : INTEGER
   name : "Contrast"
   minimum : 0
   maximum : 95
   step : 1
   default_value : 0
   flags : 0
   VIDIOC_QUERYCTRL(BASE+2)
   id : 9963778
   type : INTEGER
   name : "Saturation"
   minimum : 0
   maximum : 100
   step : 1
   default_value : 64
   flags : 0
   VIDIOC_QUERYCTRL(BASE+3)
   id : 9963779
   type : INTEGER
   name : "Hue"
   minimum : -2000
   maximum : 2000
   step : 1
   default_value : 0
   flags : 0

### video4linux device info [/dev/video0] ###
general info
   VIDIOCGCAP
   name : "Laptop_Integrated_Webcam_0.3M"
   type : 0x1 [CAPTURE]
   channels : 1
   audios : 0
   maxwidth : 640
   maxheight : 480
   minwidth : 48
   minheight : 32

channels
ioctl VIDIOCGCHAN: Invalid argument

tuner
ioctl VIDIOCGTUNER: Invalid argument

audio
ioctl VIDIOCGAUDIO: Invalid argument

picture
   VIDIOCGPICT
   brightness : 32768
   hue : 32768
   colour : 41942
   contrast : 0
   whiteness : 0
   depth : 16
   palette : YUYV

buffer
ioctl VIDIOCGFBUF: Invalid argument

window
   VIDIOCGWIN
   x : 0
   y : 0
   width : 352
   height : 288
   chromakey : 0
   flags : 0
root@EL-Mini-9:~#

So it looks like the Webcam is working, but that there is a problem
still to be found.

Anyone have any ideas?

Regards, Earl

Damian Minkov wrote:

Hi,

you must install the package v4l-conf.

damencho

Earl wrote:

Damian,

the command v41-info is "not found"v41*. Ran as root in terminal.
A search for v41* in my file system found nothing.

regards, Earl

Damian Minkov wrote:

Hi Earl,

can you install "cheese" application and run it to test is camera working at all.
For info about the camera you can run command v4l-info as root.

Cheers
damencho

Earl wrote:

Hi Lubo,

what command(s) can I use to find out more info on the internal Webcam type?

Regards, Earl

Lubomir Marinov wrote:

Hi Earl,

Thank you!

I just wanted to note though that they'll likely need more information
about your webcam because the MacBook with Apple iSight + Ubuntu 9.04
I'm running SIP Communicator on works for me like a charm.

Regards,
Lubo

On Fri, Apr 24, 2009 at 1:39 PM, Earl <Large.Files@gmx.net> wrote:

Hi,

this is to inform the SC devs of my bug report at:
https://bugs.launchpad.net/ubuntu/+bug/365979

here is the content of the bug report:[snip]

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#10

Hey Earl,

I don't think there have been commits in the direction of fixing this
problem after you reported it.

Regards,
Lubo

···

On Mon, Apr 27, 2009 at 5:12 PM, Earl <Large.Files@gmx.net> wrote:

I just noticed that with the latest build of SC, that I can now see video
preview in Linux Ubuntu 9.04.

Does this mean that the problem was found in SC and corrected?

Can I close the bug report on Ubuntu Launchpad?

Regards, Earl

Earl wrote:

Thanks for the help.

Cheese works just fine, however it would be nice if it could adjust the
brightness
level.

# v4l-info

### v4l2 device info [/dev/video0] ###
general info
VIDIOC_QUERYCAP
driver : "uvcvideo"
card : "Laptop_Integrated_Webcam_0.3M"
bus_info : "0000:00:1d.7"
version : 0.1.0
capabilities : 0x4000001 [VIDEO_CAPTURE,STREAMING]

standards

inputs
VIDIOC_ENUMINPUT(0)
index : 0
name : "Camera 1"
type : CAMERA
audioset : 0
tuner : 0
std : 0x0 []
status : 0x0 []

video capture
VIDIOC_ENUM_FMT(0,VIDEO_CAPTURE)
index : 0
type : VIDEO_CAPTURE
flags : 0
description : "YUV 4:2:2 (YUYV)"
pixelformat : 0x56595559 [YUYV]
VIDIOC_G_FMT(VIDEO_CAPTURE)
type : VIDEO_CAPTURE
fmt.pix.width : 352
fmt.pix.height : 288
fmt.pix.pixelformat : 0x56595559 [YUYV]
fmt.pix.field : NONE
fmt.pix.bytesperline : 704
fmt.pix.sizeimage : 202752
fmt.pix.colorspace : SRGB
fmt.pix.priv : 0

controls
VIDIOC_QUERYCTRL(BASE+0)
id : 9963776
type : INTEGER
name : "Brightness"
minimum : -64
maximum : 64
step : 1
default_value : 0
flags : 0
VIDIOC_QUERYCTRL(BASE+1)
id : 9963777
type : INTEGER
name : "Contrast"
minimum : 0
maximum : 95
step : 1
default_value : 0
flags : 0
VIDIOC_QUERYCTRL(BASE+2)
id : 9963778
type : INTEGER
name : "Saturation"
minimum : 0
maximum : 100
step : 1
default_value : 64
flags : 0
VIDIOC_QUERYCTRL(BASE+3)
id : 9963779
type : INTEGER
name : "Hue"
minimum : -2000
maximum : 2000
step : 1
default_value : 0
flags : 0

### video4linux device info [/dev/video0] ###
general info
VIDIOCGCAP
name : "Laptop_Integrated_Webcam_0.3M"
type : 0x1 [CAPTURE]
channels : 1
audios : 0
maxwidth : 640
maxheight : 480
minwidth : 48
minheight : 32

channels
ioctl VIDIOCGCHAN: Invalid argument

tuner
ioctl VIDIOCGTUNER: Invalid argument

audio
ioctl VIDIOCGAUDIO: Invalid argument

picture
VIDIOCGPICT
brightness : 32768
hue : 32768
colour : 41942
contrast : 0
whiteness : 0
depth : 16
palette : YUYV

buffer
ioctl VIDIOCGFBUF: Invalid argument

window
VIDIOCGWIN
x : 0
y : 0
width : 352
height : 288
chromakey : 0
flags : 0
root@EL-Mini-9:~#

So it looks like the Webcam is working, but that there is a problem
still to be found.

Anyone have any ideas?

Regards, Earl

Damian Minkov wrote:

Hi,

you must install the package v4l-conf.

damencho

Earl wrote:

Damian,

the command v41-info is "not found"v41*. Ran as root in terminal.
A search for v41* in my file system found nothing.

regards, Earl

Damian Minkov wrote:

Hi Earl,

can you install "cheese" application and run it to test is camera
working at all.
For info about the camera you can run command v4l-info as root.

Cheers
damencho

Earl wrote:

Hi Lubo,

what command(s) can I use to find out more info on the internal Webcam
type?

Regards, Earl

Lubomir Marinov wrote:

Hi Earl,

Thank you!

I just wanted to note though that they'll likely need more
information
about your webcam because the MacBook with Apple iSight + Ubuntu 9.04
I'm running SIP Communicator on works for me like a charm.

Regards,
Lubo

On Fri, Apr 24, 2009 at 1:39 PM, Earl <Large.Files@gmx.net> wrote:

Hi,

this is to inform the SC devs of my bug report at:
https://bugs.launchpad.net/ubuntu/+bug/365979

here is the content of the bug report:[snip]

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net