[sip-comm-dev] Update the launcher


#1

Hi,

As said in a previous mail by Emil, I need to add some lines in the SC launcher.

I tried to print a line (System.out.println) or stop the program
(System.exit) but nothing is done.
I compile with : ant rebuild or ant make

Do you know why ? or a way to build the launcher ?

Thanks in advance

Damien

···

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net


#2

Ah, good point! Up till now we have always compiled the SIP Communicator launcher manually. The SIP Communicator Launcher is currently used from within the lib/sc-launcher.jar file that has been manually compiled. The point was to have it compiled with Java 1.4 so that it can run with older versions of Java and announce to users that they need Java 1.5 or later.

Still, there's no reason why we should have a target that would re-build it when necessary so you can send one over if you want. You can try it out in your own GSoC branch and if it works ok we'll commit it to SIP Communicator.

Cheers
Yana

Damien Roth wrote:

···

Hi,

As said in a previous mail by Emil, I need to add some lines in the SC launcher.

I tried to print a line (System.out.println) or stop the program
(System.exit) but nothing is done.
I compile with : ant rebuild or ant make

Do you know why ? or a way to build the launcher ?

Thanks in advance

Damien

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@sip-communicator.dev.java.net
For additional commands, e-mail: dev-help@sip-communicator.dev.java.net